Double trouble (long read)

AmigaOne X1000 platform specific issues related to Linux only.
User avatar
Posts: 716
Joined: Mon Mar 05, 2012 2:36 am

Re: Double trouble (long read)

Post by kilaueabart »

jdupuis wrote: My best advice ... is what I did for myself. First. Back up all your data. ... Make sure your CF Card set up and stable. In GParted, select your CF Card, pull down Devices from menu and create Partition Table - MS-DOS. Then make your CF Card 1 entire FAT32 partition ... If yours is 4 GB or less then use FAT16. I found that Kernel 4.1.20 works very well for both Ubuntu 12.04 LTS and Mate 16.04 LTS. Stop goofing with the USB stick for Mate.
Make sure your 12.04 Install is booting and stable. Download the 16.04 image to your Downloads Folder in 12.04. Unpack with 7 zip. Do a complete erase and reformat of the Hard Drive you will use for 16.04. Delete the FAT32 Partition. GParted should show "Unallocated". Now you will use Terminal to "sudo dd" the 16.04 .img to the Hard Drive. When it is done boot with the 4.1.20 Kernel and configure 16.04 as required. Then you will be able to go into System Updater and select [Partial Upgrade]. This should bring you to the new 16.04 release. This is what I did for myself. Note that I do not have Ubuntu installed on my AOS drive. ... I hope this helps you out.
I wish I had seen this before following your less detailed previous advice. I partitioned my 4 GB card as FAT32. I really doubt it will make a difference, but I will redo that shortly. Kernel 4.1.21 always worked well for both versions of Ubuntu, but I suppose I could find 4.1.20 and try it. In any event, vmlinux-4.1 in Cf0: worked fine for Ubuntu LTS 12.04 both before and after the reformatting. Why not MATE? Very mysterious.

As for "messing" with the USB stick, that was Christian's advice on how to install MATE to a hard drive, and it worked beautifully. I enjoyed an updated and partially upgraded MATE 16.04 for four days. The initial upgrade (Christian's advice was "sudo update, sudo upgrade") took about an hour, so it must have been pretty close to a full one, I would guess.
By the way, although I was pretty sure what the result would be, I just booted the USB drive version of MATE. So each install of MATE, one on a rotary hard drive, one on a solid state drive, and one on a USB drive, behave exactly the same. They get past the notices "Started CUPS Scheduler" and "Starting Plymouth Boot Screen," put up an early version of said screen, and stop.

I just found out how to view the log files, and next time I am in Ubuntu 12.04 I will take a look at the ends of the most recent MATE logs, and see what happened after "Starting Plymouth Boot Screen." (Not sure which log I want to look at, but with "tail -10 /var/log/..." I can look at them all.)

But GParted not being able to do some things to my SSD drives ("Unable to satisfy all constraints on the partition") is a major part of the problem. I may just retry the drive that came (I think) with the X1000, and that I replaced with the larger SSD. I thoughtit had gone bad but maybe it will work better?

I agree with you about Christian's help. He has always been very generous with responses to my problems. You're up there too. Thanks.


User avatar
Posts: 223
Joined: Sat May 09, 2015 7:19 am
Location: Baton Rouge, Louisiana USA

Re: Double trouble (long read)

Post by jdupuis »

Hi Bart,

The one liner about the USB stick was meant to be light but reading again I can see where it could read the wrong way. So Christian provided me the download links and the Terminal scripts to Download unpack and copy the Mate 16.04 Disc Image in 12.04. Here's the link to that thread: ... =35&t=3411

I had to tailor the copy instructions to fit me, though. Since I unpacked the ".img" in my 12.04 Downloads folder, in the Terminal I had to "cd Downloads" and "(sudo) dd if=Ubuntu-Mate_16.04-X1000-NI-2.img of=/dev/sdb" Note that sdb is the drive I used yours may differ.
You can leave your CF Card as FAT32 if you like, because I don't think that will make a difference but you never know. I'm having good success with FAT32. I'm thinking that GParted version might have something to do with the Kernel booting correctly in 12.04 but not 16.04. Leave it as FAT32. You might be surprised.


C= A500 2 megs RAM with A590 w/40 MB SCSI HD and Workbench 1.3
C= A3000 25 MHz with Workbench 3.1
AmigaOne X1000 4 GB RAM, XFX Radeon HD 6670 1GB GDDR5 GPU and AmigaOS 4.1 FE/Ubuntu 12.04.5 LTS/Ubuntu Mate 16.04 LTS
Sam460ex 2GB DDR2 800 MHz RAM, XFX Radeon HD 5450 2GB GDDR3 GPU, 3114 SATA Raid, ENVY24HT sound card and AmigaOS 4.1 FE

User avatar
Posts: 716
Joined: Mon Mar 05, 2012 2:36 am

Re: Double trouble (long read)

Post by kilaueabart »

Since I'm downloading yet another copy of the image, and the download counter says "49 m" -- well, it just changed to "57 m" -- I'll comment on where I stand.
I replaced the no-longer working SSD with a rotary hard drive I had kicking around, one that I thought I had removed because it went bad. It turned out to be 1TB,
all one partition, containing data. So I tried booting it, and up came another instance of 12.04! I couldn't log on properly, because I have forgotten the password,
and an attempt to change it per Christian's instructions seemed to work, until I rebooted and tried the new password. Well, I was able to get on as "Guest" anyway,
and the Ubuntu LST 12.04 that came up seemed solid. Except when I used Firefox to reread your last post above, I was not able to get out of Firefox.
No "x" to click on!

I booted the 12.04 just added to the replaced 500MB SSD and used GParted to redo the 1TB rotary guy. (After looking through viewtopic.php?f=35&t=3411 per your
suggestion, I realized that that drive must be the one out of my SAM 460. Why it had become one partition of 12.04 I don't remember.) Not having looked at that
thread yet, I thought that 1TB was a terrible waste for one little 16.04 install, and set up a much smaller partition, but after seeing Christian's suggestion to you
to use the whole thing, I went back and took the partition out. I am still puzzling over whether I need to format the drive before copying the image ("35m" to go)
to it, but I'll try it unformatted first.

Most of the instructions Christian gave you in that thread I can practically do with my eyes closed now, I have done them some many times. But one that I might
not have paid sufficient attention to is the bit about copying the image down and then unpacking with 7-zip. It has been my habit to accept the downloader's
offer to unpack it. I can't remember whether the file also gets saved, and I am not at all sure that it gets done with 7-zip. OK, if it doesn't work this time (but it
always has in the past) I'll just do it over.

I guess I probably won't find out today. "27m" to go on the download. I'll be busy with other things when it finishes and I may not have any more computer time
until tomorrow, maybe Thursday.

User avatar
Posts: 716
Joined: Mon Mar 05, 2012 2:36 am

Re: Double trouble (long read)

Post by kilaueabart »

As one would probably guess, I found a few times to take a break from my other chores and see if my freshly downloaded image might be better than the old ones.

My attempt to copy to my unformatted 1TB rotary drive had initially ambiguous results. There were indeed three new partitions, unlabled, but when I clicked on them I got
rather negative-sounding responses. Nonetheless, I rebooted and attempted to launch whatever might have been on the second partition, my guess at where the new 16.04 would be. To my delight, an Ubuntu was obviously coming up. My last two breaks to check on things, about an hour apart, both looked like this:

I wasn't really surprised but I had hoped the fresh image might make a difference.
I'm not sure what to try next. I'm looking through the logs, but I don't know enough about ubuntu or linux to make any real sense of them. I wonder if these two lines from kern.log will be as familiar to others as they are to me?
May 3 23:21:02 Amigaone kernel: EXT3-fs (sdb2): error: couldn't mount because of unsupported optional features (240)
May 3 23:21:02 Amigaone kernel: EXT2-fs (sdb2): error: couldn't mount because of unsupported optional features (240)
I always see those under the penguins when I boot any variety of Ubuntu.

I am hoping to eventually find some failure to put up the log-in tool on the screen pictured above. No particular reason to think it should be in kern.log, so I will continue my search, but these final lines of kern.log suggest to me that something -- no idea what -- wasn't going right:
May 3 23:21:02 Amigaone kernel: 8139too 0000:06:06.0 enp6s6: renamed from eth1
May 3 23:21:02 Amigaone kernel: pasemi_mac 0000:00:14.3 enp0s20f3: renamed from eth0
May 3 23:21:02 Amigaone kernel: cgroup: new mount options do not match the existing superblock, will be ignored
May 3 23:21:06 Amigaone kernel: IPv6: ADDRCONF(NETDEV_UP): sit0: link is not ready
May 3 23:21:06 Amigaone kernel: IPv6: ADDRCONF(NETDEV_UP): enp0s20f3: link is not ready
May 3 23:21:06 Amigaone kernel: IPv6: ADDRCONF(NETDEV_UP): enp6s6: link is not ready
May 3 23:21:06 Amigaone kernel: i8259_unmask_irq(5)
May 3 23:21:06 Amigaone kernel: 8139too 0000:06:06.0 enp6s6: link up, 100Mbps, full-duplex, lpa 0x45E1
May 3 23:21:06 Amigaone kernel: IPv6: ADDRCONF(NETDEV_UP): tunl0: link is not ready
May 3 23:21:07 Amigaone kernel: [drm:.cypress_dpm_set_power_state] *ERROR* rv770_restrict_performance_levels_before_switch failed

Post Reply