Kernel 4.5

AmigaOne X1000 platform specific issues related to Linux only.
User avatar
xeno74
Posts: 6317
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.5

Post by xeno74 »

Hi All,

I released the Alpha5 today. I compiled the AMDGPU driver as kernel module. I successfully tested it with SliTaz PPC Linux. With the following command I was able to start X11:

Code: Select all

Xfbdev -retro -mouse mouse,device=/dev/input/mice -keybd evdev,,device=/dev/input/event2 | xterm -e amiwm
Sometimes it works with event1 or with event0 etc.

If you want to connect your SliTaz via SSH then use the username amigaone with the password amigaone.

New: Linux Git log

FYI: Many PowerPC Changes Line Up For Linux 4.5 -- phoronix.com

Download: vmlinux-4.5-alpha5-AmigaONE_X1000.tar.gz

SliTaz PPC Linux with the Alpha5 of kernel 4.5:

Image

Cheers,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
ddni
Posts: 230
Joined: Fri Dec 02, 2011 11:06 pm

Re: Kernel 4.5

Post by ddni »

Hi I get the same black screen with both 4.5 Alpha1 and 4.5 Alpha5

CFE>boot -elf -noints -fatfs usbdisk0:vmlinux-4.5

My graphics card is R9 270x connected via hdmi
User avatar
mechanic
Posts: 510
Joined: Sat Jun 25, 2011 9:22 pm

Re: Kernel 4.5

Post by mechanic »

ddni wrote:Hi I get the same black screen with both 4.5 Alpha1 and 4.5 Alpha5
A list of code for the r9 270x;
radeon/pitcairn_ce.bin
radeon/pitcairn_mc.bin
radeon/pitcairn_me.bin
radeon/pitcairn_pfp.bin
radeon/pitcairn_rlc.bin
radeon/pitcairn_smc.bin
radeon/TAHITI_uvd.bin

I wonder if building both this code and the amdgpu code into the kernel could be problematic. :?
A-Eon A1X1000 ATI HD6850, Creative SB1570 PCIe, RTL8139 net PCI.
User avatar
ddni
Posts: 230
Joined: Fri Dec 02, 2011 11:06 pm

Re: Kernel 4.5

Post by ddni »

I powered down and tried again.

CFE> ramdisk -z -addr=0x24000000 -fs=iso atapi0.1:install/powerpc64/initrd.gz
CFE> setenv bootargs "root=/dev/ramdisk"
CFE> boot -elf -noints -fatfs usbdisk0:vmlinux-4.5

No black screen this time, but this and apparently a system freeze (waiting 10 minutes now)

Image
User avatar
xeno74
Posts: 6317
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.5

Post by xeno74 »

ddni wrote:I powered down and tried again.

CFE> ramdisk -z -addr=0x24000000 -fs=iso atapi0.1:install/powerpc64/initrd.gz
CFE> setenv bootargs "root=/dev/ramdisk"
CFE> boot -elf -noints -fatfs usbdisk0:vmlinux-4.5

No black screen this time, but this and apparently a system freeze (waiting 10 minutes now)
ddni,

Many thanks for testing. I am building the Alpha6 without AMDGPU firmwares and AMDGPU support.

Cheers,

Christian
Last edited by xeno74 on Tue Jan 19, 2016 3:51 pm, edited 1 time in total.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
ddni
Posts: 230
Joined: Fri Dec 02, 2011 11:06 pm

Re: Kernel 4.5

Post by ddni »

FYI I am using the netinst iso that mechanic pointed me to ( thanks for your help mechanic)
I have also tried kernal4.4 from here http://forum.hyperion-entertainment.biz ... 6&start=60
User avatar
xeno74
Posts: 6317
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.5

Post by xeno74 »

Here is the Alpha6 without AMDGPU firmwares and AMDGPU support: vmlinux-4.5-alpha6-AmigaONE_X1000.tar.gz :-)

PLEASE test the Alpha6.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
ddni
Posts: 230
Joined: Fri Dec 02, 2011 11:06 pm

Re: Kernel 4.5

Post by ddni »

Alpha6 gives me the same error.
I retried with a DSub output too. Same black screen.
User avatar
mechanic
Posts: 510
Joined: Sat Jun 25, 2011 9:22 pm

Re: Kernel 4.5

Post by mechanic »

@ddni
CFE> ramdisk -z -addr=0x24000000 -fs=iso atapi0.1:install/powerpc64/initrd.gz
CFE> setenv bootargs "root=/dev/ramdisk"
CFE> boot -elf -noints -fatfs usbdisk0:vmlinux-4.5
Try it without the ramdisk.

IF you installed it to /dev/sdb1 - Then try setenv bootargs "root=/dev/sdb1" - or where your root (/) directory is.

Once you get it to boot then you can install the modules (as root). You may wish to try the 4.1 kernel if you keep having boot problems.
Even the 3.19rc6 should work and it does have the code for your graphics card.

Got questions....Please ask.

Linux is like getting old,,,,,,,,,It ain't for sissy's.
Last edited by mechanic on Tue Jan 19, 2016 8:35 pm, edited 1 time in total.
A-Eon A1X1000 ATI HD6850, Creative SB1570 PCIe, RTL8139 net PCI.
User avatar
ddni
Posts: 230
Joined: Fri Dec 02, 2011 11:06 pm

Re: Kernel 4.5

Post by ddni »

do you mean to just get to cfe and enter:
CFE> boot -elf -noints -fatfs usbdisk0:vmlinux-4.5

All i have done is burn the iso to a cd which is in atapi.0.1 and extract the kernel archive to a usbstick which is in one of the front usb ports.
Do the commands
CFE> ramdisk -z -addr=0x24000000 -fs=iso atapi0.1:install/powerpc64/initrd.gz
CFE> setenv bootargs "root=/dev/ramdisk"
Persist after hard reboot?

I don't understand what you mean by /dev/sdb1. I havent installed anyting anywhere yet.
Post Reply