Kernel 4.4

AmigaOne X1000 platform specific issues related to Linux only.
User avatar
Srtest
Posts: 240
Joined: Wed Jun 11, 2014 5:06 pm

Re: Kernel 4.4

Post by Srtest »

I'm just thinking about stuff I suggested that need to be reverted (everything except input) because I can't boot. Maybe it isn't even about the amdgpu (which no one is using here right now and the issues much like the Pasemi are right now or the immidiate future for others) but rather about the way it was inserted. Maybe it is something else - we don't know. Would you like to know?

User avatar
xeno74
Posts: 5886
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.4

Post by xeno74 »

Srtest wrote:I'm just thinking about stuff I suggested that need to be reverted (everything except input) because I can't boot. Maybe it isn't even about the amdgpu (which no one is using here right now and the issues much like the Pasemi are right now or the immidiate future for others) but rather about the way it was inserted. Maybe it is something else - we don't know. Would you like to know?
Hi Srtest,

I have compiled the RC7 without AMDGPU support. Please test this kernel.

Download: vmlinux-4.4-rc7-without-AMDGPU-AmigaONE_X1000.tar.gz

Thanks in advance,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
Srtest
Posts: 240
Joined: Wed Jun 11, 2014 5:06 pm

Re: Kernel 4.4

Post by Srtest »

I doesn't work - no picture. The only thing changed is that I switched the HD5870 for a R9 270, so it must be a setting that has something to do with that, at least as far as the kernel is concerned. Maybe Virtio (CONFIG_DRM_VIRTIO_GPU=y).

User avatar
xeno74
Posts: 5886
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.4

Post by xeno74 »

Srtest wrote:I doesn't work - no picture. The only thing changed is that I switched the HD5870 for a R9 270, so it must be a setting that has something to do with that, at least as far as the kernel is concerned. Maybe Virtio (CONFIG_DRM_VIRTIO_GPU=y).
OK, I'll disable CONFIG_DRM_VIRTIO_GPU for the RC8.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5886
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.4

Post by xeno74 »

I have removed some source code from the Nemo patch for the following files:

Code: Select all

arch/powerpc/include/asm/device.h
arch/powerpc/include/asm/dma-mapping.h
include/asm-generic/dma-mapping-common.h
arch/powerpc/include/asm/iommu.h
All 4 files are dependent to each other.

After that I compiled the RC7 again and the P.A. Semi Ethernet interface is still working. That means the removed source code isn't responsible for the problem.

Here are the rest of the files which I need to solve the problem with the P.A. Semi Ethernet:

Code: Select all

arch/powerpc/Kconfig
arch/powerpc/kernel/dma.c
Fantastic!!! :-) There are only 2 files left. :-)

New Nemo patch: nemo_4.4-8.patch

Happy New Year!

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5886
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.4

Post by xeno74 »

Hi All,

I disabled the option CONFIG_DRM_VIRTIO_GPU in the kernel config and after that I compiled the RC8 with the new Nemo patch 4.4-8.

Download: vmlinux-4.4-rc8-AmigaONE_X1000.tar.gz

New:
Cheers,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5886
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.4

Post by xeno74 »

I have removed some source code from the Nemo patch for the file dma.c (arch/powerpc/kernel/dma.c). After that I compiled the RC8 again and the P.A. Semi Ethernet interface is still working. That means the removed source code isn't responsible for the problem.

New Nemo patch: nemo_4.4-9.patch

Our Nemo patch becomes smaller and smaller and I hope I can detect the problematic source code.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
Srtest
Posts: 240
Joined: Wed Jun 11, 2014 5:06 pm

Re: Kernel 4.4

Post by Srtest »

It's not working and this time I don't even get to the monitor blackout phase as the cfe firmware outputs a "I/O error".

Please remove everything that has to do with virtio as it didn't exist in RC3.

User avatar
xeno74
Posts: 5886
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.4

Post by xeno74 »

Srtest wrote:It's not working and this time I don't even get to the monitor blackout phase as the cfe firmware outputs a "I/O error".

Please remove everything that has to do with virtio as it didn't exist in RC3.
OK

@All

I have removed some source code from the Nemo patch for the file Kconfig (arch/powerpc/Kconfig). After that I compiled the RC8 again and the P.A. Semi Ethernet interface is still working. That means the removed source code isn't responsible for the problem.

New Nemo patch: nemo_4.4-10.patch
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5886
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.4

Post by xeno74 »

Our Nemo patch becomes smaller and smaller ...

nemo_4.4-11.patch
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

Post Reply