Kernel 4.4

AmigaOne X1000 platform specific issues related to Linux only.
User avatar
xeno74
Posts: 5886
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.4

Post by xeno74 »

I have removed the source code from the Nemo patch for the following file:

Code: Select all

arch/powerpc/kernel/dma-iommu.c
After that I compiled the RC6 again and the P.A. Semi Ethernet interface is still working. That means the removed source code isn't responsible for the problem.

Here are the rest of the files which I need to solve the problem with the P.A. Semi Ethernet:

Code: Select all

arch/powerpc/Kconfig
arch/powerpc/include/asm/device.h
arch/powerpc/include/asm/dma-mapping.h
arch/powerpc/include/asm/iommu.h
arch/powerpc/kernel/dma.c
arch/powerpc/sysdev/dart_iommu.c
include/asm-generic/dma-mapping-common.h
New Nemo patch: nemo_4.4-6.patch
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
Srtest
Posts: 240
Joined: Wed Jun 11, 2014 5:06 pm

Re: Kernel 4.4

Post by Srtest »

Srtest wrote:Works (and thanks :-). I have a conflict that can't be resolved between the binary AMD firmware and the basic Ubuntu linux firmware: linux-firmware linux-image-powerpc64-smp linux-powerpc64-smp
Well, the changes I suggested were under a previous GPU and the R9 270 doesn't boot at all with one or more of the changes I suggested:

___
# CONFIG_OF_OVERLAY (uncomment)

# CONFIG_DRM_CIRRUS_QEMU (uncomment)

CONFIG_DRM_AMDGPU=m (y instead of m)
___

Kernel rc3 works (without changes) and with rc4 I can't even get a picture after "boot... vmlinux", so the factor are likely one or more of those changes. Probably not the QEMU and CIRRUS.

I also tried to test a Radeon R9 380 and the power supply fitted with the X1000 couldn't cope with it - it starts to work and then stops out of power. I guess it is a beast. Right now I have a R9 270 and it booted LXQt ok with 4.4-rc3.

User avatar
xeno74
Posts: 5886
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.4

Post by xeno74 »

Srtest wrote:
Well, the changes I suggested were under a previous GPU and the R9 270 doesn't boot at all with one or more of the changes I suggested:

___
# CONFIG_OF_OVERLAY (uncomment)

# CONFIG_DRM_CIRRUS_QEMU (uncomment)

CONFIG_DRM_AMDGPU=m (y instead of m)
___

Kernel rc3 works (without changes) and with rc4 I can't even get a picture after "boot... vmlinux", so the factor are likely one or more of those changes. Probably not the QEMU and CIRRUS.

I also tried to test a Radeon R9 380 and the power supply fitted with the X1000 couldn't cope with it - it starts to work and then stops out of power. I guess it is a beast. Right now I have a R9 270 and it booted LXQt ok with 4.4-rc3.
Hi Srtest,

Many thanks for testing the kernels with your beasts. :-) Shall I remove CONFIG_OF_OVERLAY and compile AMDGPU (CONFIG_DRM_AMDGPU) as module for the RC7?

Merry Christmas. :-)

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
Srtest
Posts: 240
Joined: Wed Jun 11, 2014 5:06 pm

Re: Kernel 4.4

Post by Srtest »

If those are the only changes you made between rc3 and rc4 and rc4-2 then you should revert one (like the overlay option), let me test and then if needed change the other one instead and test again, because eventually it could effect multiple users.

User avatar
xeno74
Posts: 5886
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.4

Post by xeno74 »

Srtest wrote:If those are the only changes you made between rc3 and rc4 and rc4-2 then you should revert one (like the overlay option), let me test and then if needed change the other one instead and test again, because eventually it could effect multiple users.
Hi All,

I compiled the RC7 with the new Nemo patch 4.4-6 today. I removed the kernel config option CONFIG_OF_OVERLAY and I compiled AMDGPU (CONFIG_DRM_AMDGPU) as kernel module.

New:
Download: vmlinux-4.4-rc7-AmigaONE_X1000.tar.gz

Image

Cheers,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
Srtest
Posts: 240
Joined: Wed Jun 11, 2014 5:06 pm

Re: Kernel 4.4

Post by Srtest »

Srtest wrote:
Srtest wrote:Works (and thanks :-). I have a conflict that can't be resolved between the binary AMD firmware and the basic Ubuntu linux firmware: linux-firmware linux-image-powerpc64-smp linux-powerpc64-smp
Well, the changes I suggested were under a previous GPU and the R9 270 doesn't boot at all with one or more of the changes I suggested:

___
# CONFIG_OF_OVERLAY (uncomment)

# CONFIG_DRM_CIRRUS_QEMU (uncomment)

CONFIG_DRM_AMDGPU=m (y instead of m)
___

Kernel rc3 works (without changes) and with rc4 I can't even get a picture after "boot... vmlinux", so the factor are likely one or more of those changes. Probably not the QEMU and CIRRUS.

I also tried to test a Radeon R9 380 and the power supply fitted with the X1000 couldn't cope with it - it starts to work and then stops out of power. I guess it is a beast. Right now I have a R9 270 and it booted LXQt ok with 4.4-rc3.
Unfortunately I still can't even get a picture with a R9 270. Please try disabling # CONFIG_DRM_CIRRUS_QEMU and also Virtio if you enabled it.

User avatar
xeno74
Posts: 5886
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.4

Post by xeno74 »

Srtest wrote: Unfortunately I still can't even get a picture with a R9 270. Please try disabling # CONFIG_DRM_CIRRUS_QEMU and also Virtio if you enabled it.
OK, I will disable these for the RC8.

I have removed the source code from the Nemo patch for the following file:

Code: Select all

arch/powerpc/sysdev/dart_iommu.c
After that I compiled the RC7 again and the P.A. Semi Ethernet interface is still working. That means the removed source code isn't responsible for the problem.

Here are the rest of the files which I need to solve the problem with the P.A. Semi Ethernet:

Code: Select all

arch/powerpc/Kconfig
arch/powerpc/include/asm/device.h
arch/powerpc/include/asm/dma-mapping.h
arch/powerpc/include/asm/iommu.h
arch/powerpc/kernel/dma.c
include/asm-generic/dma-mapping-common.h
New Nemo patch: nemo_4.4-7.patch
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
Srtest
Posts: 240
Joined: Wed Jun 11, 2014 5:06 pm

Re: Kernel 4.4

Post by Srtest »

I've been thinking - maybe it is the added calls for AMDGPU firmwares? maybe it creates conflict for a GCN 1.0 card like the R9 270 (AMDGPU is for GCN 1.2) or just interferes somehow with its ability to read the normal drm driver. Perhaps you could also disable those so we can isolate the cause and as there is no one here who uses cards from the R9 3xx series.

User avatar
xeno74
Posts: 5886
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.4

Post by xeno74 »

Srtest wrote:Perhaps you could also disable those so we can isolate the cause and as there is no one here who uses cards from the R9 3xx series.
And how is it in the future?
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5886
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.4

Post by xeno74 »

I have an idea. I could compile two kernels 4.4. One with AMDGPU support/firmwares and one without these. What do you think?
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

Post Reply