(X)(L)ubuntu (MATE) 16.04 LTS

AmigaOne X1000 platform specific issues related to Linux only.
User avatar
xeno74
Posts: 6311
Joined: Fri Mar 23, 2012 7:58 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Post by xeno74 »

papaoskar wrote: Hi Christian,
that is the exact result: I don't need a password and can not login anymore. The password is not accepted. What now? Start from scratch with dd-ing the image and start all over ?
I think it will be the best.
I can only recommend to dd to a whole empty hard disk.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
Posts: 6311
Joined: Fri Mar 23, 2012 7:58 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Post by xeno74 »

papaoskar wrote:Hi Christian,
that is the exact result: I don't need a password and can not login anymore. The password is not accepted. What now? Start from scratch with dd-ing the image and start all over ?
I think it will be the best.
Could you please post the file attributes of /usr/bin/passwd? Maybe the suid bit is missing to modify /etc/passwd and /etc/shadow.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
Posts: 6311
Joined: Fri Mar 23, 2012 7:58 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Post by xeno74 »

Papaoskar,

Could you set a root password with passwd in the recovery mode?

Cheers,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
papaoskar
Posts: 80
Joined: Tue Jul 01, 2014 1:48 pm

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Post by papaoskar »

xeno74 wrote:Papaoskar,

Could you set a root password with passwd in the recovery mode?

Cheers,

Christian
Hi Christian,
currently I can do nothing anymore. Therefore I have to start from scratch.
Question: Do I better take the base or the full image?
Thank you so far.
Papaoskar
User avatar
xeno74
Posts: 6311
Joined: Fri Mar 23, 2012 7:58 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Post by xeno74 »

papaoskar wrote:
xeno74 wrote:Papaoskar,

Could you set a root password with passwd in the recovery mode?

Cheers,

Christian
Hi Christian,
currently I can do nothing anymore. Therefore I have to start from scratch.
Question: Do I better take the base or the full image?
Thank you so far.
Papaoskar
The full image is better.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
Posts: 6311
Joined: Fri Mar 23, 2012 7:58 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Post by xeno74 »

Please copy it to a whole empty hard disk.

For example:

/dev/sdb
/dev/sdc
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
papaoskar
Posts: 80
Joined: Tue Jul 01, 2014 1:48 pm

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Post by papaoskar »

xeno74 wrote:Please copy it to a whole empty hard disk.
For example:
/dev/sdb
/dev/sdc
Hi Christian,
I copied the 16GB stick with tree partitions to dev/sda8 which I formatted to ext4 before.
BTW, booting the stick did not work. Probably because I formatted the stick on a x86 system running lubuntu 16.04 . Also I dd'd the image to the stick on the same computer because it is a quadcore at 2.4 GHz and therefore faster. Question: Is it necessary to reduce the 16 GB partition on the stick to 8 GB? And dump the image to the 8GB partition?
Have a nice day.
User avatar
xeno74
Posts: 6311
Joined: Fri Mar 23, 2012 7:58 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Post by xeno74 »

papaoskar wrote:
xeno74 wrote:Please copy it to a whole empty hard disk.
For example:
/dev/sdb
/dev/sdc
Hi Christian,
I copied the 16GB stick with tree partitions to dev/sda8 which I formatted to ext4 before.
BTW, booting the stick did not work. Probably because I formatted the stick on a x86 system running lubuntu 16.04 . Also I dd'd the image to the stick on the same computer because it is a quadcore at 2.4 GHz and therefore faster. Question: Is it necessary to reduce the 16 GB partition on the stick to 8 GB? And dump the image to the 8GB partition?
Have a nice day.
I recommend a 32GB USB2 stick. Better is a 64GB USB2 stick.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
papaoskar
Posts: 80
Joined: Tue Jul 01, 2014 1:48 pm

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Post by papaoskar »

I have a 64 GB stick also. I will try that one.
User avatar
Amigo1
Posts: 221
Joined: Sun Jan 01, 2012 3:32 pm

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Post by Amigo1 »

xeno74 wrote:
Amigo1 wrote: oh.. I think it was rendering a web page in the background, this looks better:

Code: Select all

amigo1@Amigaone:~$ vblank_mode=0 glxgears
ATTENTION: default value of option vblank_mode overridden by environment.
5177 frames in 5.0 seconds = 1035.321 FPS
5249 frames in 5.0 seconds = 1049.660 FPS
4534 frames in 5.0 seconds = 906.673 FPS
5099 frames in 5.0 seconds = 1019.683 FPS
5362 frames in 5.0 seconds = 1072.320 FPS
4459 frames in 5.0 seconds = 891.770 FPS
5334 frames in 5.0 seconds = 1066.768 FPS
5370 frames in 5.0 seconds = 1073.874 FPS
5360 frames in 5.0 seconds = 1071.894 FPS
^C
amigo1@Amigaone:~$ 
Hi Amigo1,

Thank you for your reply. These are fantastic glxgears values for a Radeon HD5450. :-) Have you already tested the unofficial Mesa because of your VLC problem?

Cheers,

Christian
Hi Christian,

today I tested the unofficial Mesa, but I still get a uniform colored screen. (I restarted Ubuntu) See screen shots.
I could however play one .mov file. So I'm not sure the issue is with the video card (driver) anymore.

I sudo apt-get purge --auto-removed and reinstalled the ubuntu-restricted-extras to no avail.. What could it be?
Post Reply