Kernel 4.1

AmigaOne X1000 platform specific issues related to Linux only.
User avatar
musa
Posts: 412
Joined: Tue Aug 23, 2011 7:58 pm

Re: Kernel 4.1

Post by musa »

xeno74 wrote:I released the RC7-2 of kernel 4.1 today.

New:
  • Enabled all features of the EXT3 and EXT2 file systems
  • "SYSV-FS" file system
Download: vmlinux-4.1-rc7-2-Shys_Birthday_Edition-AMIGA_one_X1000.tar.bz2

This is a birthday present for Srtest. :-)
Ubuntu mate 15.04 boot with vmlinux-4.1-rc7-2
billede13-06-2015.png
Debian 8 boot with vmlinux-4.1-rc7-2
debian fail to load modules
The attachment billede13-06-2015.png is no longer available

Happy birthday to Srtest
AmigaX1000
Follow me on twitter @basjoo_dk

User avatar
xeno74
Posts: 5912
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.1

Post by xeno74 »

musa wrote: Ubuntu mate 15.04 boot with vmlinux-4.1-rc7-2
Skærmbillede-6.png
Debian 8 boot with vmlinux-4.1-rc7-2
debian fail to load modules
billede13-06-2015.png

Happy birthday to Srtest
Hi Musa,

Many thanks for testing the RC7-2. Could you post the error messages if you want to load the kernel modules, please? I'd like to know why the kernel modules don't load.

Thanks in advance.

Cheers,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
musa
Posts: 412
Joined: Tue Aug 23, 2011 7:58 pm

Re: Kernel 4.1

Post by musa »

xeno74 wrote: Hi Musa,

Many thanks for testing the RC7-2. Could you post the error messages if you want to load the kernel modules, please? I'd like to know why the kernel modules don't load.

Thanks in advance.

Cheers,

Christian
Hi
the error is
FAILED failed to start load kernel modules.
see 'systemctl status systemd-modules-load.service' for details.

And the output of 'systemctl status systemd-modules-load.service are:
● systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static)
Active: failed (Result: exit-code) since søn 2015-06-14 11:10:40 CEST; 15min ago
Docs: man:systemd-modules-load.service(8)
man:modules-load.d(5)
Process: 2182 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 2182 (code=exited, status=1/FAILURE)

Thk.
AmigaX1000
Follow me on twitter @basjoo_dk

User avatar
Srtest
Posts: 240
Joined: Wed Jun 11, 2014 5:06 pm

Re: Kernel 4.1

Post by Srtest »

Thank you for the wishes and of course also to Xeno who responded so quicklly and made me a surprise.

Unfortunatlly... This is what I get when trying to boot the latest Lubuntu on a BTRFS partition, positioned on a SSD with amiga partition table.

When trying to boot a regular EXT4 with the latest Lubuntu, enabling of the "sysv-fs" option on the kernel level didn't seem to effect the issues with SYSTEMD-SYSV.

Perhaps enabling all of the BTRFS options on the kernel level will help boot it?

Shy.
Attachments
20150614_214823.jpg

User avatar
xeno74
Posts: 5912
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.1

Post by xeno74 »

Srtest wrote:
Perhaps enabling all of the BTRFS options on the kernel level will help boot it?

Shy.
I'll enable all BTRFS options for the RC8 tomorrow.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5912
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.1

Post by xeno74 »

http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
Srtest
Posts: 240
Joined: Wed Jun 11, 2014 5:06 pm

Re: Kernel 4.1

Post by Srtest »

Thank you. Sorry to say I got the exact same messages with all of the BTRFS features enabled, so as of now I can't boot a Lubuntu on a BTRFS partition.

User avatar
musa
Posts: 412
Joined: Tue Aug 23, 2011 7:58 pm

Re: Kernel 4.1

Post by musa »

xeno74 wrote:I released the RC8 today.

New:
Download: vmlinux-4.1-rc8-AMIGA_one_X1000.tar.bz2
ubuntu_MATE_15.04_PPC_kernel_4.1-rc8_AMIGA_one_X1000.png
Hi
Debian 8 boot with vmlinux-4.1-rc8
Skærmbillede 15-06-2015.png
Still no modules loaded.
The boot screen says:
NEMO SB600 IOB base e0000000
drm:.btc_dpm_set_power_state *ERROR* rv770_restrict_performaance_levels_switch failed
no UART detected at 0x1
EXT3-fs (sdc6): error: couldn't mount because of unsupported optional features (240)
EXT2-fs (sdc6): error: couldn't mount because of unsupported optional features (240)
FAILED Failed to start Load Kernel Modules
See 'systemctl status systemd-modules-load.service' for details
systemd 1 : failed to start Load Kernel Modules

After that there is no more errors

Thanks.
AmigaX1000
Follow me on twitter @basjoo_dk

User avatar
xeno74
Posts: 5912
Joined: Fri Mar 23, 2012 7:58 am

Re: Kernel 4.1

Post by xeno74 »

musa wrote:
xeno74 wrote:I released the RC8 today.

New:
Download: vmlinux-4.1-rc8-AMIGA_one_X1000.tar.bz2
ubuntu_MATE_15.04_PPC_kernel_4.1-rc8_AMIGA_one_X1000.png
Hi
Debian 8 boot with vmlinux-4.1-rc8
Skærmbillede 15-06-2015.png
Still no modules loaded.
The boot screen says:
NEMO SB600 IOB base e0000000
drm:.btc_dpm_set_power_state *ERROR* rv770_restrict_performaance_levels_switch failed
no UART detected at 0x1
EXT3-fs (sdc6): error: couldn't mount because of unsupported optional features (240)
EXT2-fs (sdc6): error: couldn't mount because of unsupported optional features (240)
FAILED Failed to start Load Kernel Modules
See 'systemctl status systemd-modules-load.service' for details
systemd 1 : failed to start Load Kernel Modules

After that there is no more errors

Thanks.
Thank you! :-) Could you look in the section 'Kernel Modules' of 'HardInfo - System Information' if there are kernel modules loaded?
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
musa
Posts: 412
Joined: Tue Aug 23, 2011 7:58 pm

Re: Kernel 4.1

Post by musa »

xeno74 wrote:
Thank you! :-) Could you look in the section 'Kernel Modules' of 'HardInfo - System Information' if there are kernel modules loaded?
hi
It's empty . No modules loaded
AmigaX1000
Follow me on twitter @basjoo_dk

Post Reply