A1-X1000: 3dfx Voodoo4 4500 PCI test

AmigaOne X1000 platform specific issues related to Linux only.
Post Reply
User avatar
xeno74
Posts: 5891
Joined: Fri Mar 23, 2012 7:58 am

A1-X1000: 3dfx Voodoo4 4500 PCI test

Post by xeno74 »

I have installed a 3dfx Voodoo 4 4500 PCI (32 MB VRAM) in my A1-X1000. Unfortunately the CFE doesn't boot when a Voodoo is installed in a PCI slot. I have tried out with only the Voodoo and then with the AMD Radeon HD 6870 together.
voodoo4_pci_01.JPG
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
xeno74
Posts: 5891
Joined: Fri Mar 23, 2012 7:58 am

Re: A1-X1000: 3dfx Voodoo4 4500 PCI test

Post by xeno74 »

xeno74 wrote:I have installed a 3dfx Voodoo 4 4500 PCI (32 MB VRAM) in my A1-X1000. Unfortunately the CFE doesn't boot when a Voodoo is installed in a PCI slot. I have tried out with only the Voodoo and then with the AMD Radeon HD 6870 together.
voodoo4_pci_01.JPG
The A1-X1000 Linux kernels support some 3dfx Voodoo graphics cards but I suppose the CFE not. If I installed the Voodoo 4 then the CFE try to display on this card and it doesn't work and CFE can't boot. Can I boot my A1-X1000 with the AMD Radeon HD 6870 and then use the Voodoo graphics card with a special xorg.conf?

Could someone test the A1-X1000 with a Voodoo PCI graphics card, please?
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

User avatar
zappa2009
Posts: 230
Joined: Tue Jun 21, 2011 12:17 pm

Re: A1-X1000: 3dfx Voodoo4 4500 PCI test

Post by zappa2009 »

Ive testet with a Voodoo3 PCI but its the same CFE-Bug as with my Nvidia Quattro FX.

It hangs at the CFE Intitialtest at the Moment where normaly CFE aktivate the VGA-Subsystem. So my Friend we need an new CFE for it.
X1000 RadeonHD5450 4GB (2x2GB) DDR2-PC2-8500 Kingston HyperX 5-5-5-5-15 OS4.1.6 & Lubuntu13.04/mintppc11 with Kernel 3.8.7/3.9

User avatar
xeno74
Posts: 5891
Joined: Fri Mar 23, 2012 7:58 am

Re: A1-X1000: 3dfx Voodoo4 4500 PCI test

Post by xeno74 »

zappa2009 wrote:Ive testet with a Voodoo3 PCI but its the same CFE-Bug as with my Nvidia Quattro FX.

It hangs at the CFE Intitialtest at the Moment where normaly CFE aktivate the VGA-Subsystem. So my Friend we need an new CFE for it.
Thank you very much for testing with a Voodoo3 PCI. I don't understand the CFE bug. The CFE doesn't have to initialise the Voodoo3 PCI if an AMD Radeon HD is installed. Only the Linux kernel and X11 have to configure the Voodoo card.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.

Post Reply