Liinux Installation on X1000 kills hisself !

AmigaOne X1000 platform specific issues related to Linux only.
User avatar
zappa2009
Posts: 230
Joined: Tue Jun 21, 2011 12:17 pm

Re: Liinux Installation on X1000 kills hisself !

Post by zappa2009 »

Update.

I installed Debian Wheezy. And its boots fine. No More SelfKills.
I try mintppc11 on a other HD too.
X1000 RadeonHD5450 4GB (2x2GB) DDR2-PC2-8500 Kingston HyperX 5-5-5-5-15 OS4.1.6 & Lubuntu13.04/mintppc11 with Kernel 3.8.7/3.9

User avatar
zappa2009
Posts: 230
Joined: Tue Jun 21, 2011 12:17 pm

Re: Liinux Installation on X1000 kills hisself !

Post by zappa2009 »

mintppc11 works also fine. i use the wheezyy-dvd1 for the installation.

Any Tips for mount a amiga ffs on a cf read-write ? I can read for it but not write on.

C U
X1000 RadeonHD5450 4GB (2x2GB) DDR2-PC2-8500 Kingston HyperX 5-5-5-5-15 OS4.1.6 & Lubuntu13.04/mintppc11 with Kernel 3.8.7/3.9

User avatar
zappa2009
Posts: 230
Joined: Tue Jun 21, 2011 12:17 pm

Re: Liinux Installation on X1000 kills hisself !

Post by zappa2009 »

Finaly i solved my Problem. I replace the one 2GB-Module with two 1GB Module and Linmux boots everxtime fine up. Fryday i get more DDR2-Modules and test it all 4x2GB in my X1000 with Linux and of course AOS4.1.6 (only boot cause OS4.1.6 cant see more as 2GB)
X1000 RadeonHD5450 4GB (2x2GB) DDR2-PC2-8500 Kingston HyperX 5-5-5-5-15 OS4.1.6 & Lubuntu13.04/mintppc11 with Kernel 3.8.7/3.9

User avatar
zappa2009
Posts: 230
Joined: Tue Jun 21, 2011 12:17 pm

Re: Liinux Installation on X1000 kills hisself !

Post by zappa2009 »

Update:

I bekame my 2GB-Modules.

With 2x2GB everything is fine . Boot into Linux and OS4.1.6 ;)
X1000 RadeonHD5450 4GB (2x2GB) DDR2-PC2-8500 Kingston HyperX 5-5-5-5-15 OS4.1.6 & Lubuntu13.04/mintppc11 with Kernel 3.8.7/3.9

User avatar
trevordick
A-Eon Technology
A-Eon Technology
Posts: 1381
Joined: Mon Dec 20, 2010 1:28 pm

Re: Liinux Installation on X1000 kills hisself !

Post by trevordick »

Good to hear. :-)

Trevor
I'm just Breezin'

User avatar
Hypex
Beta Tester
Beta Tester
Posts: 432
Joined: Mon Dec 20, 2010 2:23 pm
Location: Vic. Australia.

Re: Liinux Installation on X1000 kills hisself !

Post by Hypex »

zappa2009 wrote:Do you use a CF inside in the X1000 to boot the Kernel ? or boot it with the FFS-Boot-Partition on the HDD.
Is this now possible? :-o If so could you tell me how to do it!? :-D

User avatar
zappa2009
Posts: 230
Joined: Tue Jun 21, 2011 12:17 pm

Re: Liinux Installation on X1000 kills hisself !

Post by zappa2009 »

Yep i can boot the Linux-Kernel AND amigaboot.of from the CF.

Format a CF as Fat32 and copy vmlinux-3.5.7 (or otherone) and amigaboot.of to it Use a external USB_CF-reader on a PC Amiga or Mac.
Insert the CF back to the X1000-CF slot.
Poweron and press f for the CFE-Prompt
Type dir -fs=fat cf0:
If you see your Files of the CF you can settup CFE to boot your AmigaOS4.1.6 AND Linux from it. Check out the Guides come with your X1000

I wrote for a Friend a CF setup-guide feel free for use it by yourself
  • CF-Card on X1000 Setup!

    Format a CF-Card on Windoof or Linux to Fat32
    I use DiskUtility on LinuxMint13

    HDD-Type: MasterBootRecord
    Bootflags: Bootable
    PartitionType: W95 FAT32 (0x0b)
    Filesystem: Fat16 or Fat32
    Label: cf (any name ou prefer)

    The copy the amigaboot.of to the CF-Card
    Perhabs the Linux-Kernel from your prefered Linux-Distribution

    Next Insert the Card to Your X1000 in the CF-Slot
    After Powerd on , Press F to CFE-Promt.

    Type dir -fs=fat cf0:
    If you see your files all is ok
    Type: setenv -p MENU_0_COMMAND “boot -fs=fat cf0:amigaboot.of“
    I change the Label From AmigaOS to AmigaOS-CF
    Todo this
    Type: setenv -p MENU_0_LABEL “AmigaOS-CF“

    Now You can boot without the BDH0: (FFS2) Partition.

    ( For Linuxboot checkt the Guide comming with your X1000 ;) )

    Have Fun.
X1000 RadeonHD5450 4GB (2x2GB) DDR2-PC2-8500 Kingston HyperX 5-5-5-5-15 OS4.1.6 & Lubuntu13.04/mintppc11 with Kernel 3.8.7/3.9

User avatar
Hypex
Beta Tester
Beta Tester
Posts: 432
Joined: Mon Dec 20, 2010 2:23 pm
Location: Vic. Australia.

Re: Liinux Installation on X1000 kills hisself !

Post by Hypex »

Wow thanks for the detailed explanation. But, I'm sorry and have realised I missed a word in my previous post. I meant to ask how to boot off an FFS partition! :-o That is, booting off an Amiga partition from the HD. That what it looked like you were asking before.

User avatar
zappa2009
Posts: 230
Joined: Tue Jun 21, 2011 12:17 pm

Re: Liinux Installation on X1000 kills hisself !

Post by zappa2009 »

Ty but boot from FFS is standart in OS4.1.6 in the X1000

Only amigaboot.of must be in the FFS-Partition of the HDD connected to sata0.
Because sata2 must be a CDrom.
CFE can boot from any filesystem it knows. FFS FAT32 EXT2 but not SFS1/2!

If you want boot Linux copy the Kernels to the FFS-Partition where amigaboot.of is.

And then Type boot -elf -noints -fs=amigafs ide0.1:vmlinux-3.5.7 Rename ide0.1: if your HDD is not connectet to sata0.
X1000 RadeonHD5450 4GB (2x2GB) DDR2-PC2-8500 Kingston HyperX 5-5-5-5-15 OS4.1.6 & Lubuntu13.04/mintppc11 with Kernel 3.8.7/3.9

daz
Beta Tester
Beta Tester
Posts: 318
Joined: Tue Dec 21, 2010 7:32 pm

Re: Liinux Installation on X1000 kills hisself !

Post by daz »

zappa2009 wrote: If you want boot Linux copy the Kernels to the FFS-Partition where amigaboot.of is.

And then Type boot -elf -noints -fs=amigafs ide0.1:vmlinux-3.5.7 Rename ide0.1: if your HDD is not connectet to sata0.
This will not work. vmlinux fails to start if booted from a FFS partition. It just hangs. Seems to be a bug in CFE. Best to stick to booting from fatfs.

Regards
Darren

Post Reply