Downgrading various MUI items to run WookieChat on X1000?

AmigaOne X1000 platform specific issues.
Post Reply
User avatar
amigasociety
Posts: 306
Joined: Thu Feb 02, 2012 7:09 pm
Location: Northern California
Contact:

Downgrading various MUI items to run WookieChat on X1000?

Post by amigasociety »

Running into an issue trying to install and run WookieChat 2.11 on my X1000.

Download from OS4Depot fine, installed fine, but during install it is showing various MUI Lib files that it wants to change, but the versions it wants to change to are LOWER and OLDER from 2008.

Is this acceptible to do?

I noticed the files it wants to change mine are newer from 2011 so I am afraid to make these changes.

Files like BetterString.mcc is the first one it wants to downgrade.

TJ
Happy owner of several Amiga systems including:

AmigaOne X5000
Amiga A1222 Tabor

User avatar
Slayer
Beta Tester
Beta Tester
Posts: 851
Joined: Tue Dec 21, 2010 4:19 am
Location: New Zealand

Re: Downgrading various MUI items to run WookieChat on X1000

Post by Slayer »

Hi amigasociety

Did you select Expert by any chance? Expert allows you to step through alot more choices when installing software where as novice or intermediate limit the user interaction, in short, the installer would have come across a more recent version of any said component and simply bypassed it (leaving it untouched) Expert allows you to override these defaults whether or not they are suitable or not, since of course you are an expert and know what you're doing - even experts generally just leave these alone and use it as feedback and extra insight into what the actual program is installing.

A summary:

Never install an older version of an MUI library or anything else for that matter, if the said program doesn't work because of a newer component then the actual program needs to be updated (in short don't use it) although I find it hard to believe it would do this since programs generally give the lowest requirement in regards to a necessary version (hence anything higher should be accepted) not an exact release version number.

If you did do this chances are something else already installed will not work.

This comes under "if it doesn't sound right, it is very likely it isn't right"
~Yes I am a Kiwi, No, I did not appear as an extra in 'Lord of the Rings'~
1x AmigaOne X5000 2.0GHz 2gM RadeonR9280X AOS4.x
3x AmigaOne X1000 1.8GHz 2gM RadeonHD7970 AOS4.x

User avatar
amigasociety
Posts: 306
Joined: Thu Feb 02, 2012 7:09 pm
Location: Northern California
Contact:

Re: Downgrading various MUI items to run WookieChat on X1000

Post by amigasociety »

I did novice mode.

I may try one of the others and see what happens.

TJ

Slayer wrote:Hi amigasociety

Did you select Expert by any chance? Expert allows you to step through alot more choices when installing software where as novice or intermediate limit the user interaction, in short, the installer would have come across a more recent version of any said component and simply bypassed it (leaving it untouched) Expert allows you to override these defaults whether or not they are suitable or not, since of course you are an expert and know what you're doing - even experts generally just leave these alone and use it as feedback and extra insight into what the actual program is installing.

A summary:

Never install an older version of an MUI library or anything else for that matter, if the said program doesn't work because of a newer component then the actual program needs to be updated (in short don't use it) although I find it hard to believe it would do this since programs generally give the lowest requirement in regards to a necessary version (hence anything higher should be accepted) not an exact release version number.

If you did do this chances are something else already installed will not work.

This comes under "if it doesn't sound right, it is very likely it isn't right"
Happy owner of several Amiga systems including:

AmigaOne X5000
Amiga A1222 Tabor

User avatar
amigasociety
Posts: 306
Joined: Thu Feb 02, 2012 7:09 pm
Location: Northern California
Contact:

Re: Downgrading various MUI items to run WookieChat on X1000

Post by amigasociety »

No luck, there is some issue.

Anyone here running WookieChat 2.11 on their X1000 that did not have to downgrade those MUI files?

If I let it downgrade, WookieChat works.

If I do not, it does not seem to like the newer MUI files and lib that gets swapped out.

The newer versions seems to allow WookieChat to launch but I can't connect to any IRC servers. It retries for ever and never connects. If I use the older 2008 files it swaps out, then it works fine.

I for now grabbed my backed-up copies and went back to the newer MUI and LIB files so I am up to date and just using AmIRC instead. 8-)

But, I would like to use WookieChat!

tj
Happy owner of several Amiga systems including:

AmigaOne X5000
Amiga A1222 Tabor

User avatar
Slayer
Beta Tester
Beta Tester
Posts: 851
Joined: Tue Dec 21, 2010 4:19 am
Location: New Zealand

Re: Downgrading various MUI items to run WookieChat on X1000

Post by Slayer »

How very odd

@jahc, come over here and sort this out ;)

Maybe you could manually copy the older mui libs to the wookie directory and reset the machine, if you're lucky it will load the libraries from Progdir: first before trying elsewhere

p.s. I'm sure I read something about Jahc updating his software for AmigaOS4.x, perhaps that isn't the latest version?

Anyway, sorry I couldn't help, even after all that winded insight :o :P
~Yes I am a Kiwi, No, I did not appear as an extra in 'Lord of the Rings'~
1x AmigaOne X5000 2.0GHz 2gM RadeonR9280X AOS4.x
3x AmigaOne X1000 1.8GHz 2gM RadeonHD7970 AOS4.x

User avatar
amigasociety
Posts: 306
Joined: Thu Feb 02, 2012 7:09 pm
Location: Northern California
Contact:

Re: Downgrading various MUI items to run WookieChat on X1000

Post by amigasociety »

The WookieChat installer also downgraded the Codesets.Library so my YAM stopped working at is needed 6.6 or above to work.

So, glad I keep backups of my system on an external USB drive to swap back to. :D

tj
Happy owner of several Amiga systems including:

AmigaOne X5000
Amiga A1222 Tabor

User avatar
sundown
Beta Tester
Beta Tester
Posts: 465
Joined: Mon Dec 20, 2010 10:38 pm
Location: California, USA

Re: Downgrading various MUI items to run WookieChat on X1000

Post by sundown »

amigasociety wrote:The WookieChat installer also downgraded the Codesets.Library so my YAM stopped working at is needed 6.6 or above to work.

So, glad I keep backups of my system on an external USB drive to swap back to. :D

tj
Jahc's web site is here http://wookiechat.amigarevolution.com/

Download v2.12 beta 15 for os4 off his beta page.
X1000 - Antec Solo case, 4GB DDR2 mem, XFX R9 270 gfx card, Plextor DVD, 2 Samsung 1TB F3 HDD, RTL-8139 network card, Cooler Master Silent Pro 600W PSU

User avatar
ChrisH
Beta Tester
Beta Tester
Posts: 915
Joined: Mon Dec 20, 2010 9:09 pm
Contact:

Re: Downgrading various MUI items to run WookieChat on X1000

Post by ChrisH »

Ah yeah, I am using v2.12 beta 11.

Post Reply