New graphics card

AmigaOne X1000 platform specific issues.
User avatar
musa
Posts: 458
Joined: Tue Aug 23, 2011 7:58 pm

Re: New graphics card

Post by musa »

I think I was a little quick.
Several 3d games like quake 1 ,hexen 2 and dslball work. Fce3d and ASG work but with graphics errors. Others still do not work. I think I must try to get rid of all 3d software driveres and then reinstall and check all files afterwards. I'll return
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
Raziel
Posts: 1015
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: New graphics card

Post by Raziel »

Can you give a link to those non-working 3d games/demos?

I hvae nearly the same setup as you (down to using DVI) but with a radeonhd 7970...if it doesn't work for me neither than it's again the port/game that is at fault.
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
kas1e
Beta Tester
Beta Tester
Posts: 506
Joined: Sat Jun 18, 2011 7:56 am
Contact:

Re: New graphics card

Post by kas1e »

@musa
For old 3d games that use old warp3d, you need to buy RadeonHD SI Warp3D drivers (they not in the enhancer package), so to have MiniGL things works (as minigl apps work through old warp3d too). Also be sure that for old games you use the original MiniGL library (from os4depot, or from update2 not so matter), and not minigl4gl4es.

For new 3d games that use warp3dnova/ogles2.library you need to buy the latest full Enhancer so to have:

RadeonHD 3.7
Warp3DNova 1.63
Ogles2.library 2.11

Versions are must be not less.

The list of "modern" 3d stuff is not a very big one at the moment, but there is:

games:
amicraft, barony, spencer, foobillardplus, frikingshark, neverball, hcraft, night of the zombies, prototype, supertuxkart, return to castle wolfenstein, pacman arena

sdks, libs and developer's tools:
irrlicht engine sdk, gl4es sdk, sdl2, glsnoop

apps:
shaderjoy, glsnoop
User avatar
musa
Posts: 458
Joined: Tue Aug 23, 2011 7:58 pm

Re: New graphics card

Post by musa »

kas1e wrote: Thu Jan 21, 2021 6:58 am @musa
For old 3d games that use old warp3d, you need to buy RadeonHD SI Warp3D drivers (they not in the enhancer package), so to have MiniGL things works (as minigl apps work through old warp3d too). Also be sure that for old games you use the original MiniGL library (from os4depot, or from update2 not so matter), and not minigl4gl4es.

For new 3d games that use warp3dnova/ogles2.library you need to buy the latest full Enhancer so to have:

RadeonHD 3.7
Warp3DNova 1.63
Ogles2.library 2.11

Versions are must be not less.

The list of "modern" 3d stuff is not a very big one at the moment, but there is:

games:
amicraft, barony, spencer, foobillardplus, frikingshark, neverball, hcraft, night of the zombies, prototype, supertuxkart, return to castle wolfenstein, pacman arena

sdks, libs and developer's tools:
irrlicht engine sdk, gl4es sdk, sdl2, glsnoop

apps:
shaderjoy, glsnoop
Thank you very much kas1efor your answer.
I was absolutely sure I bought and downloaded the latest drivers as well as the first warp3d.
I can see a difference between your version numbers and mine.
I do not know where to find the package that gives me the version numbers you have.
here are some of my files with version numbers:
warp3d
w3d_sl.library 1.14
wsd_radeon.library 53.23

warp3dnowa
warp3dnova.library 1.34
Ogles2.library 1.12

RadeonHD.chip 3.6

minigl.library 2.20

Many thanks for your help
Musa
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
musa
Posts: 458
Joined: Tue Aug 23, 2011 7:58 pm

Re: New graphics card

Post by musa »

Raziel wrote: Wed Jan 20, 2021 9:27 pm Can you give a link to those non-working 3d games/demos?

I hvae nearly the same setup as you (down to using DVI) but with a radeonhd 7970...if it doesn't work for me neither than it's again the port/game that is at fault.
Hi
I am starting to make a list of what works and does not work on my system.
I'll be back when I'm done
Thanks for your help
musa
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
Raziel
Posts: 1015
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: New graphics card

Post by Raziel »

@musa

Warp3D stuff is the same versions for me

Warp3DNova is commercial and part of the Enhancer package which you have to pay for extra.
I'd wait for Enhancer 2 where (hopefully) all of his stuff will be in one package.

MiniGL (2.24) you can update at os4depot.net
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
User avatar
musa
Posts: 458
Joined: Tue Aug 23, 2011 7:58 pm

Re: New graphics card

Post by musa »

Raziel wrote: Wed Jan 20, 2021 9:27 pm Can you give a link to those non-working 3d games/demos?

I hvae nearly the same setup as you (down to using DVI) but with a radeonhd 7970...if it doesn't work for me neither than it's again the port/game that is at fault.
Hi Raziel
I had recently bought and downloaded warpnova. I have purchased and downloaded the Enchancer software as well as the Enchancer Upgrade. installed it all but still my versions are not the right ones. I can see in Amistore that there are 3 Enchancer packages. Do you know which one is the right one?

Here is what i until now have testet
All can be found on os4depot
Programs/games that do not work
Amicraft_nova
cow3d6
Frikingshark
glsnoop-0.3
Gl_smoke
Hcraft
pacman05
Shaderjoy-1.7
Starboxdemo

programs/games that do work
all the demo in the folder demo from the packages minigl
cubebm
face3d (With some graphic error)
glexess
mesademo
warp-1.1
wings battlefield demo
sdl-ball
supertuxkart
Duknukem3d
Hexen2 (glhexen)
Glquake
ioquake3-r4
neverball-1.5.4
RTCW

Have a nice day
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
Raziel
Posts: 1015
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: New graphics card

Post by Raziel »

@musa

Nope, sorry, never got why there are so many differing packages (other than milking the users)

My advice, wait for enhancer 2, all the stuff you'll need (hopefully) in there.

And it's "due soon" since a few months already, so...make of that what you will ;-)
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
User avatar
musa
Posts: 458
Joined: Tue Aug 23, 2011 7:58 pm

Re: New graphics card

Post by musa »

Raziel wrote: Thu Jan 21, 2021 8:52 pm @musa

Nope, sorry, never got why there are so many differing packages (other than milking the users)

My advice, wait for enhancer 2, all the stuff you'll need (hopefully) in there.

And it's "due soon" since a few months already, so...make of that what you will ;-)
It is Plus Edition Version 1.5 released on 30th June 2019 for OS4 platform.
http://wiki.amiga.org/index.php?title=Enhancer_Software
60 pound.
I will wait and see what happens. I am reasonably happy with the result so far
AmigaX1000
Follow me on twitter @basjoo_dk
kas1e
Beta Tester
Beta Tester
Posts: 506
Joined: Sat Jun 18, 2011 7:56 am
Contact:

Re: New graphics card

Post by kas1e »

@musa
warp3dnowa
warp3dnova.library 1.34
Ogles2.library 1.12

RadeonHD.chip 3.6
Those ones are VERY OLD. Especially warp3dnova and ogles2. Nothing will works over them.
As i say minimum version is warp3dnova 1.62 (or 1.63 do not remember what last one in public) and ogles2.library 2.11

I suggest you to try to run Updater, if i remember right it should offer you much more updated warp3dnova, ogles2 and radeonhd chip (3.7 is MUST, or everythign will freezes).
Post Reply