X1000 and GL Apps

AmigaOne X1000 platform specific issues.
Post Reply
MagicSN
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 6
Joined: Sat Apr 16, 2011 2:26 pm

X1000 and GL Apps

Post by MagicSN »

Hi!

I still have the problem of running 3D Accelerated apps, which complain about "cannot open an OpenGL Window/Context". My guess is I need some 3D Drivers for the Radeon Board in the X1000. Can anybody point me towards some kind of FAQ or something on the issue? Not even the MiniGL Demos run. I am pretty sure I am doing something wrong (or more likely missing the installation of something which is required). minigl.library and Warp3D.library are all installed.

Thanks.

MagicSN

User avatar
Rigo
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 346
Joined: Mon Jan 17, 2011 9:42 pm

Re: X1000 and GL Apps

Post by Rigo »

There are no minigl drivers for the R700 series cards....yet.

Simon

User avatar
ChrisH
Beta Tester
Beta Tester
Posts: 915
Joined: Mon Dec 20, 2010 9:09 pm
Contact:

Re: X1000 and GL Apps

Post by ChrisH »

Note that if you want to use 2D games/apps which use Warp3D or MiniGL (typically ports), then you can try using the Wazp3D hack, which attempts to translate them into something that can be Composited (which is hardware accelerated & thus quite fast). Configuring Wazp3D is more than a bit of a pain (it's done on a per-program basis & annoyingly has no way to set defaults), but if you are motivated then you can probably work it out...

P.S. By default Wazp3D uses software rendering (very slow) rather than Compositing (fast). Don't ask me why!

Post Reply