Page 1 of 1

Video bus speed very low when using PCI Radeon 9250

Posted: Sun Dec 30, 2012 2:08 pm
by zzd10h
Hi,
I'm using a PCI Radeon 9250 128bits 256mB (only 128mB are recognized) to have Overlay and native Warp3D on my x1000.

I have tried to play a HD movie with this gfx card, it works but it's really worst than on my Peg2 AGP Radeon 9000Pro.

When I play this movie
http://mirrorblender.top-ix.org/peach/b ... rround.avi

In fullscreen and in window mode, I have 34% of skipped frames with DVPlayer verbose option (same % in fullscreen and window mode)

On the Peg2, I only have 2% of skipped frames.

With RageMem, the Video bus speed is very low (Read = 3 mB/sec, Write = 25 mB/sec) comparing to Peg2 (52 and 221)
I have tried it with 3 cards (2 9250 128bits and 1 9250 64bits) and the DVPlayer results are around the same for each...

http://zzd10h.amiga-ng.org/Divers/Radeo ... m_9250.jpg

Are they some parameters to speed up the video bus transfer rate on CFE or AmigaOS ?
Thank for your help.

Re: Video bus speed very low when using PCI Radeon 9250

Posted: Sun Dec 30, 2012 7:16 pm
by zzd10h
I have just tested to put the Radeon9250 on the Starteck PCI2PCIE adapter.
And it works very better.

For the same DVPlayer video
I just have, now 5% of skipped frames and 22 fps
(instead of 34% and 16 fps for the test directly on the PCI slot)

RageMem
Video Bus Read = 17 MB/s (instead of 3 MB/s directly on PCI slot)

Video Bus Write = 31 MB/s (instead of 25 MB/s directly on PCI slot)

http://zzd10h.amiga-ng.org/Divers/Radeo ... 0_PCIE.jpg

Unfortunately, I can't keep the 9250 on the Starteck adapter, the card is to much heavy

It's strange, that the PCI slot was so slow, no ?

Re: Video bus speed very low when using PCI Radeon 9250

Posted: Sun Dec 30, 2012 8:35 pm
by mechanic
Could be that PCI slots are 33MHz and Startech adaptor allows 66MHz.

Re: Video bus speed very low when using PCI Radeon 9250

Posted: Sun Dec 30, 2012 11:31 pm
by Evillord68
mechanic wrote:Could be that PCI slots are 33MHz and Startech adaptor allows 66MHz.
I think so, too.

Re: Video bus speed very low when using PCI Radeon 9250

Posted: Mon Dec 31, 2012 12:15 am
by zzd10h
Unfortunately, therefore nothing can be do
Excepting waiting for an overlay substitution...

But thank you, mechanic and Evillord68 for your replies.

Re: Video bus speed very low when using PCI Radeon 9250

Posted: Sat Jul 06, 2013 10:34 pm
by zzd10h
Is PCI speed will be increased on X1000 ?
According to this thread,
http://www.amigans.net/modules/xforum/v ... mpost76264

I don't understand,
Yes or No ?

Thanks for reply

Re: Video bus speed very low when using PCI Radeon 9250

Posted: Thu Jan 09, 2014 10:34 pm
by ddni
I hope so, but that thread is now old and still inconclusive.
Sad that x1000 is still slower with 9250 than ancient A-Ones.