Freespace running on X1000 with latest Warp3D

Post Reply
User avatar
Site Admin
Posts: 57
Joined: Mon Dec 20, 2010 2:05 pm
Location: Athens/Dublin

Freespace running on X1000 with latest Warp3D

Post by walkero »

When I tested the latest updated version of Freespace (v1.6) on my X1000 with RadeonHD R7 250X Gfx Card, I had a serious crashing problem. I tested it with hardware rendering (Warp3D) and crashed right after the Hyperion intro video. I tried the Software rendering, where it didn't crash, but the game colors where wrong, like opening a 16bit color big endian screen on 32bit screen (I met it on other software as well). Unfortunately the game is not playable on my system.

Today I decided to try previous versions of freespace, so I tried the v.1.2 beta3 which someone can find at fs_os4_upd.lha at the website of Hyperion, under download section. This version doesn't show the intro videos, probably because it doesn't find the hyperion video library, but the game is playable with no problems at the colors. Unfortunately, I don't know if it uses Warp3D or software rendering, but it is pretty fast. The only problem is that when you exit the game it doesn't close it's screen and seems that it freezes. Also, the launcher freezes the system at the joystick tab, so DO NOT SELECT IT.

So, is there a possibility for someone at the Hyperion to check both these versions and release a newer fixed version, that uses Warp3D and video play? I don't know if this is big time work, but it would be nice to have it. Also, is there a way to set it run on bigger screen resolution?

Thank you all for your time and help.
If you develop or want to develop for AmigaOS 4.x, then join us at
Post Reply