Graphics rendering bug

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.
Post Reply
User avatar
jostein_aarbakk
Beta Tester
Beta Tester
Posts: 37
Joined: Thu Aug 04, 2011 11:08 pm
Location: Norway

Graphics rendering bug

Post by jostein_aarbakk »

Description:
----------------
When scrolling a workbench-window (f.ex. MultiView) slowly in either direction, I see a "waving effect" on the screen, going from the top to the bottom.
The same thing happens with games (f.ex. WordMeUpXXL) in windowed mode, when the screen is scrolling.
This bug became present in update 3.

Observations that might help you during bugfixing:
-----------------------------------------------------------------
This happens when composition effects in workbench are enabled (Prefs->GUI, choose subsystem "Effects" and choose the flag "Enable" (Compositing effects)).

When I disable workbench composition effects, the rendering bug is gone.


Thanks in advance.

User avatar
jostein_aarbakk
Beta Tester
Beta Tester
Posts: 37
Joined: Thu Aug 04, 2011 11:08 pm
Location: Norway

Graphics rendering bug

Post by jostein_aarbakk »

I forgot to mention details of my system:
o ACube SAM440EP 667MHz (mini-ITX) with 512 MB RAM and onboard Radeon M9 gfx chip.
o Amiga OS4.1 update 4.

User avatar
m3x
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 11
Joined: Sat Jun 18, 2011 7:51 pm
Location: Bologna, Italy
Contact:

Re: Graphics rendering bug

Post by m3x »

This seems to be a problem with low video memory available.
How much free gfx ram do you have?
Max Tretene, ACube Systems Srl - Soft3

User avatar
jostein_aarbakk
Beta Tester
Beta Tester
Posts: 37
Joined: Thu Aug 04, 2011 11:08 pm
Location: Norway

Re: Graphics rendering bug

Post by jostein_aarbakk »

m3x wrote:How much free gfx ram do you have?
51 MB

Post Reply