Update2 - Boot Issues...

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.
Belxjander
Posts: 310
Joined: Mon May 14, 2012 10:26 pm
Location: 日本千葉県松戸市 / Matsudo City, Chiba, Japan
Contact:

Update2 - Boot Issues...

Post by Belxjander »

I've seen this on other forums as well...
However...

I've run into the problem of the Kickstart Logo being displayed and then failure to proceed past that point of booting.

I *am* aware of the hotfix yet don't know which archive to use (is it an updated download of the Update2, something else?)

This is about my 4th or 5th attempt at updating my system (regardless of hand-installing / formatting wiping and re-installing with the installer )

I am still stuck on the Update1 Kickstart modules and have yet to install any singular update2 Kickstart module at all without something breaking.

Any hints as to where I can get the hotfix to be applied after update2 would be appreciated!
User avatar
Raziel
Posts: 1021
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: Update2 - Boot Issues...

Post by Raziel »

The hotfix was since merged into update 2, so easiest way is to get the latest version 2 update from the known site and to do an update 1 then update 2 (Should be easy as you said you wiped your installation anyway, correct?).
No need to bother with any hotfix stuff now anymore.
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
User avatar
nbache
Beta Tester
Beta Tester
Posts: 1565
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: Update2 - Boot Issues...

Post by nbache »

Once you have installed Update 1 on top of 4.1 FE (best done by using the installer in the U1 archive directly), you can just let AmiUpdate do the rest, it will automatically detect that you need the full (fixed) update 2 and install it.

Likewise, if you had installed the first update 2 from December, it would see that you just need the hotfix and install that.

Best regards,

Niels
Belxjander
Posts: 310
Joined: Mon May 14, 2012 10:26 pm
Location: 日本千葉県松戸市 / Matsudo City, Chiba, Japan
Contact:

Re: Update2 - Boot Issues...

Post by Belxjander »

That would be nice...

I have the Update1 Kernel modules with a fully installed Update2 level of compatability for everything else,
I had to "hand repair" the Kickstart folder by copying the 4.1FE CD Kickstart content to the "SFS0"="SYS":Kickstart/ folder on my Harddisk,

AmiUpdate shows *nothing* to be updated...
and the Updater from the Enhancer package freezes once it shows that updates are avalable (and sits there unusable)

I have disabled the Ringhio server that I already heard was incompatible ( without change ).
I have tried individual updates of each Kernel module provided by update2 without any actual change.

all the update2 kernel modules appear to individually lockup the system once the kernel has finished being loaded.
without any progress past the "splash screen" image displaying the 4.1FE Boot logo.

the "updater" program also includes itself as needing to be updated as well.

I feel like Im beating my head against a brick wall.

the kernel modules are ALL available through the AmiUpdate tool? not the Updater tool?
I'm only seeing AmiSSL 4.7 and MUI updates through that at this time.
User avatar
nbache
Beta Tester
Beta Tester
Posts: 1565
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: Update2 - Boot Issues...

Post by nbache »

Updater is an A-Eon tool and has nothing to do with updates to the OS itself.

AmiUpdate is what we are talking about.

Regarding Update 2 and the hotfix, AmiUpdate uses version.library to determine what you already have installed.

It doesn't investigate whether you have made updates/downgrades of other modules manually.

So start with a clean installation of OS 4.1 Final Edition plus Update 1, then it can tell that you need Update 2 on top of that.

Trying to fix stuff by copying various versions of random modules back and forth is likely to end in a mess, so save yourself the trouble and do it like it's designed.

Best regards,

Niels
Belxjander
Posts: 310
Joined: Mon May 14, 2012 10:26 pm
Location: 日本千葉県松戸市 / Matsudo City, Chiba, Japan
Contact:

Re: Update2 - Boot Issues...

Post by Belxjander »

Okay...

Results ---
Hand-updating AmigaOS 4.1 Update1 -> Update2
Kernel module updates halt booting.

Using the Installer from 4.1U1 - > 4.1U2
Kernel module updates halt booting.

Use of AmiUpdate...
Shows "AmiSSL" and "MiniGL" updates (Before AND after having updated both already)
regardless of kernel module set installed... No kernel module updates get displayed.

Use of Updater (Enhancer)
SHows diskcache.library.kmod and other updates to be installed,
is unusable for downloading/installing those updates.
Having ***long***(count in hours) freezes between GUI updates, and actual halts of system activity.
Difficult to distinguish actual halts from freezing
User avatar
Raziel
Posts: 1021
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: Update2 - Boot Issues...

Post by Raziel »

I assume you don't have the possibility to hook your miggy up to a serial logger and provide that log?

Not sure if you already tried that, but maybe you can use a blank partition/HDD and install a mint AmigaOS4.1, then download and install Update 1 and then let AmiUpdate take care of Update 2?

It sounds like you still have some interfering stuff installed somewhere (maybe used through your user-startup or from WBStartup...
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Belxjander
Posts: 310
Joined: Mon May 14, 2012 10:26 pm
Location: 日本千葉県松戸市 / Matsudo City, Chiba, Japan
Contact:

Re: Update2 - Boot Issues...

Post by Belxjander »

Do you have any adapter cable for a BeagleBoneBlack or RaspberryPi to be used for exactly that purpose?

If I had such a cable for the BBB I would already be dumping logs for bootstrap xhci.usbhcd testing... instead of messing around with updates

And how can Startup-Sequence or WBstartup programs interfere when the initial boot shell (holding the control trigger) also fails?

Do I need to strip the sam440/sam460 fpga kmod and resource objects from the Kickstart Layout as interfering?

Would those fpga materials be replaceable at some future point in time?

or will the FPGA presence be forever just an unsupported gimmick?
User avatar
Raziel
Posts: 1021
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: Update2 - Boot Issues...

Post by Raziel »

And how can Startup-Sequence or WBstartup programs interfere when the initial boot shell (holding the control trigger) also fails?
It can't, then again neither can any of the updates, as far as I can understand.

It's beginning to sound a lot like hardware issues
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
User avatar
nbache
Beta Tester
Beta Tester
Posts: 1565
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: Update2 - Boot Issues...

Post by nbache »

You still haven't tried the most logical test to determine whether the problem is in the updates or in your setup:

Start from scratch - Clean 4.1 FE on a new partition, Update 1, Update 2.

Best regards,

Niels
Post Reply