Page 1 of 1

FE CD Not booting on SSAM440ep with ATI 9200 PCI GFX

Posted: Sun Jan 04, 2015 12:55 pm
by fastbit66
Dear Amiga Lovers!

I have a problem booting the AmigaOS 4.1 FE CD.
I have a SAM440ep with a ATI 9200 PCI GFX Card.
My on-board gfx is broken.
Everything ran fine with Update 6.
But if I try to boot the FE CD the system freezes
after loading a few seconds and showing the new Boot logo.

Can't get it to work. I had the same issue whwn I installed
Update 5 when it was released. The solution these days was to change
a setting in the nvram. But I can't remeber exactly any more waht it was :-(
Maybe I must set it back or something else because of the new gfx lib and subsystem???

Can someone give me a hint what to try?

Thanx in advanve for your time and help!

Best regards

Re: FE CD Not booting on SSAM440ep with ATI 9200 PCI GFX

Posted: Mon Jan 05, 2015 3:31 pm
by fastbit66

The uboot trick didn't work - couldn't find the radeon option.

But the way yoodoo2 described semmed to work. I could install and the system is booting
AmigaOS 4.1 FE. Even I had a lot of unassigned error messages during installation.

But now I have the same behaviour I had when installing update 5:
When WB is being loaded the system freezes compeletly. The resolution is ok and I can senn the vlome icons WB DH1 DH2 and RAM . In the middle of the screen I can senn a white square shape without any icons. This must be the window foe AMIStart. That's all. System completely frozen :-(
If I boot without startup-sequence thesystem starts.

Is there a way to tell at boot time to use radeon driver or is a setting in uboot (nvvar settings) incorrect?

Thanx a lot again!


Re: FE CD Not booting on SSAM440ep with ATI 9200 PCI GFX

Posted: Tue Jan 06, 2015 7:35 pm
by fastbit66
Hallo !

I got a bit further with the problem - but still no luck.

This is what I could figure out so far - but now I am lost..

I commented LoadMonDrvs out in startup-sequence.
Then the system starts with boot sound an everything else.
I looked into the screenmodes and there are only the lower vga modes listed.
That's ok because of not loading the drivers.

I can now open a shell and load the drivers with the command 'LoadMonDrvs'
That goes well and system still running ok.
Now when I go back to screenmode prefs van see all modes available up to 1920x1080

If I say 'test the mode 1920x1080' the mode switches to this resolution and shows the test pic
and the dialog saying 'if mode is ok click ok to save' . But this is it
System freezes completely - cannot even move the mouse anymore nor save the mode.

But I recognized two issues: My gfx board is named Board-0. Up to update 6 it was always named Radeon 9200 SE.
Second is in devs/montitors. I only can see a Monitor named NONE with almost anything disabled in the information tab. I tried to do auto-reconize monitor but this didn't help.

Have you any further ideas!

Thanx so much!