ABIT WPL-01 Airpace on sam460 (PCI-E 1x card)

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.
Post Reply
Godfather
Posts: 9
Joined: Sun Jun 26, 2011 12:24 am

ABIT WPL-01 Airpace on sam460 (PCI-E 1x card)

Post by Godfather »

Dear,

try today a WLAN PCi-e card to activate the atheros device. Version from 30.8.2013 - The WLAN Card is a ABIT WPL-01 Airpace. I use the sam460ex with the latest ubot and AOS 4.1.6

Unfortunately the card isn´t recognize - Ranger doesn´t show the card under PCI - the device can´t find a card. whats wrong ? please advise.

btw. the card works great in my abit pc under windows.

Kind Regards Godfather
Spectre660
Posts: 1499
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: ABIT WPL-01 Airpace on sam460 (PCI-E 1x card)

Post by Spectre660 »

Did you enable the PCIe x1 slot by the Jumper setting and uboot vairiable as explained in the Sam460ex manual page 8 ?
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
Godfather
Posts: 9
Joined: Sun Jun 26, 2011 12:24 am

Re: ABIT WPL-01 Airpace on sam460 (PCI-E 1x card)

Post by Godfather »

Yes, an PCIe soundcard works without any problems.

Kind Regards

Godfather
Spectre660
Posts: 1499
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: ABIT WPL-01 Airpace on sam460 (PCI-E 1x card)

Post by Spectre660 »

Check to see if the card is recognized by Uboot.
To do this get in to the Uboot Shell then type pci 03 and then enter key.
If the card is recognized then you should get a pciid.
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
Godfather
Posts: 9
Joined: Sun Jun 26, 2011 12:24 am

Re: ABIT WPL-01 Airpace on sam460 (PCI-E 1x card)

Post by Godfather »

... nothing ! no pci information.... seams that the uboot / sam460 have a timing problem during the init phase. is there a uboot command to increase the init phase ?

Kind Regards

Godfather
Godfather
Posts: 9
Joined: Sun Jun 26, 2011 12:24 am

Re: ABIT WPL-01 Airpace on sam460 (PCI-E 1x card)

Post by Godfather »

get the info from acube that the uboot doesn´t support some pcie bridge. the bridge of the abit is also not supported ! :-(
Spectre660
Posts: 1499
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: ABIT WPL-01 Airpace on sam460 (PCI-E 1x card)

Post by Spectre660 »

The supported bridges that I know work are the Pex 8112 and the ASM1083/1085 .
You may be able to use a Pex8112 pciex1 to PCI adapater and a PCI version wireless card.
Or use a a Wi-Fi ethernet Hub .

http://www.iogear.com/product/GWU647/
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
Post Reply