Black screen at boot time on a Sam460ex - Apple 27 minidp

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.
cdegraeve
Posts: 4
Joined: Sat Dec 29, 2012 7:12 pm

Black screen at boot time on a Sam460ex - Apple 27 minidp

Post by cdegraeve »

Amiga OS 4.1 (update 6 and radeonHD driver last release) boots fine when using the radeon's HDMI port connected to a Samsung TV (HD ready).

But... When using the exact same system with the mini display port connected to an Apple 27 display (mini displayport), I can see the firmware screen (in a purple color), then the "loading kickstart files" screen (in a purple color) and then... A (forever) black screen.

When using a DVI to mini display port converter (dual link Kanex C247DL), the monitor remains black at boot time, then i see the Amiga OS 4.1 logo (colors are fine), then... forever black again...

I tried the INTERRUPT=NO option in the monitor tooltypes but it does not fix the issue.

Thanks!

cdegraeve
Posts: 4
Joined: Sat Dec 29, 2012 7:12 pm

Re: Black screen at boot time on a Sam460ex - Apple 27 minid

Post by cdegraeve »

Same problem with a 24 inches Apple mini displayport.

User avatar
ZeroG
Posts: 119
Joined: Sat Jun 18, 2011 11:31 am
Location: Germany

Re: Black screen at boot time on a Sam460ex - Apple 27 minid

Post by ZeroG »

Did you try to disable DDC?
Im not sure if AOS supports screens larger than 1920x1200.

cdegraeve
Posts: 4
Joined: Sat Dec 29, 2012 7:12 pm

Re: Black screen at boot time on a Sam460ex - Apple 27 minid

Post by cdegraeve »

I'll try that. thx

User avatar
Hans
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 703
Joined: Tue Dec 21, 2010 9:25 pm
Location: New Zealand
Contact:

Re: Black screen at boot time on a Sam460ex - Apple 27 minid

Post by Hans »

Amiga OS 4.1 (update 6 and radeonHD driver last release) boots fine when using the radeon's HDMI port connected to a Samsung TV (HD ready).

But... When using the exact same system with the mini display port connected to an Apple 27 display (mini displayport), I can see the firmware screen (in a purple color), then the "loading kickstart files" screen (in a purple color) and then... A (forever) black screen.
Sorry, but DisplayPort is not supported by the RadeonHD driver.
When using a DVI to mini display port converter (dual link Kanex C247DL), the monitor remains black at boot time, then i see the Amiga OS 4.1 logo (colors are fine), then... forever black again...
Assuming that connecting a DVI monitor to the graphics card works fine, this is 100% the converter's fault.

I had a look at the reviews for the C247DL on Amazon, and 4 out of the 9 complain about it not working as it should. Some are complaining about black screens, being unable to use a screen > 1280x720. That doesn't sound promising.

Hans
http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more. Home of the RadeonHD driver for Amiga OS 4.x project.

User avatar
Hans
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 703
Joined: Tue Dec 21, 2010 9:25 pm
Location: New Zealand
Contact:

Re: Black screen at boot time on a Sam460ex - Apple 27 minid

Post by Hans »

ZeroG wrote:Did you try to disable DDC?
Im not sure if AOS supports screens larger than 1920x1200.
It does.

Hans
http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more. Home of the RadeonHD driver for Amiga OS 4.x project.

cdegraeve
Posts: 4
Joined: Sat Dec 29, 2012 7:12 pm

Re: Black screen at boot time on a Sam460ex - Apple 27 minid

Post by cdegraeve »

Sorry, but DisplayPort is not supported by the RadeonHD driver.
First of all, thanks for your reply.
Do you think the DisplayPort integration is on a to-do-list somewhere?
Assuming that connecting a DVI monitor to the graphics card works fine, this is 100% the converter's fault.

I had a look at the reviews for the C247DL on Amazon, and 4 out of the 9 complain about it not working as it should. Some are complaining about black screens, being unable to use a screen > 1280x720. That doesn't sound promising.
I saw the exact same reviews on Amazon.
You are right.

User avatar
Hans
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 703
Joined: Tue Dec 21, 2010 9:25 pm
Location: New Zealand
Contact:

Re: Black screen at boot time on a Sam460ex - Apple 27 minid

Post by Hans »

cdegraeve wrote:
Sorry, but DisplayPort is not supported by the RadeonHD driver.
First of all, thanks for your reply.
Do you think the DisplayPort integration is on a to-do-list somewhere?
It's on the to-do list, but down the bottom. For starters, I don't even have a DisplayPort (DP) capable monitor, although that isn't a show-stopper. The real reason for its low priority is that DVI/HDMI/VGA covers almost every monitor available, so we're better off focusing our effort on other features (e.g., 3D). Apple is the only manufacturer that I'm aware of that produces DP only monitors.

Hans
http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more. Home of the RadeonHD driver for Amiga OS 4.x project.

Benny
Posts: 59
Joined: Fri Nov 11, 2011 8:03 pm

Re: Black screen at boot time on a Sam460ex - Apple 27 minid

Post by Benny »

Hans wrote:
cdegraeve wrote:
Sorry, but DisplayPort is not supported by the RadeonHD driver.
First of all, thanks for your reply.
Do you think the DisplayPort integration is on a to-do-list somewhere?
It's on the to-do list, but down the bottom. For starters, I don't even have a DisplayPort (DP) capable monitor, although that isn't a show-stopper. The real reason for its low priority is that DVI/HDMI/VGA covers almost every monitor available, so we're better off focusing our effort on other features (e.g., 3D). Apple is the only manufacturer that I'm aware of that produces DP only monitors.

Hans
Hello Hans, any news on DisplayPort support ?

I'm asking this because DVI for my Samsung 4K-monitor, but it only does 30Hz @3840x2160 or does a DVI Duallink cable does 60Hz (?) anyone ?

User avatar
nbache
Beta Tester
Beta Tester
Posts: 1461
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: Black screen at boot time on a Sam460ex - Apple 27 minid

Post by nbache »

Benny wrote:I'm asking this because DVI for my Samsung 4K-monitor, but it only does 30Hz @3840x2160 or does a DVI Duallink cable does 60Hz (?) anyone ?
I am using a DVI-DL cable (and DVI-DL KVM) to display 2560×1600 from my Radeon HD 5450 on my 30" Dell. This is at 50 Hz. But I'm pretty sure you do at least need the DL cable. When I used regular DVI, I could not get more than 1920×1200@50Hz.

P.S. 3840×2160, huh? Seems I've been beaten on resolution ... but not on real size ;-).

Best regards,

Niels

Post Reply