USB MassStorage Issues with Android 4.0.1

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.
Post Reply
Belxjander
Posts: 302
Joined: Mon May 14, 2012 10:26 pm
Location: 日本千葉県松戸市 / Matsudo City, Chiba, Japan
Contact:

USB MassStorage Issues with Android 4.0.1

Post by Belxjander »

Has anyone else had the opportunity to connect an android phone with AmigaOS 4.1 update 6 or older?

I keep getting "blank events" where Workbench or the shell stop responding for up to 5mins before becoming usable again

I also have found I need to restart if the phone stops card reader mode for any reason

I also have PTP and MTP mode issues as well in that the USBFD will crash with my phone connected and repeatedly do so on connection attempts

Sam440flex with update 6 applied and no further updates

I am typing this message from my phone as that is the only connectivity I have

What questions can I answer first?
User avatar
SOFISTISOFTWARE
Posts: 44
Joined: Sat Jun 18, 2011 8:14 am
Location: Latina, Italy
Contact:

Re: USB MassStorage Issues with Android 4.0.1

Post by SOFISTISOFTWARE »

i had the opportunity to connect my IPhone 3G and my IPhone 5 in usb ports of my Sam460, but the AOS4.1 PTP protocol seems doesn't work with these devices. Is there any developer/betatester that could test that please ?
Sam 460EX, 2Gb Ram, Radeon R7 250E, OS4.1 FE
chris
Posts: 552
Joined: Sat Jun 18, 2011 11:05 am
Contact:

Re: USB MassStorage Issues with Android 4.0.1

Post by chris »

I've connected my Android 2.1 phone on a number of occasions, with no problems.
Post Reply