AOne500/SAM460 unstable after update 5 [Solved]

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.
morpa
Posts: 16
Joined: Sat Oct 27, 2012 9:53 am

Re: AOne500/SAM460 unstable after update 5

Post by morpa »

Yep!, and tried some more things (updated post). I'm beginning to think that my SAM460 is a stubborn one, and has decided not too work with kernel u5. :(
SAM460ex/1.15 GHz,Kingston 2 GB RAM DDR2 800 (PC2 6400),3.5 500 GB HDD Seagate st500dm0, DVD-RW Drive,SATA Controller SiI3114 PCI (4 ports),Amiga one keyboard and mouse, Radeon HD4650, 1 GB DDR2 VGA/DVI/HDMI

Spectre660
Posts: 1492
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: AOne500/SAM460 unstable after update 5

Post by Spectre660 »

Next question. What is the rating of your power supply ?. My Amigaone500 shipped with a 400W power supply ( I have since moved the motherboard into another case with a much stronger power supply).Also do yo ever have any problems BEFORE the computer loads kickstart ?

morpa
Posts: 16
Joined: Sat Oct 27, 2012 9:53 am

Re: AOne500/SAM460 unstable after update 5

Post by morpa »

The PSU is a http://www.lc-power.de/index.php?id=185&L=1 380w. (This is the default PSU the prev. owner got when he bought the SAM from Vesalia).

What PSU's do you other guys on this forum have? Maybe this is next thing to try then..

No, not any problems before kickstart are loaded.
SAM460ex/1.15 GHz,Kingston 2 GB RAM DDR2 800 (PC2 6400),3.5 500 GB HDD Seagate st500dm0, DVD-RW Drive,SATA Controller SiI3114 PCI (4 ports),Amiga one keyboard and mouse, Radeon HD4650, 1 GB DDR2 VGA/DVI/HDMI

Spectre660
Posts: 1492
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: AOne500/SAM460 unstable after update 5

Post by Spectre660 »

The Amigaone500's now come with a a 400W PSU.which is the minimum suggested for a Radeon HD4650.
I tend to do a bit of video card experimenting so I use PSU's of 600W and upwards in my full sized tower case.

morpa
Posts: 16
Joined: Sat Oct 27, 2012 9:53 am

Re: AOne500/SAM460 unstable after update 5

Post by morpa »

No luck with updated PSU (450w). (edited first post). :/
Sure, i can live with update 4,5, but i really would like to know what the problem is, now that i tried so many different things.
Do you know whats 'safe' to comment/disable from kickstart.layout?
SAM460ex/1.15 GHz,Kingston 2 GB RAM DDR2 800 (PC2 6400),3.5 500 GB HDD Seagate st500dm0, DVD-RW Drive,SATA Controller SiI3114 PCI (4 ports),Amiga one keyboard and mouse, Radeon HD4650, 1 GB DDR2 VGA/DVI/HDMI

Spectre660
Posts: 1492
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: AOne500/SAM460 unstable after update 5

Post by Spectre660 »

Could you post your Uboot settings here.

morpa
Posts: 16
Joined: Sat Oct 27, 2012 9:53 am

Re: AOne500/SAM460 unstable after update 5

Post by morpa »

nvgetvar gives

baudrate=115200
loads_echo=1
hostname=Sam460ex
stdout=vga
stdin=usbkbd
ide_doreset=on
ide_reset_timeout=15
ide_cd_timeout=20
pcie_mode=RP:RP
pciconfighost=1
ipaddr=192.168.2.50
serverip=192.168.2.222
bootcmd=menu; run menuboot_cmd
menucmd=menu
boot_method=boota
usb_enable_4x0=1
usb_retry=1
usb_ohci_power_down_before_reset=1
scan_usb_storage=1
ethact=ppc_4xx_eth0
ethaddr=00:50:c2:80:d5:27
menuboot_cmd=boota
video_activate=pci
hush=0
serdes=sata2
ver=U-Boot 2010.06.05a (Jan 30 2012 - 16:06:56)
boot1=s4sii
boot2=s4siicdrom
boot3=usb
boota_timeout=2
menuboot_delay=2
os4_commandline=debuglevel=0
bootargs=root=/dev/sda3 console=tty0
SAM460ex/1.15 GHz,Kingston 2 GB RAM DDR2 800 (PC2 6400),3.5 500 GB HDD Seagate st500dm0, DVD-RW Drive,SATA Controller SiI3114 PCI (4 ports),Amiga one keyboard and mouse, Radeon HD4650, 1 GB DDR2 VGA/DVI/HDMI

Spectre660
Posts: 1492
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: AOne500/SAM460 unstable after update 5

Post by Spectre660 »

only difference between mine and yours apart from the boot1,boot2 and boot3 is
Mine - os4_commandline=debuglevel 0
Yours - os4_commandline=debuglevel=0
no "=" in mine.
Dont think that this would cause an problem.
Another area to check would be the memory module.

Spectre660
Posts: 1492
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: AOne500/SAM460 unstable after update 5

Post by Spectre660 »

Another thing to check is you Harddrive partition info.
I use these for all my partition types
Blocksize=512
Buffers = 600
Maxtransfer =7FFFFFFF
Mask=FFFFFFFE

morpa
Posts: 16
Joined: Sat Oct 27, 2012 9:53 am

Re: AOne500/SAM460 unstable after update 5

Post by morpa »

Tried exprimenting with different buffers, using SFSQuery to look for good cache values. Tried DH1: with JXFS. Nope. (block,masks, buffers checked)
Then tried another harddrive. 2 partitions, 10 gb SFS, 40 gb jxfs.Nope. (block,masks, buffers checked)
SAM460ex/1.15 GHz,Kingston 2 GB RAM DDR2 800 (PC2 6400),3.5 500 GB HDD Seagate st500dm0, DVD-RW Drive,SATA Controller SiI3114 PCI (4 ports),Amiga one keyboard and mouse, Radeon HD4650, 1 GB DDR2 VGA/DVI/HDMI

Post Reply