Page 2 of 2

Re: PlayCD.

Posted: Mon Sep 03, 2012 2:49 pm
by acmn
graffias79 wrote:Hi, I took the liberty of capturing the output from the Amigaone 500's SM502 chip using the very latest SM502 sound driver and mixer, configured exactly as stated in the instructions for the new driver. Here is a download link to the .wav file I created. The song is pretty easily identifiable, and the distortion present should be immediately apparent.

http://www.filehosting.org/file/details ... Output.wav

Thanks,
Jamie
Yes, sound in my AO500 is distorted very much the same way.
The distortion is even more prominent when listening the 4th
symphony of Ludwig van...MK

Re: PlayCD.

Posted: Mon Sep 03, 2012 10:24 pm
by tonyw
Could someone put that file somewhere accessible? I'm not going to sign up to their site just for the purpose.

You could email it to me: wyattaw at optusnet com au.

Re: PlayCD.

Posted: Tue Sep 04, 2012 7:06 am
by Petrol
I don't have a Sam and can't really help, but have you tried to lower your sound preferences in AHI?

Regards,
Xavier.

Re: PlayCD.

Posted: Tue Sep 04, 2012 11:52 am
by graffias79
Sorry I didn't realize that stupid site made people sign up to download. Just ask if you don't want to sign up and I'll e-mail it. I just sent it to you Tony.

Also, changing the settings in AHI do nothing or in some cases make the sound much worse.

Re: PlayCD.

Posted: Tue Sep 04, 2012 8:36 pm
by HKvalhe
Hello :) I might help here. I actually got PlayCD working. The following things were done:

If you have CodeAudio (the MP3 Lame encoder program), you might find the CDDB.library very easily. If not copied into SYS:LIBS already, then do so. I have both that and CDPlayer.library installed (last one found
at OS4Depot.net). Now go to SYS:Utilities where PlayCD is, right-click its' icon, go into the Tool-editing part of it and remove the quotes relating to AHI. We want PlayCD to use AHI, so enable that by removing the quotes.
It might be a wise idea to also remove the quotes related to using CDDB, now that if you have copied the library to SYS:LIBS, that's it. As i have an AmigaOne 500 myself, i also enabled UNIT=0 instead of 2 by removing the quotes there, too. You might wonder, why 0 and not 2? Well, 0 if i am not mistaken, uses the Music Unit of your audio system, so i thought that could be a good idea. That's all you need to do. All these things, then SAVE, and VOILA!

Test some CDs and see. They should play with music now. Hope this was helpful. 8-) :)