Page 2 of 3

Re: AmigaOne 500 issues

Posted: Thu Aug 16, 2012 10:18 pm
by xe800
Spectre660 wrote: For the SII3114 cards with only two devices attached if you set the uboot variables to indicate this on boot up
you should not get a time out . The Uboot settings look something like this

sii3114ide_timeout=5
sii3114ide_conf=1002
sii3114ide_xfer=G00F
Can you elaborate on how I do this? I don't really know what those commands mean, or where to type them.

Re: AmigaOne 500 issues

Posted: Thu Aug 16, 2012 10:38 pm
by ssolie
xe800 wrote:Can you elaborate on how I do this? I don't really know what those commands mean, or where to type them.
Actually, if you use 4.1 Update 5 you don't need to worry about any of those variables. The defaults (no variables) should work for you just fine.

Re: AmigaOne 500 issues

Posted: Thu Aug 16, 2012 11:10 pm
by xe800
I still get this:

SATA 0 - OK
SATA 1 - OK
SATA 2 - .......... *timeout'

... and thats what I want to get rid of.

Re: AmigaOne 500 issues

Posted: Thu Aug 16, 2012 11:24 pm
by K-L
Regarding Flare :

Flare is slow, really slow, even on AmigaOne G4 1,26 Ghz. It lacks optimizations unfortunately. You can improe things if you deactivate the double buffering and if you play in 640x480.

Re: AmigaOne 500 issues

Posted: Fri Aug 17, 2012 12:51 am
by tonyw
@xe800:

The "1002" code means:

1: HDD connected to port 0
0: nothing on port 1
0: nothing on port 2
2: a CD-ROM drive on port 3.

I would guess that you don't have cables connected to SATA 0 and 3. As Steven said, you don't need the variables at all, it only forces the driver to use specific information (so that you can disable particular devices, for instance).

Try setting "sii3114ide_conf" to null and let the driver sort it out itself. Use the command "nvsetvar sii3114ide_conf" in a Shell.

If you look in Documentation/IDE/sii3114ide_dev.doc, you will find this all explained.

Re: AmigaOne 500 issues

Posted: Fri Aug 17, 2012 6:56 pm
by xe800
Typing "nvsetvar sil3114ide_conf" made no change.

If I have 2x harddisks and a DVDrom I should type "nvsetvar sil3114ide_conf=1102"?

Re: AmigaOne 500 issues

Posted: Fri Aug 17, 2012 10:13 pm
by ssolie
xe800 wrote:I still get this:

SATA 0 - OK
SATA 1 - OK
SATA 2 - .......... *timeout'

... and thats what I want to get rid of.
Ah, that's a UBoot thing. Nothing to do with AmigaOS.

Anybody from ACube around that can help figure this out?

Re: AmigaOne 500 issues

Posted: Sat Aug 18, 2012 11:02 am
by ChrisH
xe800 wrote:performance in Flare. This is a 2D game, right? Then why is it so slow? To get the proper runspeed of the character I control, I must play in 640x480, anything higher and animation slows down. Is it just a badly optimized port
I would suspect that Flare is just a badly optimised port. The AmigaOne 500 is quite a decent machine (it should be way better than my Sam440 in general).

Re: AmigaOne 500 issues

Posted: Sat Aug 18, 2012 11:22 am
by kas1e
By the way, on pegasos2 Flare plays very well and pretty smooth. Sometime ago i port python version of AlienBreed, which based on PyGame (there is a link for test, and there is a youtube video to show the speed of the same code on pegasos2), and as you can notice on pegasos2 it shows pretty nice results, while on all the sams it was kind of slideshow (and if i remember right some other PyGame based games (like Mobius Skyes) have such kind of problems). By all of this i mean that while Sam460 are new one, there is something wrong/slow happens , and some apps / games sometime, seems so, need some special optimisation (or some specific flags for gcc, dunno), expectually for sams. Sure we can easy say "port is bad optimised", but i feel there is something else, which sometime in some conditions, give much worse results on sams as it should do. Not sure if it lacking of altivec, but sure it can be something about cache sizes.

Re: AmigaOne 500 issues

Posted: Sat Aug 18, 2012 1:45 pm
by samo79
@kas1e

Yes exactly these 2 games are slow, all the other Py based games still quite playable even on slower Sam440 machines, so it seems there are somethings strange on them