First keyboard press eaten...

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.
Spectre660
Posts: 1494
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: First keyboard press eaten...

Post by Spectre660 »

What usb port are you using ?

I am using the right rear port .
On this is a 4 port hub to which is connected a ps/2 keyboard and mouse to usb adaptor.
trixie wrote:
Spectre660 wrote:Its is gone with U-Boot 1.3.1d on a Sam flex.
It is still there on my Sam440ep. I have U-Boot 1.3.1d and Update2 installed (uhci.usbhcd V53.7).

User avatar
ssolie
Beta Tester
Beta Tester
Posts: 1010
Joined: Mon Dec 20, 2010 8:51 pm
Location: Canada
Contact:

Re: First keyboard press eaten...

Post by ssolie »

cha05e90 wrote:I suppose this one might already reported somewhere, so just for the record: On my SAM440ep (mini), UBoot 1.3.1b, the first keyboard press (A-Eon AmigaOne USB keyboard) after booting OS4.1 Update 2 is "eaten"/ignored.
This was a USB software issue and has been fixed.
ExecSG Team Lead

User avatar
abalaban
Beta Tester
Beta Tester
Posts: 456
Joined: Mon Dec 20, 2010 2:09 pm
Location: France
Contact:

Re: First keyboard press eaten...

Post by abalaban »

This was a USB software issue and has been fixed.
For my own I'm using a PS/2 keyboard and I have had the issue on my A1XEG4 since as long as I can remember. Note that in fact that's not really the first keyboard that'is eaten but I suspect the first input.device event related to keyboard (and mouse? but it's more difficult to spot) as moving the mouse prior any keyboard press will solve the problem for me.
AmigaOne X1000 running AOS 4 beta
AmigaOne XE/G4
Amiga 1200/PPC 603e + BVision PPC

afxgroup
Beta Tester
Beta Tester
Posts: 17
Joined: Sun Jun 19, 2011 1:15 pm

Re: First keyboard press eaten...

Post by afxgroup »

ssolie wrote: This was a USB software issue and has been fixed.
Sadly i must admit that sometimes it still happens also on my A1XE with a PS2 Keyboard. I told this also to max yesterday night. I will report it in bugzilla this evening.

User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 1433
Joined: Wed Mar 09, 2011 1:36 pm
Location: Sydney, Australia

Re: First keyboard press eaten...

Post by tonyw »

I can lose the first keypress on my A1-XE using a PS/2 keyboard. It usually happens after a really bad crash, that locks up the machine and requires a case reset. In that case I can be sure that the first keypress is going to be lost.

Using USB keyboards, the first keypress is sometimes lost. It varies with the release (I keep changing releases), the machine (Sam 440ep, Sam 440ep-FLex or Sam 460ex) and what happened last (eg a crash, a HW reset or a power down/up).
Using the current beta release or the current version of Update 3, I don't usually lose the first character. However, if I reset the Sam 460 after a lockup, it is still sometimes lost.

So I would suggest that when Update 3 comes out, you will only lose the first keypress after a total lockup and HW reset.

As to the first key not repeating, I would guess it is the same problem.
cheers
tony

Post Reply