Page 2 of 3

Re: Problems with SATA

Posted: Tue Mar 13, 2012 10:59 pm
by Ghillo
I've set the IRQ to 0 and sata hard disk seem better, then I tried nvsetvar a1ide_irq 0000, and error booting after loading the kickstart once appeared the screen AmigaOS 4.1, the computer remains with the LED of PATA hard disk and do not stop on startup, so 'I reset the IRQ ports 1 ATA100 again.
The problem is the same that I found to reinstall OS4 CD on SATA drive, because after MediaToolBox repartitioned the disk and asked me to reboot to make available the Amiga could not change more 'to boot from either CD, with the LED on the drive on the computer case.

Re: Problems with SATA

Posted: Wed Mar 14, 2012 2:48 am
by Slayer
So we've made a little progress but nothing substantial

I guess the next thing we need to do is see what versions of the drivers are you actually using and do earlier versions work better, was something missed due to limited users running this set up? And have you tried using the other SATA port? I know it mixes up all the other variables but it could be an option

Re: Problems with SATA

Posted: Thu Mar 15, 2012 10:39 pm
by Ghillo
I have another doubt arose, the various partitions on the hard disk I have numbered in a non-continuous:
dho: sfs\00 OS4 boot
dh1: jxf\04 software
dh4: swap
dh5: LNX\00 Debian-Lenny
dh6: SWP\00

Primary Master
dh2: jxf\04 Data and works
dh3: dos\3 ffs

Secondary Master
dh7: EXT3 for Linux

During the installation I had forgotten to rename the partition where I had first pata OS4 dh0 and had two: one on the sata and the other on the old hard disk that I had prepared for ext3.
Maybe it has nothing to do but it is a question that I came
And the installation of new partition for OS4 and software Hard disk SATA I performed simply by copying the contents of its partitions after making a copy on the hard disk which I use for data and work.

Re: Problems with SATA

Posted: Fri Mar 16, 2012 1:16 am
by Slayer
The other thing I don't think we established properly is what actual drives you were reading from and/or copying to and from etc If you understand?

Since you've now listed your drives can you now describe what you are doing from what partition and what happens during these pauses etc?

Something like:

Running AmigaOS4.x.x
Copying a 200MB file from dh1: to dh3:
The mouse pointer freezes 1 second at a time then zooms to where it should be if it hadn't frozen several times during the copy
After copy operation completes things return to "normal"

And... have you tried performing any these operations through different means

btw, you can relabel drives through mediatoolbox without risk to the partition


Copying via DirOpus verses doing same copy operation via the shell or via show all files on WB and dragging icons into destination drawer?

Off the top of my head I do not believe volume labeling would effect performance.

btw, you can relabel volume names via media toolbox without any risk to the partition or harddrive.

Re: Problems with SATA

Posted: Fri Mar 16, 2012 10:02 pm
by Ghillo
I tried to do the operations between partitions via the WB is that DirectoryOpus with 180MB of video files, but there are no delays and it does not lock the mouse pointer or anything.
The steps I performed with both PATA and SATA partitions and tried to copy a video file on the partition sata gives me problems and run the play of video, it works fine with no slowdowns.
The problem comes in every so often in this program loading is the strange thing.
Thank you for your patience!

Re: Problems with SATA

Posted: Sat Mar 17, 2012 12:10 am
by Slayer
hmmm, so the bottom line is when you go to execute a program (just opening it up so its gui appears etc) the system locks or slows and the process takes what seems like an extraordinary amount of time but the gui eventually appears right?

does this also include opening documents in said program or loading other things like pictures and what about saving from said program?

or can hanging occur while just copying media from hd to hd between ide and sata

I know where's discussed most of this now but the thread is getting so long! :lol:

and what patience? ;) but thanks and no worries :D

Re: Problems with SATA

Posted: Sat Mar 17, 2012 1:05 am
by Ghillo
The problem is sometimes so random to me, especially if I start to run programs, in the case of reading or writing files everything works correctly without blocks, I can watch movies write files, copy them too long or otherwise without problems.
Again the problem appears only in the launch of software so random, I can work for hours without problems, when I load the program can 'happen this problem.

Re: Problems with SATA

Posted: Sat Mar 17, 2012 1:28 am
by Ghillo
Sorry but I have to fix, I ran another test by copying a partition on the SATA mp4 video programs and where I've run with MPlayer, and at one point he stopped and then start running the video.
It could be a bad sector? Strange that when there are these blocks will always turn on the LED device PATA, I can not understand very own.

Re: Problems with SATA

Posted: Sat Mar 17, 2012 2:00 am
by Slayer
Okay so it is just from launch, let me think about this :)

As for the movie file stopping during playback I'd be more inclined to believe the movie stream is corrupt or corrupted (can you play the source version and check to see if that plays normal?) during that copy process. (therefore looking at maxtransfer for that particular HD [playing movie from] could be something we need to look at - after trying to change them earier to enhance reading speed) From what partition did you copy it from to what destination partition?

Re: Problems with SATA

Posted: Sat Mar 17, 2012 11:32 pm
by Ghillo
I try to understand what the device PATA problems.
There is a command UBoot which disable a device by ide SETENV not save the variable in order to perform the tests without having to disconnect the devices? I would not want to give the old problems of PATA 40GB HD that I use with Linux EXT3 entirely in the device which is where I first installed the partition OS4.x more with the software.
Meanwhile language is rather the system by lowering the UDMA hard disk.
Spero che ci capiamo bene quando scriviamo nel forum, visto che utilizzo il traduttore di Google , perchè non parlo inglese. :oops: