Page 1 of 1

microA1 Serial port(s)

Posted: Thu Feb 11, 2021 10:45 am
by migthymax

I'm trying to establish a communication link with another computer via the microA1 serial port. Without any luck up till now. And it behaves somehow
strange. My setup is actually the same as described here: ... ic_id=4985

Regardless what i do nothing happens at the other side, when sending data via the serial port. I tried to let the kernel output via the serial port, nothing. I even compiled a simple program to just send a fix string via the first serial port. Nothing. I checked the baud, etc settings. Nothing happens.

Sometimes trying to send something via the serial port the system hangs. But because it isn't reproducible i think it just another issue.

So i started to run the 'post serialtest' on the u-boot shell. Regardless if run with or without the 'null-modem-cable plug', it hangs.

Is the serial port of the mictoA1 supported to work? And sometimes i read there is a second serial port (At least opening the unit 1 of the serial.device, doesn't fail), where is the second port located?


Re: microA1 Serial port(s)

Posted: Sun Feb 14, 2021 3:07 pm
by migthymax
The original author if the question ... ic_id=4985, was
so kind an answered me on a PM. Even than, no solution was found.

Thus so little bit different question: Anyone ever had success with using the serial port of the microA1? It seems that no one very had success
in using it.

BTW even U-Boot does write anything out on the serial port, at least it is supposed to do.

Re: microA1 Serial port(s)

Posted: Thu Feb 18, 2021 10:50 am
by smf
Ofcourse the serial port is supposed to work :)

The devs and betatesters use it all the time.

Re: microA1 Serial port(s)

Posted: Mon Apr 12, 2021 4:15 pm
by xenic
I don't have a microA1 any more but when I had one years ago I connected a "header to female 9 pin" adapter to the internal serial serial header so I could use that serial port with a dialup modem and it worked for years. Unlike some newer NG Amigas the µA1 uses all serial pins which allows hardware flow control. On newer systems I think you need to use software flow control. Maybe your problem relates to flow control or baud rate. I don't know if this information will help but I thought I'd let you know that I did use µA1 serial with a dialup modem.