Page 1 of 1

aos4.1fe original cd will not boot

Posted: Wed Oct 28, 2020 10:07 am
by satiropan
I stiil have my AmigaOne G3SE, I don't use it very often still.
Generally I turn it on once every 3 or 4 months.
Last time was in august. It worked fine with my AOS4.1FE original installation.
Then I have moved and since then, the AOS4.1FE won't boot anymore, it freezes at the boot screen, black screen with thh AmigaOS 4.1 Final edition logo.
I had this problem years ago but I don't remember which was the cause.
Anyway, I decided to do a new installation on a spare hard disk just to see.
Hard Disk and DVD are both SATA, connected to a SIL 4 ports SATA PCI board, hard disk on port one and DVD on port 3
If I start in uboot with boot device selected as sil 4 sata cdrom, uboot doesn't find the cd.
I tested then with the old, original, AOS4.1 cd that I have, and it boots with no problem from the cd, so I have to think that in some way the original AOS4.1FE cd is corrupted (even if I have kept it always in a fresh environment, inside its original box).
What should I do? Is there a procedure to have it new?

Re: aos4.1fe original cd will not boot

Posted: Wed Oct 28, 2020 11:35 am
by nbache
Go to, log in with the same credentials you used when registering your OS4.1FE, and you should be able to find it under Downloads. From there you can download the ISO for your product and burn it to a fresh CD-R - if you have another machine which can do that (e.g. a PC).

P.S. If it started after moving, another possibility is of course that some card has wiggled in its slot and created an intermittent contact problem. So if a freshly burned disc does not solve it, try opening the case and pressing carefully down on any cards and memory modules that sit in slots.

SATA cable plugs also deserve checking - are they fully inserted, and at a completely right angle?

And for good measure - change the coin cell battery (the number one cause of "strange" problems on AmigaOnes).

Best regards,


Re: aos4.1fe original cd will not boot

Posted: Wed Oct 28, 2020 5:06 pm
by satiropan
thank you.
I will try.
another question, since I was experimenting yesterday, I booted with the old aos4.1 cd that I have and tried to install it on an adata 120GB ssd, but media toolbox didn't see it.
is there any trick to have the OS recognize the ssd or maybe the 4.1 is to old?

Re: aos4.1fe original cd will not boot

Posted: Sat Oct 31, 2020 10:36 pm
by tonyw
An SSD looks just like an old mechanical disk electrically, so MTB should be able to set it up normally.

I would guess that you have the ENV-Var "sii3114ide_conf" set to allow only the old disk. You will have to change it to include the new one as well.

Re: aos4.1fe original cd will not boot

Posted: Tue Nov 03, 2020 2:14 pm
by satiropan
I had forgotten to disable all USB ports in the UBoot menu.
The G3SE board has always had problems with the on board USB
Now it boots regularly, both from the FE cdrom and the FE Hard Disk
The fact that the original AOS4.1 cd booted also with USB enabled I think is due to the USB devices that are into the CD which are older than those in the FE cd.
Now I am copying all the boot partition from the old hard drive to the SSD, then I will try booting from the SSD
Thanx and hope this wil help someone