Page 1 of 1

AmigaOne XE broken

Posted: Sun Jun 09, 2019 1:20 pm
by Tomcat
My router and my AOne XE were hit by the result of a lightning strike. Fortunately the other devices connected to the router were not affected.

The 3com chip has visual marks, it definitely looks roasted. It is no longer detected at the beginning of the boot. The computer seems to boot to some point, but shows the following behavior:
It takes a "correct" cold start (PSU remove from power) to detect the keybaord. From there, it could be used to change settings in UBoot. Booting into OS4.1 works only until the boot splash screen appears. This splash screen often looks like screen garbage. From that point the computer does not continue and tries booting again after some time.

When doing a reset or switching off the computer on the front button afterwards, the keyboard will be detected as defective.

What else could be broken? Is the whole board only usable as a wall decoration?

Re: AmigaOne XE broken

Posted: Sun Jun 09, 2019 1:44 pm
by Raziel
edit: First of all, sorry to hear that...strange that the fuses (router) didn't pop

I guess you know what you're doing, given the board might become bricked if you remain using it while being in this insecure state of not really knowing what blew and what still works?
If one chip already "looks" roasted than probably more has been shot.

I'd refrain from turning it on again, unless someone with knowledge has checked it thouroughly...

Anyway, if you are sure what you're doing, you can try this:

Is the keyboard USB?
If so, have you tried with a PS2 or completely different keyboard? (One that wasn't connected when lightning stroke)
If a PS2 keyboard works, than the USB controller chip might have been harmed aswell.

Which gfx card do you use?
Have you tried the card in another machine to see if it is allright? (Same as with the keyboard)

Test your RAM too.
I remember strange booting behaviour (back in the days when i still had ym XE) of all sorts and kinds from using broken/unsupported RAM.

Re: AmigaOne XE broken

Posted: Sun Jun 09, 2019 2:25 pm
by Tomcat
Both types of Keyboard are attached. I habe no other PS2-Keyboard.

Graphic-Card ist Radeon9000 with 128MB. UBoot looks OK, only the OS4.1-Bootscreen looks weird.
I'll look for another card to test.

RAM runs fine first.

Re: AmigaOne XE broken

Posted: Sun Jun 09, 2019 4:48 pm
by Raziel
I guess you don't have the possibility to hook your XE up to serial?
That way you could probably see where it bails out.

Typically (afair), when an XE stumbles over while showing the bootscreen (even garbled), either the gfx driver crashed or intuition (personal experience: the gfx driver crash happened to me. It bombed because of the infamous XE DMA/USB hardware issues, may not be the exact case for you, but there still may be other hardware damaged, which we won't hope).

If RAM would be the culprit, you'd probably crash while UBoot is still UBooting (also personal experience)

The reason why gfx work in UBoot is because there is a rudimentary gfx driver/display used.
Once WB is loaded the OS4 gfx driver takes over. Just the same as with the keyboard/mouse usbfd's.

You could trys to turn off USB and DMA in UBoot and see if that helps.
Another gfx card to test would be good too.

Hopefully others with more knowledge or even an XE on their table will chime in.

Good luck

Re: AmigaOne XE broken

Posted: Sun Jun 09, 2019 8:27 pm
by Tomcat
Tested another Radeon, better bootpicture, but no real booting and same problems with Keyboard on reset.
Tested Install-CD, no changes.
On-Board-IDE is off (SiI0680IDE-Card in PCI), OnBoard-USB off (NEC-USB2.0 in PCI).

I have my A1200, can i set up a serial connection A1200 <> AOneXE?

Re: AmigaOne XE broken

Posted: Sun Jun 09, 2019 8:29 pm
by Rigo
I seem to remember that when using an XE, it stalls for a really long time when trying to initialise the onboard ethernet when no physical connection can be found. I would suggest to leave it for a good few minutes, then, if it boots, remove the onboard ethernet driver and config files.

Like Raziel says, hooking up serial debugging would definitely help here, it's a lot of guesswork otherwise.


Re: AmigaOne XE broken

Posted: Sun Jun 09, 2019 8:57 pm
by Tomcat
Tested with and without LAN-Connection. Same result.

Re: AmigaOne XE broken

Posted: Sun Jun 09, 2019 9:03 pm
by nbache
Tomcat wrote:I have my A1200, can i set up a serial connection A1200 <> AOneXE?
Sure, you just need Term (from Aminet) on the A1200 and a null-modem cable (serial cable with some wires swapped to give each computer the illusion of talking not to another computer, but to a serial peripheral).

There's a good guide to serial debugging on the Wiki: ... ging_Guide

Best regards,


Re: AmigaOne XE broken

Posted: Sat Jun 22, 2019 8:09 am
by Tomcat
I got a replacement motherboard, up and running again! :)