Page 7 of 9

Re: OS4.1FE did not start.

Posted: Sun Jun 21, 2015 7:28 pm
by nbache
nzv58l wrote:I have reset everything to factory several times, it is displaying the AmigaOS 4.1 final edition logo fine. My screen is not black when it freezes, it is displaying the logo. I think it actually has issues just before it starts the startup-sequence as I did not get any output when using the SerialEcho program in the startup-sequence either.
I am suspecting that either the SerialEcho command you found isn't working correctly (as I said, I didn't ever try it myself), or you are using it - or the serial link - wrong. It is very unlikely, IMHO, that you see the boot logo without at least the first commands in the Startup-Sequence being executed - unless you have renamed the S dir or the Startup-Sequernce or something weird, but I guess that's not the case? :-D

So another thing you could try is inserting

C:Echo "Start of S-S" > SYS:MyLog

at the very top of the Startup-Sequence and try booting again. When it stops at the boot logo, do a hard reset with your CD in the drive, boot from that and examine the root of your HD boot partition. There should be a file called MyLog containing the text "Start of S-S". If that worksm, you know the Startup-Sequence was at least started. Then you can put further lines like that into it, repeat the process and see how far you get. With a bit of luck, you'll end up finding the problem line.

Best regards,


Re: OS4.1FE did not start.

Posted: Mon Jun 22, 2015 3:41 am
by nzv58l
I formated and reinstalled to make sure I had a clean install to work from. Then I edited the Startup-Sequence (did not move it) Entered the C:Echo "Start of S-S"> SYS:MyLog as the very first line in the S/Startup-Sequence file. Rebooted from the HD without the CD in the CD drive. It did the very same thing. Froze right after the splash faded in. Put the CD in and booted from that into the OS. The file never got created.

Again it is not getting to the starup-sequence and is dying before that. If you have an AmigaOne XE, try formatting and setting up a blank formatted disk and installing fresh off of the CD as you should be able to. I am pretty sure you will be able to reproduce the same result. If not then check your version of UBOOT. Is it 1.1.1 or is it a newer beta version which may act a little different.

I really think it has something to do with setting up the SWAP volume. Does anyone know at what point the OS sets up the SWAP drive? I do not have a SWAP drive, but if I create one it may boot into the disk one time and then go back to not letting me boot.

Is it Kickstart that starts the fade in of the Logo? I doubt that the startup-sequece does it as there is no command in there that I see that does it. I do not think the startup-sequence has anything to do with my issue. It is dying before that.

Things I know so far:
-It is not executing startup-sequence
-It dies somewhere after the splash screen fades in, and if the Startup-Sequence is right after that then it is dying between the two.
-I have tried using the built in IDE, a 0680 IDE card, A Sil3114 SATA card, and I do see all of these after booting into the cd. They all load kickstart and get to the point of the Splash screen.
-Sometimes when I create or delete the SWAP partition it lets me boot for one time from the hd. The next time I boot it goes back the same thing. What else could it be if not something to do with the SWAP drive.
-I have not done anything with my board, not even the USB fix. It is the way it came from Eyetech and my CPU is not soldered in. I have installed UBOOT 1.1.1 .
-I have tried downloading the CD image that Hyperion lets us for backup to see if there was something wrong with my CD. However, Same result.
-When I ask if anyone else has an AmigaOne XE, there are never any replies, so I may have been one of very few that have one.
-As far as I am concerned, Amiga OS 4.1 final edition does not work on an AmigaOne XE. Installing to a Formatted blank disk should be something that should have been tested, but I do not see how it could have been. I do not know what step to take next, because it simply does not work. I do not have any other newer version of UBOOT or any other version of OS 4.1 to install first and update like many others do. An install on a blank formatted disk with all factory default settings should work, but unfortunately it does not. Install for OS4.0 4th update does work and updateing to OS 4.1 FE does not work.

Re: OS4.1FE did not start.

Posted: Mon Jun 22, 2015 4:13 am
by nzv58l
As a test. I created a swap volume. Booted from the HD and it finised booting into Workbench.

It has to be the SWAP volume that is killing my system. Something does not work like it is supposed to.

I need to find out how to TURN IT OFF or POINT IT to the point where it doesn't even look for it. (Don't say just do not create one, because that does not work, I think because it still trys looking for it even if it is not there.)

I need to make it so it does not even try to look for a SWAP volume, Does anyone know how to make it like the CD where it does not even try using it?

I would like to get the SWAP file working, as I think it is a good idea, but I would first like to turn it off and see if I can get it so it consistantly boots from the HD.

Re: OS4.1FE did not start.

Posted: Mon Jun 22, 2015 4:26 am
by nzv58l
Further evidence it is not the Startup-Sequence. MyLog file appeared after it booted successfully with the message in it that the startup-sequence started.

So after the install it did not boot
created a swap file then it booted
tried turning it off after it was running awhile and it would not boot
logged into drive and saw that the startup-sequence Echo out to the file actually does work.

Re: OS4.1FE did not start.

Posted: Thu Jun 25, 2015 12:39 am
by nzv58l
Another thing I am curious about is how it did not find/or could not use the SWAP partition on the second boot? It read the disk well enough to get the kickstart loaded and running, and the SWAP is on the same drive. I know the SWAP has something to do with my issue, directly or indirectly it is preventing me from booting. Is there anyone I can talk to that understands how the SWAP volume works in detail? From what I understand it is the exec that uses the SWAP volume. Does anyone know if it is hard coded in the exec on where to find the SWAP volume? How does it know if it does not have a SWAP volume? I would hope that it stores the location of the SWAP volume when it finds it so it does not have to search for it on every boot of the system. It is also curious that it finds it ok on the first boot after I change it from having to not having a boot volume and boots with it, but the next time I boot it doesn't seem to find it or can not use it for some reason. I should be able to boot without one, but it only boots once without it and then will not boot.

Another test I did was that after I booted successfully and then booted unsuccessfully, I deleted and then recreated the SWAP partition to see if it would boot on a fresh SWAP volume, but it failed when I did so.

I really hope someone can help me, I have had OS 4.1 since May and have not been able to use it yet. If I had the disk drive set wrong some how, would it be able to run Kickstart, but not use the SWAP partition off of the same Disk drive?

Re: OS4.1FE did not start.

Posted: Sat Jun 27, 2015 12:43 am
by nzv58l
Could it have something to do with how the Sil0680 is configured? I really do not think so, but if there is some chance I would like to explore that as well. It seemed to work OK with the same disk drive and Sil0680 PCI card when I loaded OS 4.0 update #4 with no problem. I also do not see how this could not be a problem for anyone else using an AmigaOne XE/G4, when I am all stock unmodified board and pretty much default settings. I even tried FFS and it did the same thing.

Does the SWAP require disk performance that my unmodified AmigaOne XE is not capable of? This really does not make sense, because I also have tried without a SWAP volume and still had the same issue. I am really trying to not get frustrated and figure this out, but I am not sure anyone would know the answers that I am looking for unless they know exactly how the SWAP file is handled. (How it looks for it and how it gets assigned?). I have done about as much as I can do, but if I do not get some kind of help I will have to go back to OS 4.0 and write off OS 4.1 as not being compatable with my system.

Is there a better place to report this, because OS 4.1 does not work for me?

Re: OS4.1FE did not start.

Posted: Sat Jun 27, 2015 8:09 am
by tonyw
A SWAP partition is optional and the system will boot and run perfectly well without it. To disable the SWAP partition, use MTB to change the "SWAP" type to something else, eg FFS\07.

I can assure you that others have installed FE on AmigaOne XEs successfully. There is nothing peculiar about the old XEs. I can think of a few possibilities, but I believe they have all been suggested at some time in this thread.

I can only suggest that you start again and:
1) Drop the belief and assertion that it won't work.
2) Assume instead that you are doing something wrong.
3) Read the original installation instructions that came with the XE (how to set up U-Boot).
4) Check the boot sequence in U-Boot. Remember that simply entering the menu to check the "Boot1", "Boot2", "Boot3" clears them to zero. It's better to set them from the command line.
5) Check the sii0680ide_xxx variables with U-Boot or nvgetvar/nvsetvar.
6) Remember that U-Boot loads Kickstart modules from the first bootable partition on the first disk. The system that it boots, however, comes from the Kicklayout config that you choose or the one with the highest priority if you just let it run. It is quite possible to load Kickstart modules from one partition and boot the system from another, leading to a memory-resident OS that won't run. I always have only one bootable disk partition, it's safer than changing and relying on boot priorities.

If you like, I can send you my "log" command, which does the same as many others, simply dumps the rest of the command line to the serial port. Good for comments etc.

Re: OS4.1FE did not start.

Posted: Mon Jun 29, 2015 2:39 am
by nzv58l
Well, I went back one more time... very carefully, unpluged my my AmigaOne, took the battery out, I used a transister to short out the battery connection (safer than just shorting it like installing the battery upside down does). In fact I replaced the battery as it was at about 3.032 volts. very closed to the 3 volts it needs.

I have simplified the system, I am running as follows:

Sii0680 card with an IDE hard drive attached to the Primary, CD attached to the secondary, both set to master alone.
I have the 512 Mb memory that came with my amiga that I have been using for years now.
I do have the SoundBlaster Pro, again, been using this card for years without issue.

Just for giggles, I configured a partition on the drive of about 20 Gb with the standard file system that OS 4.0 update #4 comes with. This is the only partition and the only hard drive that I have hooked up to the system.

Ran the install for OS 4.0 update #4 and it installed and I was able to boot to the hd after the CD was removed and the Install was completed. I have the boot sequece set to Parallel CD first then Parallel HD second. It finds the drive fine, and works.

Tried installing 4.1 FE on top of OS 4.0 update #4. Same issue I have had all along with OS 4.1. It is getting hard to have faith that OS 4.1 FE works on my machine when OS 4.0 does not have the same issue. Installed on the same hardware with the same UBOOT and the same file system, OS 4.1 FE does not work, but OS 4.0 does. How can this possibly be something configured wrong when the only thing that changes is installing OS 4.1 FE as opposed to OS 4.0 Update #4. I am going to try and format this drive with the standard file system on it so it is again the only partition, a blank formatted partition, that OS 4.0 update #4 ran successfully on. I'll look into my crystal ball and I'll bet it does the same exact thing.

I have not heard of anyone that has installed OS 4.1 FE on an AmigaOne XE/G4 onto a blank formatted disk and then boot into it. I don't care if you have a swap partition or not. It does not work for me either way. If there is anyone that has, please reply, so I can confirm it is possible? Updating from earlier versions of OS 4.1 does not count.

So I would like to ask if anyone has OS 4.1 FE and an AmigaOne XE/G4, I would really like to know if they can install it to a blank formatted disk?

I do not have any other disk drives attached, there is just the CD and the one HD partition, It can not be any simpler.

This problem happens wheather I create a SWAP volume or not. From everything I have tried and all the data that I have collected it points to a SWAP or SWAP related issue. If I create a SWAP volume it will let me boot once into the HD, but on the next boot it will not.

Again, OS 4.0 update #4 installes and boots fine(I do not have a seperate OS 4.0 partition installed when trying FE), OS 4.1FE installs, but fails to boot until I Create or delete the SWAP partition and then it will boot once, will not boot after that. I really do not see how it could be my configuration. I do not have any of the 4.1 earlier versions, so I can not try to install them and see if I can update to FE. I wanted to get the earlier versions, but I was out of work for a few years and did not have that kind of money. OS 4.1 FE was a chance for me to update. However, I am finding out it is not so easy to get working on my machine. It has been months now since I have had it, and I have spent considerable amount of time trying to get it to work. I should get a new SATA Sil3112 card, and there is not much else left to try. I do not currently have the SWAP partition created, but I am pretty sure it is something in the SWAP that is the problem.

Re: OS4.1FE did not start.

Posted: Tue Jun 30, 2015 12:57 am
by nzv58l
Because OS 4.0 works with the same configuration and I have even tried several times with different hardware and only one partition with one disk drive attached to the system with a DVD drive.

At this point I have to say it does not have anything to do with my configuration. It is an OS problem related to SWAP. I think it is time that someone who has access to an AmigaOne XE/G4 and access to the code for the OS to figure the rest of this out.

I still have not heard from ONE person that has an AmigaOne XE/G4 and is able to do a fresh install on a Formated blank hard drive using only the OS 4.1 FE disk, no previous versions. If there are any out there, please respond and tell me how you did it? If no one responds, I have to assume that no one has done it.

I know that the AmigaOne XE has lots of design issues and it is not exactly like a MicroA1.

I think I need someone from Hyperion on this issue.

Re: OS4.1FE did not start.

Posted: Tue Jun 30, 2015 2:31 pm
by RussellB
My setup:

AmigaOne XE 800mhz G4
1GB Ram
Radeon 9250 AGP card
Soundblaster Live
SII0680 IDE card
RTL8139 Network card

I had no problems at all setting up 4.1 FE on my system on a clean hard drive with a SWAP partition on my hard drive but if I use the SWAP partition for example copying more the 1GB into ram disk it will cause my system to lock up.