Page 5 of 9

Re: OS4.1FE did not start.

Posted: Tue Jun 02, 2015 7:34 pm
by Elwood
nzv58l wrote:I can not understand why it would let me boot into the CD's version of the workbench, but not the HD.
probably because you have a more recent driver on your HD than on the CD. Maybe you purchased the latest RadeonHD driver from Aeon.
Maybe you can check version of RadeonHD (it's the first one I would try) on the HD and on the CD. If this is what is different between HD/CD, to confirm you should copy the RadeonHD driver from the CD to the HD (keep a copy of your driver of course) and test again.
If it works then you found the culprit :-)

Re: OS4.1FE did not start.

Posted: Wed Jun 03, 2015 3:17 am
by nzv58l
This is a freshly formatted drive, in fact I formatted it and re-installed OS 4.1 on it just before doing the serial dumps. I am not installing over OS 4.0 For my next test, I plan on taking the card over to a pc that I have and see if it has any issues with the card. These XE boards seem to have a bunch of issues, so I wouldn't be surprised if somehow the card is clashing with something in the board design. I don't see how it could be the driver, because it is a fresh install and I pulled the plug on the eithernet, so there is no internet connection either.

Re: OS4.1FE did not start.

Posted: Sat Jun 06, 2015 3:22 am
by nzv58l
Well, The card works fine in a PC... This is the same Radeon 9000 64m that came with my AmigaOne when I bought it.

So, I did notice that the CD uses a Radeon driver as opposed to a Radeon 9000 driver, so I pushed the Radeon 9000 driver over to storage and then copied the Radeon from the cd to the Workbench and it did not work again.

since graphic cards are rather cheap, I ordered two more video cards to try out. One is the Pro version of the 9000 that has 128mb and the other one was a PCI 9250 that I tried out again with no success.

I have not tried reformatting again and re-installing with the PCI video card yet so that is the next thing to try.

Re: OS4.1FE did not start.

Posted: Sat Jun 06, 2015 3:52 am
by nzv58l
Question for anyone out there?

If the video is incompatible, does the screen go completely black or does it freeze on the AmigaOS4.1 final edition splash screen?

I sure hope this mother board is not damaged, beyond the normal things that do not work right on this board.

Is there anyone else running a Radeon 9000 with 64m (Non-Pro version) on a AmigaOne XE with the G4 and Amiga OS 4.1

Do you have to run 1.1.1 version of uboot with os 4.1?

Re: OS4.1FE did not start.

Posted: Sat Jun 06, 2015 8:44 am
by Raziel

I read through the thread and it seems you tried a lot, but never gave a complete summary of your settings.

- I don't think your gfx card is broken (it works with the cd boot, and you said you checked it in a pc)
- I don't think your board is broken either (again, it works with cd boot)

I rather think there might still be some setting that is acting up, either in UBoot or the setup of your hdd

Could you do us a favour and
1) Boot into the cd workbench and post your UBoot settings here (there should be a shell command to print them, but i don't remember)
2) Open MediaToolbox and post your HDD settings

Also...just a shot in the dark, of course, but did you remove the cd after hdd installation?

Re: OS4.1FE did not start.

Posted: Sat Jun 06, 2015 10:58 am
by Elwood
Raziel wrote: 1) Boot into the cd workbench and post your UBoot settings here (there should be a shell command to print them, but i don't remember)
From AmigaOS shell: nvgetvar
From Uboot prompt: print

Re: OS4.1FE did not start.

Posted: Sun Jun 07, 2015 3:24 am
by nzv58l
Here is what it says. I currently have a Sil0680 IDE card that I was using before with OS 4.0 FE, I now have a Radeon 9000 Pro installed with the AGP slot with 128mb installed along with a Soundblaster card that I also used with OS 4.0 FE and came with the AmigaOne. I also currently have a 1GB SDRAM PC133 ECC REG (S2872R33MJ) installed. I have another one exactly like it, but just to get things going I only installed one of them.

Extra parts I have are as follows:
I have a 4port SATA SIL3114 card that seems to work, but I am just trying to get this loaded before I change too much.
I have a PCI Radeon 9250 256mb that I have tried, but still same issue.
I have another AGP Radeon 9000 64mb non-pro version. I used this with OS 4.0 FE, so I thought swapping it out for the pro may make a difference, but it didn't.
I have another 512MB from DaneElec that came with and I used with OS 4.0 FE. Tried this and it still did the same thing.

I really appreciate everyones help with this. I know that it is a very limited run, bug infested design of a board and for as few people that have these I think it is amazing that I can find anyone to help... so again, I really appreciate it!

New Shell process 4
4.AmigaOS 4.1 Final Edition:System> nvgetvar
bootcmd=menu; run menuboot_cmd
ethact=3Com 3c920c#0
bootargs=root=/dev/ram rw ramdisk=4096

Startup Sequence:
; $VER: Startup-Sequence 53.11 (04.10.2014)



FailAt 21

Version >NIL:
SetEnv Workbench $Workbench
SetEnv Kickstart $Kickstart
UnSet Workbench
UnSet Kickstart

MakeDir RAM:T RAM:Clipboards

Assign >NIL: T: RAM:T
Assign >NIL: CLIPS: RAM:Clipboards
Assign >NIL: KEYMAPS: DEVS:KeyMaps
Assign >NIL: PRINTERS: DEVS:Printers
Assign >NIL: REXX: S:ARexx
Assign >NIL: GHOSTSCRIPT: SYS:Utilities/GhostScript DEFER
Assign >NIL: PYTHON: SYS:System/Python


Mount QUIET DEVS:DOSDrivers/~(#?.info)

Path RAM: C: S:Shell S:ARexx PYTHON:Scripts SYS:Utilities SYS:Utilities/Commodities SYS:System SYS:Prefs APPDIR:

SYS:System/RexxMast >NIL:

If EXISTS S:User-Startup
Execute S:User-Startup
If EXISTS S:Network-Startup
Run >NIL: <NIL: *>NIL: Execute S:Network-Startup

Makelink ENVARC:Sys/ SOFT


Run >NIL: *>NIL: SoundPlayer QUIET


C:Assign >NIL: ADD LIBS: MUI:Libs
C:Assign >NIL: ADD LOCALE: MUI:Locale
C:Assign >NIL: ADD HELP: MUI:Docs

assign tbimages: SYS:Prefs/Presets/tbimages

; $VER: Shell-Startup 52.1 (15.12.2006)

Prompt "%N.%S> "
Alias Clear "Echo NOLINE *"*E[0;0H*E[J*" "
Alias Cls Clear
Alias XCopy "Copy CLONE "
Alias Italic "Echo NOLINE *"*E[3m*""
Alias Bold "Echo NOLINE *"*E[1m*""
Alias Normal "Echo NOLINE *"*E[0m*""
Alias Underline "Echo NOLINE *"*E[4m*""

When I set up the disk, I selected the following:
Name is DH0, Automount, Bootable, Bootpriority 0, SFS\00,Blocksize 512,Buffers 512,Maxtransfer 128kBytes -IDE standard(I have tried maximum before with same results) The drive is a 15GB IDE and I formated a 10 GB partition for Workbench. I have this and an IDE DVD drive and floppy installed.

Re: OS4.1FE did not start.

Posted: Sun Jun 07, 2015 6:52 am
by Raziel
I'm not sure if those SFS limitations still apply, but can you try to *not* make your WB/boot partition bigger than 2 GB (try 1.5 GB first) and put it at the first position on the HDD.
(Actually if you keep your WB/Boot partition "clean" you probably won't hit 500 MB for quite a while).
My boot partition is 2 GB in size and i have only approx. 370 MB used (then again, i'm using SFS/02).

I remember SFS being limited to a 2 GB boot partition needing to be inside the first 4 GB of a HDD (the rest of the partitions can be as big as 120 GB max[?] anywhere on the HDD - i think those limitations were broken with SFS2[?])

Please correct me if i'm wrong, guys...

Re: OS4.1FE did not start.

Posted: Sun Jun 07, 2015 5:15 pm
by ZeroG
Raziel wrote: I remember SFS being limited to a 2 GB boot partition needing to be inside the first 4 GB of a HDD
This is only true on classic hardware because it will first boot os3.x. BTW: It's like this with every filesystem, not only sfs.
(the rest of the partitions can be as big as 120 GB max[?] anywhere on the HDD
SFS/00 has a partition limit of 128 GB.

Re: OS4.1FE did not start.

Posted: Mon Jun 08, 2015 1:40 am
by nzv58l
Well, I reduced the size of the partition to exactly 1.5 GB.

To be on the safe side, I installed the 512 mb memory stick by itself as that came with the machine. It just sticks at the black background with the AmigaOS 4.1 final edition logo screen. I still have questions about this.

I loaded UBOOT 1.1.1 and have had issues ever since. Is anyone else using this with an AmigaOne XE with the G4 processor?

Is it possible that UBOOT loaded wrong and somehow it tries to work with a piece of hardware that the CD boot does not?

Is there a setup for a very basic version of Workbench, that starts as little as possible. Kind of like the CD minus the tools and the quick start thinggy at the bottom? What is absolutly needed in the startup-sequence?

What is the Amiga doing right after the AmigaOS 4.1 final edition shows? Is it supposed to execute the Startup-sequence at this point?

Was OS 4.1 tested on a machine like mine(Amiga One XE with a G4) before it was released? If it was, was it tested as a fresh install? What was the configuration of that AmigaOne?

Can I run an older version of UBOOT with OS 4.1 or does it require UBOOT 1.1.1, which I am beginning to think is the problem. I just hate the risk of reloading this if I do not need to, so this will be the last thing I try, but I am running out of things to try here.

I have not tried using the option of the slowest IDE setting yet , Does anyone know what is meant by 64KBytes - buggy old IDE? Is this possibly for Disks as well as controllers? I really do not think this will help, because when I boot off the cd, I can access the Workbench DH0: without any problem, but I have not tried it yet.