Booting into WB with sii3114 with UBOOT 1.1.4 on micro

A forum for AmigaOne XE and MicroA1-C specific issues.
User avatar
Elwood
Posts: 65
Joined: Sat Jun 18, 2011 6:57 pm
Location: Lyon, France
Contact:

Re: Booting into WB with sii3114 with UBOOT 1.1.4 on micro

Post by Elwood »

amigaonefan wrote:sii3114ide_conf
it's not needed since a long time ago. The drivers can check what is connected alone. At least on recent hardware, but it should be the same with the MicroA1 as the SATA drivers are the same.
If you want to remove it, do from uboot:
setenv sii3114ide_conf
save
amigaonefan wrote:but the software on my system partition with all of its myriad of third party hacks, addons and programs, caused a problem
No, as your system stopped at the animation disk not one single file was loaded from the startup-sequence and other scripts. At this point only kickstart files are loaded.
Last edited by Elwood on Thu Feb 20, 2014 12:12 pm, edited 1 time in total.
Philippe "Elwood" Ferrucci
Sam460 owner
AmigaOS 4 betatester
User avatar
ssolie
Beta Tester
Beta Tester
Posts: 1010
Joined: Mon Dec 20, 2010 8:51 pm
Location: Canada
Contact:

Re: Booting into WB with sii3114 with UBOOT 1.1.4 on micro

Post by ssolie »

Elwood wrote:
amigaonefan wrote:sii3114ide_conf
it's not needed since a long time ago...
Note the IDE drivers default to PIO on old Eyetech hardware. See the documentation for details.
ExecSG Team Lead
User avatar
Elwood
Posts: 65
Joined: Sat Jun 18, 2011 6:57 pm
Location: Lyon, France
Contact:

Re: Booting into WB with sii3114 with UBOOT 1.1.4 on micro

Post by Elwood »

Yes, the "xfer" variable is still useful.
Philippe "Elwood" Ferrucci
Sam460 owner
AmigaOS 4 betatester
User avatar
Hypex
Beta Tester
Beta Tester
Posts: 444
Joined: Mon Dec 20, 2010 2:23 pm
Location: Vic. Australia.

Re: Booting into WB with sii3114 with UBOOT 1.1.4 on micro

Post by Hypex »

voxel wrote:Hello ^^)

so tryied "sfs0", reinstall and .... BOOT !!! oh joy ^^)

so try this ^^)
I can assure you that slb_v2 with support for Linux and SFS does indeed support DOS7. DOS7 is the minimum supported filesystem and the one that must be used for an OS4 partition unless SFS is used instead. Something else is at play here.

The only thing I know to not support DOS7 is the Parthenope Linux bootloader for the Sam.
User avatar
Hypex
Beta Tester
Beta Tester
Posts: 444
Joined: Mon Dec 20, 2010 2:23 pm
Location: Vic. Australia.

Re: Booting into WB with sii3114 with UBOOT 1.1.4 on micro

Post by Hypex »

thomasrapp wrote: Most likely something in the Kickstart directory. Perhaps you removed the SATA driver from the Kicklayout file.
If that is so then how does Mounter open the SATA device driver? ;-)
joerg
Posts: 371
Joined: Sat Mar 01, 2014 5:42 am

Re: Booting into WB with sii3114 with UBOOT 1.1.4 on micro

Post by joerg »

Hypex wrote:The only thing I know to not support DOS7 is the Parthenope Linux bootloader for the Sam.
That one doesn't support SFS either.

(AFAIK it supports the incompatible AROS SFS version, probably for booting AROS, but it doesn't support the AmigaOS SFS.)
User avatar
javierdlr
Beta Tester
Beta Tester
Posts: 380
Joined: Sun Jun 19, 2011 10:13 pm
Location: Donostia (GUIPUZCOA) - Spain
Contact:

Re: Booting into WB with sii3114 with UBOOT 1.1.4 on micro

Post by javierdlr »

joerg wrote:
Hypex wrote:The only thing I know to not support DOS7 is the Parthenope Linux bootloader for the Sam.
That one doesn't support SFS either.

(AFAIK it supports the incompatible AROS SFS version, probably for booting AROS, but it doesn't support the AmigaOS SFS.)
My SAM460ex has SFS AOS4.1 as boot partition and works fine.
I changed from SFS2 to SFS 'cos Parthenope booter doesn't support SFS2 IIRC.
artblink
Posts: 5
Joined: Sat Nov 12, 2011 6:43 am

Re: Booting into WB with sii3114 with UBOOT 1.1.4 on micro

Post by artblink »

Hello,

I have MicroAone with UBoot 1.1.1, can i install Uboot 1.1.4 or 1.2.0 on my MicroAone?

I use Amiga OS 4.1 only, not linux, are you sure that Uboot work qith Amiga OS 4.1 ?

If yes, where can i download this Uboot 1.1.4 or 1.2.0?

Can i connect PCI GFX Card on My microAone with this version of UBoot (1.1.4 or 1.2.0) ?

Thanks
amigaonefan
Posts: 43
Joined: Fri Sep 16, 2011 9:20 pm

Re: Booting into WB with sii3114 with UBOOT 1.1.4 on micro

Post by amigaonefan »

Thomasrapp was correct.....the problem all along was something in my kickstart directory. Specifically, it was a file named diskboot.config (not kicklayout).

On my non-booting partition it contained this:

; $VER: diskboot.config 53.1 (21.6.2008)
;
; device units flags (1 = mount HD, 2 = mount CD/DVD, 3 = both, +4 = support LUNs)
it8212ide.device 16 3
lsi53c8xx.device 64 3
cybppc.device 16 7
scsi.device 8 2
2nd.scsi.device 8 2
a1ide.device 4 3
sii0680ide.device 16 3
;sii3112ide.device 8 3
;sii3114ide.device 16 3
;sii3512ide.device 8 3

Yikes! When did I do that!
No wonder I couldn't boot from the 3112 or 3114 cards with this in my kickstart directory!
So I removed the comments from the last 3 lines, did a cold reboot, and all now works!
User avatar
Elwood
Posts: 65
Joined: Sat Jun 18, 2011 6:57 pm
Location: Lyon, France
Contact:

Re: Booting into WB with sii3114 with UBOOT 1.1.4 on micro

Post by Elwood »

@artblink
You should open new threads if you want to find answers...
Philippe "Elwood" Ferrucci
Sam460 owner
AmigaOS 4 betatester
Post Reply