Page 1 of 1

USB not working on AmigaOneXE/G4 4.1U6

Posted: Fri Dec 13, 2013 7:49 pm
by amiganut
I recently re-imaged my AmigaOneXE to 4.1U1 and then upgraded it to Update 6. I also ran several auto updates as well. I don't remember if the USB worked before but it doesn't recognize anything now. I tried USB thumb drives and logitech mices just to test things. Nothing.

I performed the upgrade by re-imaging 4.1U1 and then applied 2-6 + several autoupdates.

I have not changed any of the defaults of the software and it appears that all the USB drivers are in their proper location. I also checked UBoot 1.1.1 and it says both front and back USB ports are active. I have also tried the USBCTRL stop/start/restart without issue.

I am sure it is something I am missing or a Bug.

Also, another issue I am having is not everytime but either when i turn on or reboot, the HD light will come on full for 30 seconds and nothing just a black screen. If I reboot, i will get the uboot screen and it will start. Another weird thing is I will not get any error but it will boot to AmigaOS but mouse will not work. Recently I have had it boot into the old kickstart screen like I held both mouse buttons down. I'll try and replace my mouse.

I have replaced the bios battery.

I have also maxed out the RAM with 2-1 Gig DIMMS to give me the max of 2gig.

Re: USB not working on AmigaOneXE/G4 4.1U6

Posted: Fri Dec 13, 2013 11:04 pm
by tonyw
That may be the problem. The A1-XEs are particularly sensitive to RAM type. I also have found in all the XEs that I have upgraded for people, that two DIMMs are a no-no.

Often it will appear to work with two DIMMs, but either crashes later, displays corrupted pictures or otherwise is unstable.

I would suggest that you remove one of the two DIMMs as a first priority. 1000 MB is more than enough for an A1-XE.

Re: USB not working on AmigaOneXE/G4 4.1U6

Posted: Sat Dec 14, 2013 6:51 am
by amiganut
Weird thing after I did that, the PS/2 mouse stopped working. So I put both back in and it worked again. First time I pulled the DIMM farthest from the CPU. Then I pulled the one closest to the CPU. Both times it booted but no mouse.

On the Uboot, I see that it says 1USB device found.

Re: USB not working on AmigaOneXE/G4 4.1U6

Posted: Wed Dec 18, 2013 2:55 pm
by amiganut

I think I fixed my mouse issue. The last couple times I have tried to use the machine, not only was the mouse giving issues but the keyboard started acting like it was possessed. The lights started blinking and if I had a text window or cli opened I started to get all these weird connectors. So I pulled the board and started doing continuity checks from the PS/2 connector through the ferrite beeds soldered to the board. Everything seemed to be checking out until I took a small screwdriver and started lightly flicking at the ferrite square beeds. I found one on the top corner that just popped off with a cold solder joint. I soldered it back on and touched up the solder on the others both top and bottom of the board. I used it all last night for hours rebooting it several times and the mouse/keyboard issues seemed to have disappeared.

USB - I did as suggested. I purchased and installed Startech 7port and plugged in the front ports to the board. I also purchased a UltraATA 133 PCI SC-PE4B12-S4 IDE CONTROLLER.

The USB was just plug and play. The UltraATA required making the parallel SIIG as the first in the boot sequence. I also disabled both onboard USB and IDE in UBoot.

A friend of mine gave me a 250M USB Zip drive. I got that working in a snap. I just had to change the device on the "zip" device driver in storage/dosdriver from the siiide.device to usbsys.device and unit to zero. I got it to read my old amiga 100 zips and PC100 zips using the ZIC device driver making the same changes to it.