AmigaOS 4.1 Classic Hardware compatibility list...

A forum for Classic Amiga specific support issues.
User avatar
DarrenHD
Beta Tester
Beta Tester
Posts: 635
Joined: Mon Dec 20, 2010 3:38 pm
Location: London, Ontario, Canada
Contact:

AmigaOS 4.1 Classic Hardware compatibility list...

Post by DarrenHD »

I have created (unofficially at this point) a hardware compatibility list for AmigaOS 4.1 Classic. It is not yet complete, but when it is, I was thinking of including it with future updates. Comments?

For now you can access it here:

http://www.hd-zone.com/2011/05/amigaos- ... lity-list/

Feedback, additions/deletions, and comments welcome.

Thanks,
Darren
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
Neil_P
Posts: 26
Joined: Sat Jun 18, 2011 1:16 am
Location: Manchester, Britain (United Kingdom)

Re: AmigaOS 4.1 Classic Hardware compatibility list...

Post by Neil_P »

I am very grateful for you taking the trouble to complete a hardware compatability list, on your HD-Zone website, and continually updating it as hardware compatibility is confirmed either as working or with information as to any conflicts that are found with hardware. :?

It would definitely be a good thing to include with the Classic OS4.1 package, so as to avoid as many 'teething' troubles when carrying out an initial first installation onto Classic PPC hardware. :geek:

I feel sure anyone who considers upgrading to Classic OS4.1 and higher will benefit from your efforts, and it is certainly much appreciated by me, as an Amiga user who has the PPC hardware to upgrade to Classic OS4.1 and higher.

Kudos to you Darren. :mrgreen:
SAM 440ep-flex 733MHz 1GB RAM, Radeon 9250 PCI, OS4.1FE Upd 1, Amiga A1200 Blizzard SCSi PPC G3 240Mhz/060-50Mhz, 256MB + 200MB -> Radeon 9200 256MB in Mediator TX, + Voodoo 3 3000 16MB, Sound Blaster Live + TT-SOLO-1 soundcards, Spider USB, Ethernet RTL8139 + RTL8029AS, Adaptec 2940UW SCSI.
User avatar
DarrenHD
Beta Tester
Beta Tester
Posts: 635
Joined: Mon Dec 20, 2010 3:38 pm
Location: London, Ontario, Canada
Contact:

Re: AmigaOS 4.1 Classic Hardware compatibility list...

Post by DarrenHD »

Neil_P wrote:I am very grateful for you taking the trouble to complete a hardware compatability list, on your HD-Zone website, and continually updating it as hardware compatibility is confirmed either as working or with information as to any conflicts that are found with hardware. :?

It would definitely be a good thing to include with the Classic OS4.1 package, so as to avoid as many 'teething' troubles when carrying out an initial first installation onto Classic PPC hardware. :geek:

I feel sure anyone who considers upgrading to Classic OS4.1 and higher will benefit from your efforts, and it is certainly much appreciated by me, as an Amiga user who has the PPC hardware to upgrade to Classic OS4.1 and higher.

Kudos to you Darren. :mrgreen:
Thanks for the kind words! It is not that much work to maintain it now because things are added usually one at a time now :)

Darren
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
Neil_P
Posts: 26
Joined: Sat Jun 18, 2011 1:16 am
Location: Manchester, Britain (United Kingdom)

Re: AmigaOS 4.1 Classic Hardware compatibility list...

Post by Neil_P »

Are the Betatesters aware that Elbox appear to be working on version 10.x of the PCI.library which should allow the currently usable DMA cards to work in the Mediator in Classic OS4.1, thus re-enabling the DMA 'hack' or at least running their DMA system legally, and in a method that is allowed by OS4.1 Classic OS4.1, by some means or other? :?:

This would be great news, and a real step forward IMHO, for much more modern PCI hardware drivers to be made available to Classic OS4.1+ users. :D
SAM 440ep-flex 733MHz 1GB RAM, Radeon 9250 PCI, OS4.1FE Upd 1, Amiga A1200 Blizzard SCSi PPC G3 240Mhz/060-50Mhz, 256MB + 200MB -> Radeon 9200 256MB in Mediator TX, + Voodoo 3 3000 16MB, Sound Blaster Live + TT-SOLO-1 soundcards, Spider USB, Ethernet RTL8139 + RTL8029AS, Adaptec 2940UW SCSI.
User avatar
DarrenHD
Beta Tester
Beta Tester
Posts: 635
Joined: Mon Dec 20, 2010 3:38 pm
Location: London, Ontario, Canada
Contact:

Re: AmigaOS 4.1 Classic Hardware compatibility list...

Post by DarrenHD »

Neil_P wrote:Are the Betatesters aware that Elbox appear to be working on version 10.x of the PCI.library which should allow the currently usable DMA cards to work in the Mediator in Classic OS4.1, thus re-enabling the DMA 'hack' or at least running their DMA system legally, and in a method that is allowed by OS4.1 Classic OS4.1, by some means or other? :?:

This would be great news, and a real step forward IMHO, for much more modern PCI hardware drivers to be made available to Classic OS4.1+ users. :D
I'm not personally aware that they are...but that doesn't mean that they aren't :) Would be nice.

Darren
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
Rotzloeffel
Posts: 35
Joined: Sat Jun 18, 2011 4:56 pm
Location: Wolfach / Germany

Re: AmigaOS 4.1 Classic Hardware compatibility list...

Post by Rotzloeffel »

DarrenHD wrote:
Neil_P wrote:Are the Betatesters aware that Elbox appear to be working on version 10.x of the PCI.library which should allow the currently usable DMA cards to work in the Mediator in Classic OS4.1, thus re-enabling the DMA 'hack' or at least running their DMA system legally, and in a method that is allowed by OS4.1 Classic OS4.1, by some means or other? :?:

This would be great news, and a real step forward IMHO, for much more modern PCI hardware drivers to be made available to Classic OS4.1+ users. :D
I'm not personally aware that they are...but that doesn't mean that they aren't :) Would be nice.

Darren
Hi Darren!

Elbox is working on that! I recieved a Beta-version this morning from pci.library 10.0 and a Radeon.card file, that should fix the Problem usion the Radeon-Card in the Mediator. I also recieved a Todo List for the Kicklayout and the picasso96.config ! I will inform you, if this works in OS4.1. I will try it this evening!

Kind regards

Harald
Neil_P
Posts: 26
Joined: Sat Jun 18, 2011 1:16 am
Location: Manchester, Britain (United Kingdom)

Re: AmigaOS 4.1 Classic Hardware compatibility list...

Post by Neil_P »

Rotzloeffel wrote:Hi Darren!

Elbox is working on that! I recieved a Beta-version this morning from pci.library 10.0 and a Radeon.card file, that should fix the Problem usion the Radeon-Card in the Mediator. I also recieved a Todo List for the Kicklayout and the picasso96.config ! I will inform you, if this works in OS4.1. I will try it this evening!

Kind regards

Harald
Hi Harald, are you a Classic OS4.1 Betatester then, or is there some other way that you happen to have the latest pci.library for testing already?

I thought this pci library update was to resolve the DMA issues for the Mediator card, and not just solve Radeon issues, is that correct?
SAM 440ep-flex 733MHz 1GB RAM, Radeon 9250 PCI, OS4.1FE Upd 1, Amiga A1200 Blizzard SCSi PPC G3 240Mhz/060-50Mhz, 256MB + 200MB -> Radeon 9200 256MB in Mediator TX, + Voodoo 3 3000 16MB, Sound Blaster Live + TT-SOLO-1 soundcards, Spider USB, Ethernet RTL8139 + RTL8029AS, Adaptec 2940UW SCSI.
Rotzloeffel
Posts: 35
Joined: Sat Jun 18, 2011 4:56 pm
Location: Wolfach / Germany

Re: AmigaOS 4.1 Classic Hardware compatibility list...

Post by Rotzloeffel »

Hi Harald, are you a Classic OS4.1 Betatester then, or is there some other way that you happen to have the latest pci.library for testing already?

I thought this pci library update was to resolve the DMA issues for the Mediator card, and not just solve Radeon issues, is that correct?
Hi Neil,

I am not a betatest of Classic OS4.1! I am a frustrated Customer of Elbox who received a Radeon-Card that does not work with os4.1 classic! I think they are interested in selling PCI Cards for OS4.1 tha work:-) I think you are right with the DMA issues, but I think my problem with the Radeon let them work a lot faster:-)

kind regards

Harald
User avatar
Hans-Joerg Frieden
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 223
Joined: Wed Dec 08, 2010 3:52 pm

Re: AmigaOS 4.1 Classic Hardware compatibility list...

Post by Hans-Joerg Frieden »

Neil_P wrote:I thought this pci library update was to resolve the DMA issues for the Mediator card, and not just solve Radeon issues, is that correct?
Please note: Installing the 68k PCI library and using it under AmigaOS 4.1 is asking for trouble. The PCI bus is a hardware device like any other. You would never expect to install two IDE drivers for the same hardware and be able to use this reliable, and the same holds true for PCI. If you install the 68k PCI library, then two libraries are fighting for control over the PCI hardware, and this WILL NOT WORK. It might not blow up immediately under certain circumstances, but it will surely get you into trouble if you are mixing drivers, and it will very likely blow up even if you don't.

Such a "solution" is not supported.
NOTICE: If you want to contact me, use E-Mail. I cannot be contacted via the forum/private messages anymore
Rotzloeffel
Posts: 35
Joined: Sat Jun 18, 2011 4:56 pm
Location: Wolfach / Germany

Re: AmigaOS 4.1 Classic Hardware compatibility list...

Post by Rotzloeffel »

Hans-Joerg Frieden wrote:
Please note: Installing the 68k PCI library and using it under AmigaOS 4.1 is asking for trouble. The PCI bus is a hardware device like any other. You would never expect to install two IDE drivers for the same hardware and be able to use this reliable, and the same holds true for PCI. If you install the 68k PCI library, then two libraries are fighting for control over the PCI hardware, and this WILL NOT WORK. It might not blow up immediately under certain circumstances, but it will surely get you into trouble if you are mixing drivers, and it will very likely blow up even if you don't.

Such a "solution" is not supported.
You are absolutely right! The only solution is to get these Radeon-Cards work with the native OS4.1 pci drivers because:
1. the 68k driver is too slow
2. it is not compatible with the supported hardware of the os4.1 native driver

So it is not a "Solution" it is a hack. Is ELBOX not involved in the driver development of OS4.1 ? If not I am confuesed because they are the harware manufacturer....

kind regards

Harald
Post Reply