Page 1 of 1

Problems with 3.1.4 and CD-Rom

Posted: Mon Jun 03, 2019 1:16 pm
by Wachi
Hello, I have an Amiga 1200 with an A1230 Accelerators/Phase 5: Blizzard 1230 Mk-III FPU/32Mb and a 4xEIDE'99 interface for the IDE controller.
So far and with ROM 3.1.0 I had no problems with the CD-ROM I had in Unit 2 of the 4xEIDE. But when I install the rom 3.1.4 (Kickstart 46.143) and Workbench 45.194 I have a lot of problems and I can not get the CD to work.
I have Devs/CD0 with L: CDFileSystem and tooltypes ACTIVATE=1 DEVICE=scsi.device UNIT=2
4xEIDEPrefs recognizes the unit
But when I insert a CD, nothing appears.
Can someone help me with this, thank you very much in advance.

Re: Problems with 3.1.4 and CD-Rom

Posted: Tue Jun 04, 2019 12:34 pm
by thomasrapp
The second channel of an IDE splitter is not supported by the built-in scsi.device. You have to run the driver software which came with the interface to activate it. In this case it's 4xEIDE.driver.

Re: Problems with 3.1.4 and CD-Rom

Posted: Tue Jun 04, 2019 8:15 pm
by Wachi
That already tried, when installing the driver software 4xEIDE.driver runs at the start of Startup-Sequence and while the CD-ROM is empty everything seems to be going well, 4xEIDEPrefs recognizes the unit.
But the moment you put a CD the computer is blocked and nothing appears.
After trying it in all possible ways, I think the problem is the scsi.device of ROM 3.1.4, as you say.
Although the scsi.device in theory would have to be an advantage instead of a problem. Somehow it does not get along with 4xEIDE.
You would have to change the CD-ROM drive as a secondary from the first channel using an IDE cable from 2.5 to 3.5.
I can also try to replace the scsi.device of the rom with C: LoadModule> NIL: DEVS: scsi.device
If this does not work, I would have to go back to 3.1.0 and 3.1.4 I would put it in a 1200 without cd-rom, but it would be a shame.

Re: Problems with 3.1.4 and CD-Rom

Posted: Wed Jun 05, 2019 11:40 am
by thomasrapp
Wachi wrote:I think the problem is the scsi.device of ROM 3.1.4
This has yet to be proven IMHO. Actiually the eide driver should replace scsi.device completely so that the version of the ROM driver does not matter at all.

I think you should first try without a CD driver. Remove CD0 and any other CD driver from Devs/DosDrivers, reboot and insert a CD. Does it still block?

Then you should try the CD file system which comes with the eide interface. Copy AllegroCDFS to L: and copy CD2 (+ to Devs/DosDrivers. Double click CD2 or reboot. Does it still block if you insert a CD?

I am not sure if AllegroCDFS has configuration options. I would next try AmiCDFS2 from Aminet. It can be configured to not use disk change interrupts but rather poll for disk changes. This might fix the blocking issue.

Re: Problems with 3.1.4 and CD-Rom

Posted: Thu Jun 06, 2019 5:48 pm
by Wachi
I'm sorry, but I can not get this to work ......
Thanks for your help.

Re: Problems with 3.1.4 and CD-Rom

Posted: Sat Jun 08, 2019 10:08 am
by Wachi
Yesterday I was able to get the IDE cable to be able to connect the CF of 44 and the DVD-ROM of 40 on the same cable.
I put the CF 32Gb in UNIT 0 and the DVD-ROM in UNIT 1 as a slave and Devs / DiskImage / CD0 in its place.
Reset the Amiga and the first CD appears on the screen.
I try several data and music CDs and everything works fine.
I tried a game with music and data and it got stuck.
Instalo is software that comes with 4xEIDE and Allegro .
Now all the discs that I tested work perfectly, data dico, music, games with music, CD32 discs, up to a DVD of more than 4Gb of data for Amiga.
It seems that in the end I got it but it was thanks to that I gave up putting the DVD-ROM in UNIT 2 as a Master.
Thank you very much for your help ;)

Re: Problems with 3.1.4 and CD-Rom

Posted: Tue Jun 25, 2019 10:42 am
by WilliamBirkin
I had similar issues. I have a FastATA MKI and with 3.1.4 my Amiga can not see any hard drives or whatever that is connected to the board (rarely and i mean rarely it could actually see the hdd & dvd drive under early startup menu).
Under 3.1 there is no problem at all.

My solution to the problem is just to remove the FastATA board completely and use the Amiga own interface by making the hdd as primary and the dvd-rom drive as secondary. Works 100%. Its fast enough really. Boots every time now without any issues.

I use an Amiga 1200.