OS 3.1.4 - Amiga 1200 with 68030 Card

A forum for Classic Amiga specific support issues.
Post Reply
Thunder43
Posts: 3
Joined: Mon Apr 01, 2019 7:32 pm

OS 3.1.4 - Amiga 1200 with 68030 Card

Post by Thunder43 »

I have an Amiga 1200 with accelorator card DKB Cobra 68030 @ 28 http://amiga.resource.cx/exp/cobra with 128 MB Ram. For this device I bought an OS 3.1.4 set (Kickstart ROMs, floppy disks, ready configured 8GB CF card). I have installed the ROMs and the CF card but the Amiga doesn't boot. When I remove the card, it boots without problems.

Do I still have to install a driver for the card (I have never needed one before under 3.1) or do these accelerator cards not work with the new system, but I can't believe it?

Gulliver
Posts: 25
Joined: Fri Sep 28, 2018 11:29 pm

Re: OS 3.1.4 - Amiga 1200 with 68030 Card

Post by Gulliver »

Hi Thunder43,

Does the Cobra accelerator work on the same Amiga with a 3.1 rom?

Thunder43
Posts: 3
Joined: Mon Apr 01, 2019 7:32 pm

Re: OS 3.1.4 - Amiga 1200 with 68030 Card

Post by Thunder43 »

Yes, with old 3.1 Kickstart I have no problems. All is running fine. With the new Kickstart it does not boot (no CF and no floppy).

User avatar
thomasrapp
Posts: 281
Joined: Sat Jun 18, 2011 11:22 pm

Re: OS 3.1.4 - Amiga 1200 with 68030 Card

Post by thomasrapp »

If you remove the CF card, does it show the insert-disk-screen?

When you switch power on, does the power LED act normally? It should first glow half bright and half a second later change to full brightness. If it does not do this, the Kickstart is not executed.

BTW, the page you linked says "needs firmware update for Kickstart 3.1, otherwise it works only with memory removed". Does it work better if you remove the memory from the card?

Thunder43
Posts: 3
Joined: Mon Apr 01, 2019 7:32 pm

Re: OS 3.1.4 - Amiga 1200 with 68030 Card

Post by Thunder43 »

Thanks for your help. I have found the error now. The shield of the mainboard pressed on the accelerator card and caused a short circuit. Strangely enough the combination Kickstart 3.1 + Workbench 3.1 didn't care. I never had any problems. I bent the sheet metal and now Kickstart 3.1.4 + Workbench 3.1.4 runs without problems with the card and 128 MB Ram.

Post Reply