Scripts don't abort properly in 3.1.4

A forum for Classic Amiga specific support issues.
Gulliver
Posts: 26
Joined: Fri Sep 28, 2018 11:29 pm

Re: Scripts don't abort properly in 3.1.4

Post by Gulliver »

Raziel wrote:@Gulliver
We are still collecting and fixing bugs, as despite what you could think, we had a surprisingly low occurence of them, despite our forecasts.
How are you collecting bugs?
Is there a central place where users can report them or are you doing manual forum scans?
We have an internal bug database where we officially report them, confirm them and test possible solutions.
We do scan Amiga forums (including this one), and perform some internal stress tests and beta deployments that also end up feeding our database.

So you can go and report a bug here, at Amiga.org, EAB, Amigaworld.net, A1k.org, etc. and we will add it to our database and in there it will evolve according to its merits.
All of our team is composed of long time amiga users, and we all visit amiga sites and forums on a daily basis (even several times a day).

User avatar
Raziel
Posts: 957
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: Scripts don't abort properly in 3.1.4

Post by Raziel »

Understood, thanks for the feedback
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg

patrik
Posts: 3
Joined: Thu Dec 17, 2015 11:59 pm

Re: Scripts don't abort properly in 3.1.4

Post by patrik »

Noticed this bug when a failing BlizKick in the first line of S:Startup-Sequence didn’t stop the execution.

User avatar
MMikhail
Beta Tester
Beta Tester
Posts: 52
Joined: Wed Feb 18, 2015 8:06 am
Location: Moscow / Russia
Contact:

Re: Scripts don't abort properly in 3.1.4

Post by MMikhail »

This problem has been solved, solution will be available in the upcoming update.
A1260T/BPPC/BVPPC/128MB/CNET/SCSI/HDD/CDRW/DVD/HPLJ4P/HPSJ6 (AMiGA)

kolla
Posts: 19
Joined: Wed Oct 24, 2018 10:38 am

Re: Scripts don't abort properly in 3.1.4

Post by kolla »

MMikhail wrote:This problem has been solved, solution will be available in the upcoming update.
Which is due when?

This "problem" is rather urgent, scripts need to be abortable or they do much unwanted things. The only current alternative is to downgrade Shell-Seg.

It would be very much preferable that such serious bug fixes are taken care of swiftly, with updates available ASAP, instead of having to wait and wait and wait and wait for enough bugs to be fixed to justify a "boingball" release.

kolla
Posts: 19
Joined: Wed Oct 24, 2018 10:38 am

Re: Scripts don't abort properly in 3.1.4

Post by kolla »

Happy half-year birthday, dear reported bug!

Post Reply