Page 1 of 1

New Mediator 1200 TX and OS 41 Final Edition

Posted: Sun Mar 04, 2018 1:45 pm
by ralph.egas
Hi all,

Recently I've acquired a nice Elbox case together with Mediator 1200 TX and 4 PCI cards from
* Radeon 9200 128 MB
* Fast Ethernet RTL8139
* Soundblaster 128 4.1
* Spider II USB

I've built everything from those parts, my Amiga 1200 board, a simple IDE on board controller for CF + CD, etc. The system works and I'm running in 1920x1080 true color.

So, the Radeon was recognised automatically, but so far I've not been able to get any of the other PCI cards working.

First I tried the MMCD and update for the Mediator board provided by Elbox. Later it turned out the drivers only work for OS 3.1 - 3.9 and that OS 4.1 has its own means of dealing with a PCI bus board. All good. However, there's close to zero documentation from Elbox or anywhere else where I've looked.

This is what I run into right now:

Ranger reports all PCI cards with correct types in the order as pointed out at the top of this post.

Ethernet: doesn't find the card at unit 0. Then again, the driver that's part of OS 4.1 is called 'RTL8059', not 'RTL8139'. On the other hand, there's no 8139 to be found anywhere (where I've been looking so far)

Soundblaster: although AHI is part of OS4.1, somehow isn't distributed by hyperion as part of OS 4.1. I found one on OS4Depot and I may try this one later, but I'd rather first get ethernet to work to save money and effort on burning CD's for just a few files every time I try something ;).

Spider: don't know where to find OS 4.1 drivers to begin with. I've installed Poseidon 4.4, but the accompanying driver from Elbox called spider.device apparently talks to the pci.library from MMCD that's incompatible with OS4.1. Using pci.library in any way indeed leads to an immediate system hang. Makes sense if OS 4.1 has its own (protected) way of dealing with PCI hardware where pci.library would interfere and cause memory overwrites and/or race conditions.

Apart from the above I must say I'm super excited to seeing my A1200 running OS 4.1 on a high resolution. Dare I say it's even more 'fun' than playing with my X5000 ;)

Anyway, any suggestions are appreciated to getting my PCI cards working!


Re: New Mediator 1200 TX and OS 41 Final Edition

Posted: Mon Mar 05, 2018 10:24 am
by smf
Nice setup you got there.
unfortunately your rtl8139 and spider will not work out of the box because they require DMA and the mediator doesn't really have it.
You probably can install Elbox PCI drivers and use their DMA hack but this is something i have never bothered to do so i lack knowledge about it but i know it has been done before.

Your SB128 will probably work with the driver you found on OS4depot (it works for me)
For ethernet you could get another card based on the 'RTL8029 and use that driver.

Re: New Mediator 1200 TX and OS 41 Final Edition

Posted: Mon Mar 05, 2018 12:38 pm
by ralph.egas
Hi smf,

Thanks! I'm very happy with them rigs, yes ;)

Aha, I understand about DMA lacking. That's unfortunate. Wish would have stated OS3.x/4.x support clearly per PCI card. Not biggie as those cards aren't that expensive.

I've just ordered an rtl8029 through eBay. Hard to get by elsewhere and found this one thankfully.

So, for the spider card there's no real alternative you know of? I have my Subway working now on the A1200 clock port, but it's rather slow. Inserting a USB stick and having it mount takes about 2 minutes where the whole system is practically unresponsive. The benefit of using the Subway still is of course that I was able to route it to top from panel ;). Still, I'd prefer higher speed USB through PCI, assuming it would be faster than the Subway to begin with.

The SB128 is indeed recognised and I've been able to set frequency on Music and both frequency and channels on both on Unit 0. So, that's looking good. 2 problems though and you may recognise them: 1) I don't hear a thing out of my speakers (whereas my X5000 does make some noise using the same cable and speaker setup) and 2) When I run the Prefs/Sound and I try play back a sample, I can't close the Sound app anymore, so it seems to be hanging internally in the app. This suggests the sound app is waiting for the hardware to respond through the driver I'd say. Any ideas?

Mind you that I haven't been able to update the OS online as I haven't got Ethernet to work yet, nor am I able to hookup my wireless lan PCMCIA card yet as I'm waiting for the PCMCIA 90 degree adapter. So, it might be that once I'm able to live update the OS, the SB128 starts working. Not sure. I have the Enhancer Software installed as well.

Anyway, thanks again for your feedback!