XSurf100 + RapidRoad USB & Mouse Wheel Problems

A forum for Classic Amiga specific support issues.
Post Reply
ancalimon
Posts: 35
Joined: Tue Oct 18, 2011 7:31 am

XSurf100 + RapidRoad USB & Mouse Wheel Problems

Post by ancalimon »

RapidRoad USB problem:

I can not get the Mouse Wheel, third mouse button, fifth mouse button and the right-left scroll buttons to work on my AmigaOS 4.1 installation. I installed Poseidon 4.5 and deleted the line it inserted at the beginning of my Startup-Sequence. (it wasn't replacing input.device anyway). How do I add Wheel support to OS4.1? I saw that there was an option for wheel inside Input Prefs but I guess it's for mouse connected to Amiga's mouse port?. Do I need Freewheel to add support for wheel? What about MUI? Doesn't MUI4 support wheels out of the box?


XSurf100 problem:

First of all the I tried the 020 version of XSurf100.device. It caused a freeze in between 5 seconds to 30 seconds after AmigaOS4.1 finished booting. I managed to load aminet and os4depot a couple of times but trying to download anything caused a freeze. After removing it from interfaces, the freeze was no longer there.

I tried adding x-surf-100.device to compatibility list. It did not change anything. Then I decided to try other versions. First I tried the 040 version. It froze the system. Then I tried the one named x-surf-100.device_030z3fd and it's working at the moment and I have updated my AmigaOS4.1 installation (although I sometimes get a frozen AmigaOS When Workbench screen appears or sometimes when WBStartup programs are loading). I will try the x-surf-100.device_030z3nd later to see if anything changes.

Could this be happening because of dirty Zorro slots? I also have the following problems with OS3.9: (but not with XSurf100 and RapidRoad. They are working perfectly on OS3.9)
1) Toccata sound card's left channel almost muted
2) ZorRAM256 causes a reboot a few seconds after I start copying stuff to RAM (this does not happen with OS4.1 for some reason)
User avatar
danbeaver
Posts: 367
Joined: Thu Jan 19, 2012 9:58 pm
Location: Someplace you'd rather not be
Contact:

Re: XSurf100 + RapidRoad USB & Mouse Wheel Problems

Post by danbeaver »

I don't know about all the other mouse buttons, but yes you need Freewheel for scroll support.

The other issues don't sound like an OS4.1 problem, but it would help if you separated them into individual threads.
User avatar
thomasrapp
Posts: 290
Joined: Sat Jun 18, 2011 11:22 pm

Re: XSurf100 + RapidRoad USB & Mouse Wheel Problems

Post by thomasrapp »

FreeWheel is surely not the right software for OS4.

OS4 already supports mouse wheel moves, but Poseidon does not support OS4.

All you need is an input handler which translates IECLASS_NEWMOUSE into IECLASS_MOUSEWHEEL.

I don't know if AllKeys can do this.
ancalimon
Posts: 35
Joined: Tue Oct 18, 2011 7:31 am

Re: XSurf100 + RapidRoad USB & Mouse Wheel Problems

Post by ancalimon »

Fixed ZorRAM by cleaning Zorro slots.

Freewheel at the moment does the job but it's not elegant.

I guess Poseidon will never support OS4.
User avatar
danbeaver
Posts: 367
Joined: Thu Jan 19, 2012 9:58 pm
Location: Someplace you'd rather not be
Contact:

Re: XSurf100 + RapidRoad USB & Mouse Wheel Problems

Post by danbeaver »

Poseidon works fine in OS4.1, as does freewheel; I could never get native OS4.1 scroll support to work on my A4000T.

Without Poseidon the E3B boards except the Subway would never work, including the Deneb.
User avatar
thomasrapp
Posts: 290
Joined: Sat Jun 18, 2011 11:22 pm

Re: XSurf100 + RapidRoad USB & Mouse Wheel Problems

Post by thomasrapp »

Here is a program which properly translates NewMouse events into native IECLASS_MOUSEWHEEL events. Could not test with Poseidon, but it works in WinUAE.

Remove FreeWheel.

Then run nm2mw from a Shell window. If it works, put this into your user-startup:

run >nil: *>nil: nm2mw
Attachments
nm2mw.lha
(2.39 KiB) Downloaded 2201 times
ancalimon
Posts: 35
Joined: Tue Oct 18, 2011 7:31 am

Re: XSurf100 + RapidRoad USB & Mouse Wheel Problems

Post by ancalimon »

Wheel is working now without Freewheel. Once again Thomas to the rescue. Thanks! :)

I have put it right after psdstackloader (the command that runs Poseidon. I don't remember the exact name so I might be wrong). May I ask what *>nil: is for?

I have also configured the Vertical wheel of my Logitech G7 using Trident and that's working as well.

Now I will mess with the fourth mouse button to see if there any way to configure it to do something useful.

By the way, for those having problems with X-Surf100 freezes under OS4.1. Using x-surf-100.device_030z3nd seems to work best. You will get the minimum number of freezes using that version. Although speed is not as fast as under OS3.9
User avatar
thomasrapp
Posts: 290
Joined: Sat Jun 18, 2011 11:22 pm

Re: XSurf100 + RapidRoad USB & Mouse Wheel Problems

Post by thomasrapp »

ancalimon wrote:May I ask what *>nil: is for?
It redirects the error output channel. In order to detach a program from the current CLI window, all output channels have to be redirected. >NIL: only redirects the standard output.
Now I will mess with the fourth mouse button to see if there any way to configure it to do something useful.
May I hint again towards AllKeys. If Poseidon feeds input events for the additional buttons into input.device, then AllKeys should be able to remap them to something useful IMHO.
ancalimon
Posts: 35
Joined: Tue Oct 18, 2011 7:31 am

Re: XSurf100 + RapidRoad USB & Mouse Wheel Problems

Post by ancalimon »

Does anyone have an idea why the x-surf-100.device_020 version causes freeze, while the x-surf-100.device_030z3nd (1.11 - 16/09/13) that has a size of 17332 bytes is working without freezing the Amiga?

The 020 version is at least 10 times faster. (I can download at nearly 1mb per second on my 10megabit connection. But It freezes after a while.

Is it possible to fix 68k emulation so that x-surf100 020 version works if it's a problem with emulation? I will try testing more to determine if it's a problem on my hardware. Maybe a termination problem or heating problem...
Post Reply