Acard 7730A Media Toolbox problem

A forum for Classic Amiga specific support issues.
Post Reply
Posts: 35
Joined: Tue Oct 18, 2011 7:31 am

Acard 7730A Media Toolbox problem

Post by ancalimon »

When I run HD ToolBox using OS3.9, I can see two harddrives. The IDE one connected using Acard 7720UW and the Sata one connected using Acard 7730a.

Using OS4 Media Toolbox, I get this:

Every time I open Media Toolbox in expert mode, it says the following:
Automatic Adjust
Some drives have been either removed or added to your system.
Do you want to update your disk configuration to reflect these changes?
"More Information" displays the following:
Unit 10 (ATA SAMSUNG HD501LJ), is no longer last LUN.
Unit 10 (ATA SAMSUNG HD501LJ), is no longer last disk.
Unit 10 (ATA SAMSUNG HD501LJ), is no longer last unit.
The suggested answer is "yes". After clicking yes, it says modified for all the LUNS expect the last one (ID10, Lun6) which is "Ready"

That's another problem. I have 7 different Samsung HD501LJ's displayed. I can edit them each one differently and the changes I make to one of them does not reflect to the other ones (I can update a filesystem on one of the luns but it won't change on another one). On CyberStormPPC early boot menu, I have chosen 1 LUN for the three devices I have and not 7 LUNS (or 8 LUNS). Maybe the harddrive is incompatible. Or it's a problem with the Acard 7730A. I can not say. I will try another SATA hdd but I don't have any spare one at the moment.

I have the following devices in the following order:

Acard 7720UW (IDE Seagate 160GB) Termination Jumper: ON Term Power Jumper:ON ID set to : 6
Acard 7730A (Sata Samsung 500GB) (There are no jumpers for termination or term power. Only for choosing ID) ID set to: 10
CyberstormPPC (ID 7)
Yamaha CRW8824S 50pin SCSI CDWRITER (Termination OFF)
Termination that at the end of the cable. (it's part of the cable which I got from AmigaKit. I also have another cable that doesn't have any termination on it)

By the way, I think the termination is not working properly because I can get maximum 11mb per second. I have bought two terminators and waiting for them to be posted to me.

I am using the SCSI CDWRITER on my CyberStormPPC using a basic 50pin to 68pin converter and nothing else. I don't know what to use to stop it from slowing the bus down (maybe some kind of different terminator?) but even if I don't use it, the bus is slow anyway probably because either the terminator on the cable or the terminator on Acard 7720UW (or both) is not working properly.

I have to use this CD device because I am having problem with the A4000T IDE device. It sees most of my harddrives only if I patch the scsi device and reboot. Even then I may have to plug two different drives and what works or not is totally random. I couldn't get the IDE CDROM to work with my A4000T. I would simply get Insert OS4.1 Update 2 requester if I tried to install OS3 from the IDE CDROM. I tried ejecting the cdrom and reinserting it the requester disappeared and appeared again after like 0.1 second.
User avatar
Posts: 367
Joined: Thu Jan 19, 2012 9:58 pm
Location: Someplace you'd rather not be

Re: Acard 7730A Media Toolbox problem

Post by danbeaver »

The Acard devices work in general, but add a layer of complexity to your bus; try to get one at a time working and make sure both ends of your SCSI-3 bus has: Active, Powered, and Wide termination (there are explanations all over the forums on this). The CD drive runs are SCSI-2 Speed and will slow down transfers to that speed; you don't say this is in an A4000, but a better solution is to put slower drives on the IDE bus, which are cheaper than the SCSI ones. The IDE drive you used previously sounds like it was the problem, not the bus, but check to see if it was set to Master; sometimes a SLAVE drive is not seen (although IDEFix'97 usually works here).

Try to break up several problems into their own threads as l:-)jumped altogether they are intimidating.
Post Reply