AmigaOS 4.1 Final Edition for classic

A forum for Classic Amiga specific support issues.
Lio
Posts: 46
Joined: Tue Sep 13, 2011 8:07 pm

Re: AmigaOS 4.1 Final Edition for classic

Post by Lio »

so now that AOS4.1 FE is released can anyone list what classic owners will benefit from it besides the new shell ?
do we get scsi support for blizzardppc ?
do we get a working 3D driver for permedia2 ?
those are the minimal requirements for me to buy it, because as I wrote before, these are crippling my experience ! IBrowse needs 20 sec to be loaded the first and 6 sec the 2nd time, wtf ?? Amidock is not very responsive, when I click on something there is always a delay of 2-3 sec before something happens.
User avatar
DarrenHD
Beta Tester
Beta Tester
Posts: 635
Joined: Mon Dec 20, 2010 3:38 pm
Location: London, Ontario, Canada
Contact:

Re: AmigaOS 4.1 Final Edition for classic

Post by DarrenHD »

Lio wrote:so now that AOS4.1 FE is released can anyone list what classic owners will benefit from it besides the new shell ?
do we get scsi support for blizzardppc ?
do we get a working 3D driver for permedia2 ?
those are the minimal requirements for me to buy it, because as I wrote before, these are crippling my experience ! IBrowse needs 20 sec to be loaded the first and 6 sec the 2nd time, wtf ?? Amidock is not very responsive, when I click on something there is always a delay of 2-3 sec before something happens.
Some of the new features are:

-Experimental Support for GREX 1200/4000 - Voodoo3 and RTL8029 network cards work.
-Radeon 9250 now works on Prometheus PCI / Firestorm PCI
-changes to mediator memory allocation so more Zorro / PCI board combinations may work (eg. not run out of address space).

There already exists a Permedia2 Warp3D driver, it is on the CD. If there are specific bugs with it I can forward them to the development team.

There is no Blizzard PPC scsi driver. We made many attempts to find a programmer who a) has the skills, b) has the time, c) is willing to actually write it, but we were unable to find someone to do it. If you know of such a person please let us know.

In terms of your computer's responsiveness, what spec computer do you have?

Darren
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
User avatar
davebraco
Beta Tester
Beta Tester
Posts: 140
Joined: Sat Jun 18, 2011 7:06 am
Location: Belgium

Re: AmigaOS 4.1 Final Edition for classic

Post by davebraco »

do we get scsi support for blizzardppc ?

No
do we get a working 3D driver for permedia2 ?
I don't know what you mean by working. Having a mediator, i've switched to a Radeon9250 card.

MUI is loaded too the first time you start iBrowse (or any other MUI program). That's why it's longer.

About AmiDock, I think it's the same delay as if you double click an icon in a Workbench window. (At least it's like that on my 1200)
µA1 256mo SATA -> lend to a dev
A1200PPC 256Mo MediatorTX Radeon9250 SATA RTL8029 SOLO-1
Sam440ep 533mhz 512mo 64Go SSD
Sam460ex 1150mhz 2Go RadeonHD 6570LP ENVY24HT
AmigaOne X1000 4Go SSD R9 270X Catweasel MK4
AmigaOne X5000 -> work in progress
Lio
Posts: 46
Joined: Tue Sep 13, 2011 8:07 pm

Re: AmigaOS 4.1 Final Edition for classic

Post by Lio »

here is what I wrote on page 2 :
Lio wrote:Thanks for your answer (you are the only one in the dev team apparently taking care of my request (or at least giving me answers) which is disappointing from a user/customer POV)

Indeed I have W3D_permedia.library in Warp3D/HWdrivers and I also have Avenger, Napalm R200 and Radeon.

I tried CubeBM and the window closes immediately :x
strangely enough I launched snoopy and then cubeBM and suddenly the window appears (and stays) with the rotating cube.
after reboot, it is working right away, go figure !!!
so I got 2039 frames in 13.1 sec (329 fps/159 fps with swap)

gears_ppc is also working (with gltiches when pressing F to get the fps), the screen, window gave 30 fps vs 35 fps for window_small.

Quake 2.40 in 640x480 clut8 gave graphical glitches (jumping screen) and 6.4fps with timedemo demo1.dem
Quake2 in 640x480 with degraded sound (11025) gave a timerefresh of 6.1fps right a the start vs 5.6fps in software mode with the same resolution/settings !

ok so the good thing is that the 3D driver is indeed present and working but the bad thing is that 3D games do not benefit from it...
I am NOT going to upgrade to a Mediator because I have already a ZorroIV bus carrying my CatWeasel2 and XSurf3, and I am not going to upgrade to FastATA because I have the SCSI from the BPPC.
So I guess the FE will not change the behavior/unresponsiveness of my system and that I probably benefit better from AOS3.9 (and even from the old MorphOS 1.4.5), which is really sad.

About my config : I have the fastest (not overclocked) BPPC (PPC240/060+SCSI) and Permedia2 and 192Mo of FAST.
User avatar
walkero
Site Admin
Posts: 57
Joined: Mon Dec 20, 2010 2:05 pm
Location: Athens/Dublin
Contact:

Re: AmigaOS 4.1 Final Edition for classic

Post by walkero »

@lio
I have a BVision on my system and I think that warp3d works just fine the last time I checked it. Do you have problems with a specific program/game? Which one, so that I can test it too.
If you develop or want to develop for AmigaOS 4.x, then join us at OS4Coding.net
Lio
Posts: 46
Joined: Tue Sep 13, 2011 8:07 pm

Re: AmigaOS 4.1 Final Edition for classic

Post by Lio »

@ walkero : just read what I wrote above and test Quake and Quake 2 and you will see the problems.

what software/game did you use for testing ? for me the 3D performance are miles away below AOS3.9+Warp3D, which is really a shame from what is supposed to be the successor (which imply better) !
User avatar
Karlos
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 84
Joined: Sun Jun 19, 2011 11:42 am
Location: United Kingdom of England and anybody else that wishes to remain.

Re: AmigaOS 4.1 Final Edition for classic

Post by Karlos »

@Lio

Sorry to hear you are having such sub-optimal experiences with the Permedia2.

What I can say is that the Warp3D driver itself is, unquestionably faster than it was in OS3.9 (I have the synthetic benchmarks to prove it), especially for v1-v4 rendering functions. There's no comparison for v5 rendering functions because there aren't any v5 functions in the version for OS3.9

The biggest software issue for Permedia2 systems is MiniGL2. Please bear in mind that this version was written on and for machines with Radeon / Voodoo class graphics cards. There are numerous examples of software that runs fine on Radeon R200 but struggles on R100. And the R100 is much faster and more capable than the Permedia2. Many applications simply assume a minimum 3D feature set that the Permedia2 cannot support and either fail totally, or render with badly broken visuals.

In fact, the driver was extensively unit tested against during development and for API clean applications (no context hacking, which sadly makes some old demos a bit flaky) that take care to respect the limitations of the hardware, performs very well. Unsupported features aside, it's one of the most complete drivers.

For MiniGL 1 applications, the experience is faster and more compatible as they assume a feature set more in keeping with what is actually available. For example, here are two windowed copies of the WarpUP MiniGL 1 gears demo running concurrently with a 68K lens application (note, this lens application does not use HW acceleration for scaling):

https://www.youtube.com/watch?v=xglmLuFZrjU

For me, the same experiment is significantly slower on OS3.9 on the same machine as the context switch overhead dominates the two WarpUp applications.

As a comparison, here's the same MiniGL gears demo running against the MiniGL 2 version:

https://www.youtube.com/watch?v=XKuXF48HiRQ

This not to say that MiniGL 2 is inherently bad; ironically, the issues that make MiniGL2 slow on Permedia2 tend to make it faster and more scalable on higher spec hardware.
User avatar
Karlos
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 84
Joined: Sun Jun 19, 2011 11:42 am
Location: United Kingdom of England and anybody else that wishes to remain.

Re: AmigaOS 4.1 Final Edition for classic

Post by Karlos »

@Lio
PS Running Quake2 in CLUT mode will use software rendering. Although the Permedia2 can do 3D operations on 8-bit screens (limited, no shading, 8-bit textures only), There's certainly no support for 8-bit render targets in MiniGL.

Also see:

http://wiki.amigaos.net/wiki/UserDoc:Warp3D#Permedia_2
nyteschayde
Posts: 2
Joined: Mon Jan 23, 2012 10:08 am
Location: California
Contact:

Where can I setup a login for AmiUpdate?

Post by nyteschayde »

I got OS4.1 FE working on my machine. It seems to download files fine from AmiUpdate, but it then prompted me for a login and password and there was no indication as to where I would ever have made that account. Any ideas?
User avatar
davebraco
Beta Tester
Beta Tester
Posts: 140
Joined: Sat Jun 18, 2011 7:06 am
Location: Belgium

Re: AmigaOS 4.1 Final Edition for classic

Post by davebraco »

nyteschayde , you have to create an account on www.hyperion-entertainment.biz et register your final edition. The login/password of the website are the one to use with amiupdate.
µA1 256mo SATA -> lend to a dev
A1200PPC 256Mo MediatorTX Radeon9250 SATA RTL8029 SOLO-1
Sam440ep 533mhz 512mo 64Go SSD
Sam460ex 1150mhz 2Go RadeonHD 6570LP ENVY24HT
AmigaOne X1000 4Go SSD R9 270X Catweasel MK4
AmigaOne X5000 -> work in progress
Post Reply