Windows fadeout flicker

A forum for general AmigaOS 4.x support questions that are not platform-specific
Post Reply
Deniil
Posts: 108
Joined: Mon Jul 11, 2011 6:59 pm

Windows fadeout flicker

Post by Deniil »

Not sure if this have been filed or fixed but since it wasn't fixed between update 2 and 3 I thought I'd file it here.

When a window is set to fade away when closed (like for example http://www.onyxsoft.se/files/mplayergui.lha which is hardcoded to do this), the window often flashes back to full opacity just the moment is it closed.

I believe the reason for this is that just as the window is to be removed the parent (or next or whatever) window becomes active. This makes the closing window inactive triggering a redraw of the window frame or something which happens at full opacity just a fraction of a second before it is removed from the screen.

Or perhaps the fadedown overflows into a negative number resulting in full or almost full opacity just before closing.
User avatar
Raziel
Posts: 980
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: [BUG] Windows fadeout flicker

Post by Raziel »

I had this behviour with upd2 and AutoPoint running.
it was reproduceable avery time i move the mouse away from MPlayer-GUI.

Alas i cannot trigger this behaviour at all anymore, not even with AutoPoint...fades away smootly
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Deniil
Posts: 108
Joined: Mon Jul 11, 2011 6:59 pm

Re: [BUG] Windows fadeout flicker

Post by Deniil »

I always start MPlayer-GUI from an auto-closing subdock. It seems like it mostly happens when closing MPlayer-GUI when started from there.
User avatar
Raziel
Posts: 980
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: [BUG] Windows fadeout flicker

Post by Raziel »

Deniil wrote:I always start MPlayer-GUI from an auto-closing subdock. It seems like it mostly happens when closing MPlayer-GUI when started from there.
The it will probably only happen when some other window(?)/subdock is being closed right before MPlayer is closed?

Does it happen for you if you open/close MPlayer-GUI from its icon?
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Deniil
Posts: 108
Joined: Mon Jul 11, 2011 6:59 pm

Re: Windows fadeout flicker

Post by Deniil »

In the short tests I did I couldn't reproduce it when starting from the icon. Tried different combinations of starting, closing the parent WB window, closing MP-GUI and stuff. Did test very thoroughly though.

But the subdock of course closes pretty much immediately when I start MP-GUI since it closes automatically. MP-GUI itself I may close hours later after having opened and closed dussins of other windows. Hard to tell exactly what's causing it. MP-GUI itself is a normal RA GUI window without any trickery AFAIK.

I'll try to create a reproducible test case, although in normal uses (i.e. not just start and close) it always happens for me.
Post Reply