Page 2 of 2

Re: [BUG] SWAP broken

Posted: Sat Dec 17, 2011 8:14 pm
by Deniil
Would be interesting to know where I got this VIRTUAL stuff from then. All allocations in Annotate for example I made with VIRTUAL|PRIVATE for some reason a number of years ago. I've changed it now though.

But if VIRTUAL is ignored as an AllocMem flag I guess that mem would have been PRIVATE and swappable after all.

When the migration guide was written the swapping was not yet implemented I assume, so then it wasn't 100% sure what state SHARED would have. Maybe there is some technical limitation not yet built around that makes it much easier to just lock all SHARED memory (for now?).

Re: [BUG] SWAP broken

Posted: Sun Jan 01, 2012 9:58 am
by Raziel
sundown wrote:The SWAP problem hase been fixed. My settings follow;

SWAP
Blocksize=4096
Buffers=10
Maxtransfer=7FFFFFFF (7 Fs)
Mask=FFFFFC

Not sure why the buffer setting is low, guessing default, but it does work. I can copy a 1.4GB file to RAM without problems now, crashed the system before the fix.
Just to be sure...

Are you certain that this works for you and stays after clicking OK?
Maxtransfer do work here (alhough i'd rather use FFFFFFFF [8F's] as with all my partitions), but if i set Mask to your value it always jumps back to 7FFFFFFC after clicking OK and returning to "Edit Partion details"?

Why is that and what does your Mask setting actually use then?
Any memory = 7FFFFFFF
Any memory (32 bit) =7FFFFFFC
24 bit DMA memory = ??? (greyed out here)
??? = your setting

Could it be that you accidently switched mask and maxtransfer in your post?

Thank you

edit: added information