Swapping with 4.1.update 3 hardly works at all.

A forum for general AmigaOS 4.x support questions that are not platform-specific
Post Reply
Deniil
Posts: 108
Joined: Mon Jul 11, 2011 6:59 pm

Swapping with 4.1.update 3 hardly works at all.

Post by Deniil »

Don't know if this has been officially reported or acknowledged yet so I'll put my story here.

Since OS4.1.3 the swapping has gone from fairly ok to almost useless. With update 2 I could go pretty deep into the swap, and back without issues. Only sometimes it just stopped swapping after a while if it was just too much out of memory and nothing more could be swapped out or whatever (I couldn't possibly know which).

But with update 3 it seems that swapping out stuff works ok as before, but it seems that when a swapped out page is referenced or freed (as when quitting the program running out or memory) the machine just locks up hard with a buzzing sound and only the reset button works.

This is obviously annoying since MUI-OWB uses a lot or ram, especially when browsing images, and other situations as well, like large compiles or huge images or whatever combination of this. This used to work nicely with update 2 (unless I overdid it and forced the machine onto its knees), but with update 3 I will get a certain lockup soon after I notice the swapper has kicked in.

AmigaOne-XE G4, 512MB RAM, SII680 with 2 PATA-disks.
Deniil
Posts: 108
Joined: Mon Jul 11, 2011 6:59 pm

Re: Swapping with 4.1.update 3 hardly works at all.

Post by Deniil »

Since non of these swapping (or whetever it is) problems seem to have been acknowledge or even commented on by the core developers I thought I'd bump this (third or fourth) thread on the subject as well.

MUI-OWB is obviously a bad test case for memory outage so I made this one instead:
http://hem.bredband.net/deniil/files/swaptest.lha

Extremely simple CLI tool with C source that can be run without startup-sequence to test and demonstrate allocations, swap attempts and using swapped out memory. It kind of feels like the developers would already have something like this, but considering this severe bug it doesn't look like it.

Not sure about the OS4 internals I wonder if the pager refuses to swap out memory from the same task that asked for more? Because of this possibility (that I still doubt) it may be a good test to run two instances of my test program. One that allocates most memory, and then another one that run out and cause swapping.
User avatar
tboeckel
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 68
Joined: Mon Jun 20, 2011 8:56 am
Contact:

Re: Swapping with 4.1.update 3 hardly works at all.

Post by tboeckel »

There has been a bug in virtual memory handling which was introduced with update #3 and will be fixed with update #4. Most probably this bug is guilty of causing most virtual memory/paging related issues.
Deniil
Posts: 108
Joined: Mon Jul 11, 2011 6:59 pm

Re: Swapping with 4.1.update 3 hardly works at all.

Post by Deniil »

Thank you for the answer! :-)
Glad to see it being taken care of.
Post Reply