Overall system speed question.

A forum for general AmigaOS 4.x support questions that are not platform-specific
User avatar
Tuxedo
Posts: 38
Joined: Fri Jun 17, 2011 10:44 pm

Re: Overall system speed question.

Post by Tuxedo »

interesting...
However in programs like lame or blender wasnt so noticeable difference...
I found it only in programs that usese DataTypes...atm...
User avatar
Tuxedo
Posts: 38
Joined: Fri Jun 17, 2011 10:44 pm

Re: Overall system speed question.[UPDATE]

Post by Tuxedo »

update...
Andreas says on Hollywood ml that maybe the speed difference can be related to a different speed/optimisation of the "fetching Intuition events" that Hollywood fetches often to stay responsive on MOS and AmigaOS4.x...

Any dev reading and can reply to that?

Thank you!
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 1438
Joined: Wed Mar 09, 2011 1:36 pm
Location: Sydney, Australia

Re: Overall system speed question.

Post by tonyw »

You won't get an answer because only an expert on both systems can find out why there is a difference, and there are no experts in both OSes with access to the code base of both. Thus, each side can only make guesses.
cheers
tony
User avatar
Tuxedo
Posts: 38
Joined: Fri Jun 17, 2011 10:44 pm

Re: Overall system speed question.

Post by Tuxedo »

@tonyw

that's right...however I'm not looking for a real answer I only hope that pointing on that problem will give developers a motiviation to optimize/improve AmigaOS4.x :)
Only that :)
Locked