Overall system speed question.

A forum for general AmigaOS 4.x support questions that are not platform-specific
User avatar
Tuxedo
Posts: 38
Joined: Fri Jun 17, 2011 10:44 pm

Overall system speed question.

Post by Tuxedo »

Hi,
as someone here may know I'm the developer of the utility LoView.
I tryed my app under MOS 2.7 on my machine(Pegasos2 2GB G4@1131) and I noticed a weird thing...

Loading big pics (I tryed with some 10mpx pictures), the loading times was really different...

I get 1.628 on overall from about 10 loadings of the same pics(doing the test by go forward and reward 10 times) on AmigaOS4.1 Update3(but on Upd2 I get the same).

On the MOS 2.7 install I get an overall time of 1.33 so about 20% faster...

Any idea on why?

I repeated the test in RAM: and on the same SFS volume but the times was quite equal so no matter of filesystem I thnik.

Thank you.
kas1e
Beta Tester
Beta Tester
Posts: 483
Joined: Sat Jun 18, 2011 7:56 am
Contact:

Re: Overall system speed question.

Post by kas1e »

@Tuxedo
As benchmarked many times , morphos on the same hardware almost in all the areas faster than amigaos4. Somethere faster on 5%, somethere on 20%. There was nice benchmark article from Obligement, which show the differences pretty clear. While in that article compared plain amigaos4.1 vs morphos 2.3, i found that results are still the same in most areas. Some of them start to be faster (usb, gfx), some of them slower (coping, starting of os). Will be nice to re-benchmark it again on the latest versions of oses.

The conclusion of the article was:

"With 228.5 points against 164 for the MorphOS AmigaOS 4.1, the comparison turns sharply to the advantage of MorphOS. Taking the average, this represents 9.93 / 10 for the system to the butterfly and 7.13 / 10 for the one to the ball bouncing. Almost all areas are favorable for MorphOS in terms of performance (start, USB, desktop, 3d, 68k emulation, emulation and WarpOS Warp3D, etc.)..

Contrary to what I wrote initially, AmigaOS 4.1 on Pegasos II is not in beta. The fact remains that it is the first version of this system for Pegasos II. Does the AmigaOS 4.x improve on this equipment? Maybe or maybe not. Meanwhile, there is less optimized than MorphOS. Finally, we note that the performance of some tests is due to how the software was compiled at the system itself. "

In other words, there is only one answer can be "its a bit slower, because its just like this for now". I hope that it all will be optimised in the future of course, but for now we can only live with it.
kas1e
Beta Tester
Beta Tester
Posts: 483
Joined: Sat Jun 18, 2011 7:56 am
Contact:

Re: Overall system speed question.

Post by kas1e »

Btw, if you in intrest, there is some small benchmark-tests for comparing mos2.5 and aos4.1u3. I compare RAM, usb1.1 (because default ports of peg2 are usb1.1) and booting.
User avatar
Tuxedo
Posts: 38
Joined: Fri Jun 17, 2011 10:44 pm

Re: Overall system speed question.

Post by Tuxedo »

Hi!
I read Obligement and your tests, however my question was about why on AmigaOS4 there was so big difference...
Possibly optimized AltiVec DataTypes? or picture.datatype?

I've also opened a topic on AmigaWorld last year but no os4 devss replyed to it(http://amigaworld.net/modules/newbb/vie ... at&order=0)...

I'm curious on what are os4 devs thinking about that...only that.
kas1e
Beta Tester
Beta Tester
Posts: 483
Joined: Sat Jun 18, 2011 7:56 am
Contact:

Re: Overall system speed question.

Post by kas1e »

@Tuxedo

Maybe you already think about it, so sorry for repeating, but maybe its just AOS4's version of Hollywood are slower (because author use some other methods for different aspects) ? Maybe that can explain differences beetwen ?
User avatar
Tuxedo
Posts: 38
Joined: Fri Jun 17, 2011 10:44 pm

Re: Overall system speed question.

Post by Tuxedo »

Andreas Falkennhan confirm that no opts was made on Hollywood version for MOS so only faster system components can explain that...
User avatar
Tuxedo
Posts: 38
Joined: Fri Jun 17, 2011 10:44 pm

Re: Overall system speed question.

Post by Tuxedo »

An user on Hollywood ml made some tests and I attach that here...

Hope that can help in some way to know what's the problem...

Thank you.
Attachments
TestHolly.png
Hollywood test on various systems
(100 KiB) Downloaded 1394 times
xenic
Posts: 1165
Joined: Sun Jun 19, 2011 12:06 am

Re: Overall system speed question.

Post by xenic »

@Tuxedo
I don't notice a speed difference because I have no other computers to compare with and LoView seems reasonably fast at loading images to me. However, I don't like the fact that my pointer slows down/freezes if I am moving it right before LoView displays the selected image. I don't get any pointer slowdown/freezing when loading pictures with WarpView so I think something is wrong with LoView. I would rather have something (picture/text etc.) load a little slower than to mess with other critical system functions like the mouse pointer.
AmigaOne X1000 with 2GB memory - OS4.1 FE
User avatar
Tuxedo
Posts: 38
Joined: Fri Jun 17, 2011 10:44 pm

Re: Overall system speed question.

Post by Tuxedo »

@xenic

[OT]
hi and thanks for feedback.
[/OT]

I made some fast tests and noticed the pointer slowdown in all the app used...
I tryed LoView, MultiView, PicShow and WarpView...

Try to load big images(like 10Mpx+ photos from cameras and you will see the locks...
On LoView they was a bit bigger but probably because of the waay Hollywood made some internal things where I'm not able to act...

In MultiView and PicShow was a bit better and on WarpView really low but still present here to...

So I think was a problem related to some way of screen refresh or wahtever else...or maybe DataTypes on the first 3 programs was the bigger issue...
But only an OS4 dev can tell taht to us :)
Deniil
Posts: 108
Joined: Mon Jul 11, 2011 6:59 pm

Re: Overall system speed question.

Post by Deniil »

I have an idea why OS4 seem slower in many areas:
Could it be because OS4 uses more memory protection than MOS and therefore the memory access through the MMU is slower because the MMU has more work to do?
Locked