USBCtrl

A forum for general AmigaOS 4.x support questions that are not platform-specific
Post Reply
Gregor
Posts: 88
Joined: Thu Sep 08, 2011 10:44 am

USBCtrl

Post by Gregor »

USBCtrl command seems to have these options:

PREBOOT/S,START/S,RESTART/S,STOP/S,FLUSHLOG/S,FORCE/S

Some of them are self-explanatory, but what do the rest of them mean...?

Regards,

Gregor
User avatar
Spektro
Beta Tester
Beta Tester
Posts: 122
Joined: Sat Jun 18, 2011 6:55 am
Location: Finland
Contact:

Re: USBCtrl

Post by Spektro »

Hi Gregor,
USBCtrl's description can now be found from the AmigaOS Documentation Wiki:
https://wiki.amigaos.net/wiki/AmigaOS_M ... ce#USBCTRL
- Janne Peräaho
Neil_P
Posts: 26
Joined: Sat Jun 18, 2011 1:16 am
Location: Manchester, Britain (United Kingdom)

Re: USBCtrl

Post by Neil_P »

@ Spektro or anyone else with knowledge on this topic

I've just become the owner of a SAM 440ep-flex OS4.1 FE, update 1 system, with a Radeon 9250 card and 1GB of RAM, but I am having issues with USB on this system - apart from the keyboard and mouse ports (with a wired USB2 mouse) - though it doesn't even like my USB2 dongled wireless mouse, as I get no response or recognition for a Belkin USB 5 port PCI 3.3v/5v card that I fitted in the slot below (towards the edge of the motherboard) the Radeon 9250, as that USB PCI card is not found on the system, which is pitiful as this is one of the most widely used PCI USB cards available, and works a treat in my MorphOS PowerMac G5 system, in fact I have 2 of them in each MorphOS/PowerMac G5 system.

I cannot even plug in and have recognised a USB stick/pendrive/flashdrive or SD card adapter in the external slot as I get an "unrecognised" error requester with it, which is really disappointing.

There does not even seem to be any support for hard drives plugged into the case external USB2 sockets, though I can see my Iomega portable drive is found in the USB Inspector but it is not mounted, and there seems to be no way to get this achieved currently. As there are no USB def_Icons for such devices or USB sticks or SD cards in the Env-archive folder, or even in Storage. In fact, so much so, that I am very disappointed that there is such poor support for USB2 on these boards especially after so long for this to be implemented for Amiga OS4.1 FE.

I hope there are some answers to this topic as it is really very frustrating and disappointing that these issues do not seem to have been addressed appropriately previously, and considering these boards and the OS4.1FE has been out so long it really is lacklustre, I am sorry to have to say. :cry:
SAM 440ep-flex 733MHz 1GB RAM, Radeon 9250 PCI, OS4.1FE Upd 1, Amiga A1200 Blizzard SCSi PPC G3 240Mhz/060-50Mhz, 256MB + 200MB -> Radeon 9200 256MB in Mediator TX, + Voodoo 3 3000 16MB, Sound Blaster Live + TT-SOLO-1 soundcards, Spider USB, Ethernet RTL8139 + RTL8029AS, Adaptec 2940UW SCSI.
Post Reply