Jerky mouse with dockies enabled on X1000/Radeon 9250

A forum for general AmigaOS 4.x support questions that are not platform-specific
User avatar
Srtest
Posts: 240
Joined: Wed Jun 11, 2014 5:06 pm

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Post by Srtest »

For some reason I can't explain, linking all libpng.so libraries to libpng16.so.16.20.0 produces better docky performance and maybe even beyond dockies (I also use a bunch of them) while breaking compatibily with some older AOS4 titles (games).

X1000 + Southern Islands + latest drivers - composite and Warp3D on AOS4.1FE.

K-L
Posts: 76
Joined: Thu Sep 08, 2011 8:35 pm
Location: Lyon, France
Contact:

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Post by K-L »

This has nothing to do with the reported problem by the way. You'd better open a new thread about your topic ;)
--
AmigaONE X1000 / Radeon 2400 Pro (R610LE) / AmigaOS 4.1 Final Edition
Samm440ep/733Mhs (o/c) / Radeon M9 / AmigaOS 4.1 Final Edition

User avatar
Srtest
Posts: 240
Joined: Wed Jun 11, 2014 5:06 pm

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Post by Srtest »

K-L wrote:This has nothing to do with the reported problem by the way. You'd better open a new thread about your topic ;)
You reported a jerky mouse in combination with one or more dockies. You reported an issue of performance and multitasking as it relates to that.

What I've found out was an accident (a game reported incompatibility with the newest libpng.so library). After reverting to the version supplied with Final Edition I've noticed somewhat of an operation that is less smooth as can be seen in what I described. Not something that is a main improvement or a so called fix for your situation, just that it might help a little or it might just effect me, ot it might have a bigger effect in your situation (which I didn't exactly experience).

K-L
Posts: 76
Joined: Thu Sep 08, 2011 8:35 pm
Location: Lyon, France
Contact:

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Post by K-L »

Regardin my situation, Hans already replied that this is a bug in the Radeon HD driver (DMA) on AmigaONE X1000.
--
AmigaONE X1000 / Radeon 2400 Pro (R610LE) / AmigaOS 4.1 Final Edition
Samm440ep/733Mhs (o/c) / Radeon M9 / AmigaOS 4.1 Final Edition

User avatar
Hans
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 703
Joined: Tue Dec 21, 2010 9:25 pm
Location: New Zealand
Contact:

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Post by Hans »

K-L wrote:Regardin my situation, Hans already replied that this is a bug in the Radeon HD driver (DMA) on AmigaONE X1000.
Actually, it's DMA in the graphics.libarary, not the driver.

A semi-random thought, could you (and anyone else experiencing the jerkiness) try disabling anti-aliased text rendering? I think that it's in the font preferences (or maybe GUI prefs). Let me know if that reduces the jerkiness.

Hans
http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more. Home of the RadeonHD driver for Amiga OS 4.x project.

User avatar
Raziel
Posts: 964
Joined: Sat Jun 18, 2011 4:00 pm
Location: a dying planet

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Post by Raziel »

Setting font prefs to an unchecked "Antialiasing if possible" shows no difference for me
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg

K-L
Posts: 76
Joined: Thu Sep 08, 2011 8:35 pm
Location: Lyon, France
Contact:

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Post by K-L »

I'd say that it reduces the jerkyness in very subtle way (but I can also reduce the behaviour if I get rid of my dockies).
--
AmigaONE X1000 / Radeon 2400 Pro (R610LE) / AmigaOS 4.1 Final Edition
Samm440ep/733Mhs (o/c) / Radeon M9 / AmigaOS 4.1 Final Edition

zzd10h
Posts: 546
Joined: Sun Sep 16, 2012 5:40 am
Location: France

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Post by zzd10h »

@Hans
"K-L guessed right, it is DMA (and text rendering) related. I can't say when a fix will be released, sorry."

According to Broadblues, DMA fix has been delivered in update 1.
http://amigaworld.net/modules/newbb/vie ... r=0#791508

Effectively, my OS4 seems faster and no more "jerky mouse" symptom.
Thank you !
http://apps.amistore.net/zTools
X1000 - AmigaOS 4.1.6 / 4.1 FE

Post Reply