FE and Copy/Paste crash

A forum for general AmigaOS 4.x support questions that are not platform-specific
zzd10h
Posts: 546
Joined: Sun Sep 16, 2012 5:40 am
Location: France

Re: FE and Copy/Paste crash

Post by zzd10h »

No, except to send the log of course ;)

Maybe that something is wrong in my partition, OK. But even by booting on the CD, it fails.

Is somebody could try by booting directly on the CD on his X1000, please ?

Thank you
http://apps.amistore.net/zTools
X1000 - AmigaOS 4.1.6 / 4.1 FE
xenic
Posts: 1165
Joined: Sun Jun 19, 2011 12:06 am

Re: FE and Copy/Paste crash

Post by xenic »

zzd10h wrote:No, except to send the log of course ;)

Maybe that something is wrong in my partition, OK. But even by booting on the CD, it fails.

Is somebody could try by booting directly on the CD on his X1000, please ?

Thank you
I tested ContextMenu copy/paste when I booted from the OS4.1 FE CD. I opened the SYS:Prefs window, right-clicked on the AHI icon and selected copy from the Contextmenu. Then I opened the RAM: window, right-clicked an empty area in the RAM: window and selected paste from the Contextmenu. AHI was copied into the RAM: window. Sorry, but I am unable to reproduce your problem even when booting from the CD.
AmigaOne X1000 with 2GB memory - OS4.1 FE
zzd10h
Posts: 546
Joined: Sun Sep 16, 2012 5:40 am
Location: France

Re: FE and Copy/Paste crash

Post by zzd10h »

Thank you for your test,
hopefully that Raziel have the same problem than me.

@TonyW
if you need a tester or more elements...
Thank you
http://apps.amistore.net/zTools
X1000 - AmigaOS 4.1.6 / 4.1 FE
zzd10h
Posts: 546
Joined: Sun Sep 16, 2012 5:40 am
Location: France

Re: FE and Copy/Paste crash

Post by zzd10h »

Problem solved by removing "SERIAL DEBUGLEVEL=5 MUNGE" from os4_commandline in CFE !

I thought that these parameters were only used by kernel.debug ?
At least under 4.1.6, it seems that it was the case.

under 4.1.6
My LittleBrother was OK with this line and standard kernel
but it crashed with this line and debug kernel.
(I solved this problem in my program since months )

BUT

1) Is the FE standard kernel a debug kernel ?

2) Is it normal that MUNGE and/or DEBUGLEVEL and/or SERIAL make crash Copy/Paste from ContextMenu ?


Regarding "New text file bug", not better, still crashs !
http://apps.amistore.net/zTools
X1000 - AmigaOS 4.1.6 / 4.1 FE
zzd10h
Posts: 546
Joined: Sun Sep 16, 2012 5:40 am
Location: France

Re: FE and Copy/Paste crash

Post by zzd10h »

@TonyW
Are you around ?

Thx
http://apps.amistore.net/zTools
X1000 - AmigaOS 4.1.6 / 4.1 FE
xenic
Posts: 1165
Joined: Sun Jun 19, 2011 12:06 am

Re: FE and Copy/Paste crash

Post by xenic »

zzd10h wrote:Problem solved by removing "SERIAL DEBUGLEVEL=5 MUNGE" from os4_commandline in CFE

I thought that these parameters were only used by kernel.debug ?
My system has had: "os4commandline=DEBUGLEVEL=5 SERIAL" since the day I bought it. I would guess that it's just the "MUNGE" that is causing the crash. Maybe MUNGE (whatever that is) needs to be fixed.

P.S. There is SYS:Kickstart/kernal.debug in my FE installation but it's not used in the Kicklayout.
AmigaOne X1000 with 2GB memory - OS4.1 FE
User avatar
salass00
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 521
Joined: Sat Jun 18, 2011 3:12 pm
Location: Finland
Contact:

Re: FE and Copy/Paste crash

Post by salass00 »

xenic wrote:My system has had: "os4commandline=DEBUGLEVEL=5 SERIAL" since the day I bought it. I would guess that it's just the "MUNGE" that is causing the crash. Maybe MUNGE (whatever that is) needs to be fixed.
If "munge" option causes a program to crash then that program is buggy and should be fixed. Possible reasons for munge causing a program to crash is if it reads from uninitialised memory or memory that has already been freed.

The whole point of "munge" option is to cause bugged programs to crash in a visible manner so no, it should not be "fixed".
xenic
Posts: 1165
Joined: Sun Jun 19, 2011 12:06 am

Re: FE and Copy/Paste crash

Post by xenic »

salass00 wrote:
xenic wrote:My system has had: "os4commandline=DEBUGLEVEL=5 SERIAL" since the day I bought it. I would guess that it's just the "MUNGE" that is causing the crash. Maybe MUNGE (whatever that is) needs to be fixed.
If "munge" option causes a program to crash then that program is buggy and should be fixed. Possible reasons for munge causing a program to crash is if it reads from uninitialised memory or memory that has already been freed.

The whole point of "munge" option is to cause bugged programs to crash in a visible manner so no, it should not be "fixed".
Then I guess that means that ContextMenu copy/paste does have a bug :-)
AmigaOne X1000 with 2GB memory - OS4.1 FE
User avatar
salass00
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 521
Joined: Sat Jun 18, 2011 3:12 pm
Location: Finland
Contact:

Re: FE and Copy/Paste crash

Post by salass00 »

xenic wrote: Then I guess that means that ContextMenu copy/paste does have a bug :-)
Yes, most likely it does.
kas1e
Beta Tester
Beta Tester
Posts: 483
Joined: Sat Jun 18, 2011 7:56 am
Contact:

Re: FE and Copy/Paste crash

Post by kas1e »

@Xenic
Btw, you probably remember that in some of the dopus5 bugreports on our repo i write "bug can be reproduced with munge only", what mean that even if without munge there is no crashes/dsi/isi, etc, but triggered when we use "munge" kernel's feature, then bug in reality is here. "munge" just help us to find it , while when we not use munge, bug just hide itself.
Post Reply