Update 3 scroll wheel no longer working

A forum for general AmigaOS 4.x support questions that are not platform-specific
sicky
Posts: 6
Joined: Sun Jul 10, 2011 8:45 pm

Update 3 scroll wheel no longer working

Post by sicky »

I have just updated my SAM460 with OS4.1 Update 3 and my scroll wheel no longer works, is anyone else having this problem?
User avatar
Rigo
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 354
Joined: Mon Jan 17, 2011 9:42 pm

Re: Update 3 scroll wheel no longer working

Post by Rigo »

Can you check with USBInspector and see which driver is assigned to your mouse.

It should be the hid driver, but it may be the bootmouse driver, which doesn't AFAIK support the scrollwheel.

Simon
User avatar
ssolie
Beta Tester
Beta Tester
Posts: 1010
Joined: Mon Dec 20, 2010 8:51 pm
Location: Canada
Contact:

Re: Update 3 scroll wheel no longer working

Post by ssolie »

Yes, the Sam460 still has an annoying habit of defaulting to the bootmouse and bootkeyboard drivers when it should not. This is a known problem and nothing new.
ExecSG Team Lead
Godfather
Posts: 9
Joined: Sun Jun 26, 2011 12:24 am

Re: Update 3 scroll wheel no longer working

Post by Godfather »

Dear, same problem here (Sam440ep - 667). I use a USB HAMA 2.0 HUB. if i use a USB 1.0 HUB everything work well !

Kind Regards

Godfather
sicky
Posts: 6
Joined: Sun Jul 10, 2011 8:45 pm

Re: Update 3 scroll wheel no longer working

Post by sicky »

@Rigo

Hi Simon

I checked and it says driver is bootmouse.usbfd

How do I change it to HID?
User avatar
Rigo
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 354
Joined: Mon Jan 17, 2011 9:42 pm

Re: Update 3 scroll wheel no longer working

Post by Rigo »

@sicky

Unfortunately, you can't. It should be done automatically. But at least thats why your scrollwheel doesn't work.

Simon
User avatar
ssolie
Beta Tester
Beta Tester
Posts: 1010
Joined: Mon Dec 20, 2010 8:51 pm
Location: Canada
Contact:

Re: Update 3 scroll wheel no longer working

Post by ssolie »

sicky wrote:How do I change it to HID?
Hit the reset button on your case. That always seems to work for me.
ExecSG Team Lead
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 1445
Joined: Wed Mar 09, 2011 1:36 pm
Location: Sydney, Australia

Re: Update 3 scroll wheel no longer working

Post by tonyw »

The 460 User Manual says to always turn the machine off for a few seconds.

I've found that if I do that religiously, I never have a problem with the bootmouse driver getting in the way.
cheers
tony
mrdarek
Posts: 12
Joined: Tue Aug 30, 2011 4:44 pm

Re: Update 3 scroll wheel no longer working

Post by mrdarek »

ssolie wrote:Yes, the Sam460 still has an annoying habit of defaulting to the bootmouse and bootkeyboard drivers when it should not. This is a known problem and nothing new.
This is new problem - not "known". In update2 I have no problem with scroll wheel!!!
Please repair this issue fast - for some software like my "ami-lineapolis" scroll mouse button is crucial for using this software. I feel like some other destroying my work, and this was work for the glory of Amiga, and now is destroyed...
Well, I'm not angry, I just ask nicely abour high rank for this issue in repairing queue...
-------------------------
Good news! I found that if mouse plugged in one of internal USB port has scroll button active!!! Tips: Don't use rear USB ports for mouse if you want scroll mouse button work!!!
-------------------------
Bad news: after restart port changed - scroll button not work. After some desperatly plug and unplug mouse I found different working port...Every time I need search for working USB port???
hardware: sam460ex, Scythe KAMA 2 Card Reader, Sil 3114, Radeon HD 4650
interest: ami-lineapolis developer
User avatar
ssolie
Beta Tester
Beta Tester
Posts: 1010
Joined: Mon Dec 20, 2010 8:51 pm
Location: Canada
Contact:

Re: Update 3 scroll wheel no longer working

Post by ssolie »

mrdarek wrote:
ssolie wrote:Yes, the Sam460 still has an annoying habit of defaulting to the bootmouse and bootkeyboard drivers when it should not. This is a known problem and nothing new.
This is new problem - not "known". In update2 I have no problem with scroll wheel!!!
I suggest you try the workaround as described in your manual and discussed above.
ExecSG Team Lead
Post Reply