Update 3 IBrowse & YAM not working

A forum for general AmigaOS 4.x support questions that are not platform-specific
User avatar
RobMattin
Posts: 107
Joined: Mon Dec 20, 2010 10:23 pm

Re: Update 3 IBrowse & YAM not working

Post by RobMattin »

danwood wrote:Update:

I restored the MUI drawer from my Update 2 CD and everything is working now, IBrowse, Yam, MUI app, Sabremsn etc. so it's definitely a MUI issue with some configs. Hope we can get to the bottom of this.
Have you tried installing update 3 again to see if the problems persist.

danwood
Posts: 16
Joined: Mon Aug 29, 2011 6:37 pm

Re: Update 3 IBrowse & YAM not working

Post by danwood »

davebraco wrote:I would suggest to remove third parties mui libs found mui:Libs/mui/ and check which ones are really needed by iBrowse and YAM. It's also important to be sure that up to date version of these libs are use.
Yeah I've tried totally wiping out the MUI drawer, copying from my 4.1.2 CD-ROM, then running updates from update 3, still results in heaps of crashes.

Next I will try a fresh hard disk and fresh install to see if that remedies the problem.

hotrod
Posts: 53
Joined: Tue Jun 21, 2011 10:17 pm

Re: Update 3 IBrowse & YAM not working

Post by hotrod »

I don't know if this should be its own threat but it's MUI related. If I use Wookiechat and click the different buttons at the bottom for channels/people the list with name flickers on the left side for a brief moment. It doesn't cause a crash or anything, it just looks a little weird.

xenic
Posts: 1164
Joined: Sun Jun 19, 2011 12:06 am

Re: Update 3 IBrowse & YAM not working

Post by xenic »

IBrowse, YAM, Jabberwocky and other MUI apps appear to be working on my SAM Flex 800 after the update.
AmigaOne X1000 with 2GB memory - OS4.1 FE

User avatar
Mrodfr
Posts: 29
Joined: Wed Jul 06, 2011 5:29 pm

Re: Update 3 IBrowse & YAM not working

Post by Mrodfr »

Hello,

No problems with MUI and Ibrowse, YAM, SabreMSN,... with my SAM440ep.

User avatar
tboeckel
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 68
Joined: Mon Jun 20, 2011 8:56 am
Contact:

Re: Update 3 IBrowse & YAM not working

Post by tboeckel »

You definitely have an ancient version of MUI running on your system.
Look at the crashlog. These libraries don't exist anymore in the current MUI release:
- muiconfig.library V20.336
- muigfx.library V20.520
- muirexx.library V20.268
- muiwinborder.class V20.260
- ... lots of other classes and libraries

But the most important evidence for an old installation is this:
muimaster.library V20.2290

This stems from the MUI version released together with AmigaOS 4.1 (without any update).
The version of muimaster.library released with AmigaOS 4.1 update #3 is 20.2328 dated August 22nd 2011.

So please be sure to install MUI 3.9 in the correct place and not just anywhere. You are definitely mixing up versions here.

User avatar
vulture
Beta Tester
Beta Tester
Posts: 10
Joined: Sat Jun 18, 2011 10:07 am

Re: Update 3 IBrowse & YAM not working

Post by vulture »

Both work fine here on both my peg2 and A1200. I've versioned all my mui libs and they're the latest so, that must not be it.
Peg2 2b5, G4@1.266ghz, 2gb RAM, Radeon 9200 128mb, Audigy 2 ZS, Nec USB 2.0, Sata sil3512
A1200 BPPC 603e@333mhz , 256mb RAM, BVision, Subway USB, Fasata MK1, 3com pcmcia ethernet
A1200 BPPC 603e@333mhz , 256mb RAM , Mediator 1200TX, Voodoo 3 3500, Radeon 9200 256mb, Spider USB2.0, Realtek 8029, Soundblaster Live!, Fastata MK3, 3com pcmcia ethernet

User avatar
vox
Posts: 173
Joined: Thu Jun 23, 2011 2:19 pm
Location: Belgrade Country:Serbia
Contact:

Re: Update 3 IBrowse & YAM not working

Post by vox »

danwood wrote:YAM Crashlog: http://pastebin.com/V7FyJ4vq

IBrowse Crashlog: http://pastebin.com/axbKVJWF

AmigaOne XE with 1 gig RAM.
Seems improved MUI has brought some problems after all ...

This was posted at AW.net

Regarding MUI problems:

The new MUI is incompatible with some older settings and will cause crashes and other funny artifacts, like help bubbles looking wierd perhaps.

If you have a problem with an app, delete its MUI settings. At the moment I thing it is the .config part, not the .prefs part in ENVARC:mui/ (and ENV:mui/ too unless you reboot). Then try again.
------------------------------------------
Future MOS user pon SAM460ex
https://www.facebook.com/rasvoja
https://www.youtube.com/user/rasvoja
http://socdevelopment.wordpress.com/

User avatar
djrikki
Posts: 138
Joined: Fri Jun 17, 2011 10:21 pm
Location: Grimsby, Lincolnshire, UK
Contact:

Re: Update 3 IBrowse & YAM not working

Post by djrikki »

I have no problems with MUI applications, probably because I never configured the blasted thing. :lol:

However, I did do the following that may help if your still experiencing problems. Open SimpleMail, go to the Project Menu and select About MUI. In the About menu IF it says something along the lines of 'These files are no longer required and can be safely deleted.' and lists each one in - it also gives you the option to delete them all by clicking ona button. So I did.

User avatar
Hypex
Beta Tester
Beta Tester
Posts: 403
Joined: Mon Dec 20, 2010 2:23 pm
Location: Vic. Australia.

Re: Update 3 IBrowse & YAM not working

Post by Hypex »

tboeckel wrote:You definitely have an ancient version of MUI running on your system.
I agree. As noted in the AW.net thread there is a lot of 68K MUI files running and ones with weird names! :-P

Post Reply