Issues installing TimberwolfRC3 OS4.1U6 font cache

A forum for general AmigaOS 4.x support questions that are not platform-specific
Post Reply
amiganut
Posts: 10
Joined: Tue Dec 10, 2013 4:38 am

Issues installing TimberwolfRC3 OS4.1U6 font cache

Post by amiganut »

I performed a fresh install on my AmigaOne XE/G4 to OS4.1U1 then 2- :cry: upgrade 6 and ran several autoupdates. I ran into a problem setting up the font cache. Docs say if you don't do this you will have very slow performance which I am experiencing. Like Timberwolf taking 3 minutes to load.

Timberwolf docs say to:

Workbench:> cd fonts:fontconfig/fontconfig_cache
Workbench:Fonts/fontconfig/fontconfig_cache> delete #?
Workbench:Fonts/fontconfig/fontconfig_cache> fc-cache -s -f

I was able to delete the cache but I try to recreate the cache, it errors out. So I did a fc-cache -s -f -v to see what it was doing and it errors out on Tru Type Fonts.

Since this is a fresh install and upgraded to upgrade 6, I am wondering what can be the issue here.
chris
Posts: 552
Joined: Sat Jun 18, 2011 11:05 am
Contact:

Re: Issues installing TimberwolfRC3 OS4.1U6 font cache

Post by chris »

Try fc-cache -r
amiganut
Posts: 10
Joined: Tue Dec 10, 2013 4:38 am

Re: Issues installing TimberwolfRC3 OS4.1U6 font cache

Post by amiganut »

I get the same result. With fc-cache -r -v

Fonts:_TrueType: caching, new chche contents: 31 fonts, 0 dir
Fonts:_TrueType: failed to write cache
fonts:fontconfig/ontconfig_cache: cleaning cache directory
fc-cache: failed

It bombs on the _TrueType.
amiganut
Posts: 10
Joined: Tue Dec 10, 2013 4:38 am

Re: Issues installing TimberwolfRC3 OS4.1U6 font cache

Post by amiganut »

Update:

When I do a fc-cache -V I get

fontconfig 2.5.0 Is this the correct version?
Post Reply